summaryrefslogtreecommitdiffstats
path: root/recipes/libvorbis
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-11-25 19:13:33 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-11-30 02:00:13 +0100
commitf519bc2e363cc4ccb8acf5f1a7faa335e9e07d1d (patch)
tree65869d3bdd1e185e691c31e91d18b4eb794c3071 /recipes/libvorbis
parentce34c40212d02a1ca5d9d74daad21cca67a5dd37 (diff)
downloadopenembedded-f519bc2e363cc4ccb8acf5f1a7faa335e9e07d1d.tar.gz
libvorbis: update to version 1.2.3
* update to newer version because of security issues * switch to INC_PR and use the new autotools feature * for version 1.2.3 disable EXTRA_OECONF stuff which is handled by pkgconfig * add dependency for pkgconfig to find libogg * bump PR
Diffstat (limited to 'recipes/libvorbis')
-rw-r--r--recipes/libvorbis/libvorbis-1.2.3/configure_powerpc-no-fixed-cpu.patch15
-rw-r--r--recipes/libvorbis/libvorbis.inc19
-rw-r--r--recipes/libvorbis/libvorbis_1.0.1.bb32
-rw-r--r--recipes/libvorbis/libvorbis_1.2.0.bb32
-rw-r--r--recipes/libvorbis/libvorbis_1.2.3.bb11
5 files changed, 53 insertions, 56 deletions
diff --git a/recipes/libvorbis/libvorbis-1.2.3/configure_powerpc-no-fixed-cpu.patch b/recipes/libvorbis/libvorbis-1.2.3/configure_powerpc-no-fixed-cpu.patch
new file mode 100644
index 0000000000..06ec874eb1
--- /dev/null
+++ b/recipes/libvorbis/libvorbis-1.2.3/configure_powerpc-no-fixed-cpu.patch
@@ -0,0 +1,15 @@
+Index: libvorbis-1.2.3/configure.ac
+===================================================================
+--- libvorbis-1.2.3.orig/configure.ac 2009-11-25 13:20:46.274395527 +0100
++++ libvorbis-1.2.3/configure.ac 2009-11-25 13:21:05.136894132 +0100
+@@ -157,8 +157,8 @@
+ fi;;
+ powerpc-*-linux*)
+ DEBUG="-g -Wall -Wextra -D_REENTRANT -D__NO_MATH_INLINES"
+- CFLAGS="-O3 -Wall -Wextra -ffast-math -mfused-madd -mcpu=750 -D_REENTRANT"
+- PROFILE="-pg -g -O3 -ffast-math -mfused-madd -mcpu=750 -D_REENTRANT";;
++ CFLAGS="-O3 -Wall -Wextra -ffast-math -mfused-madd -D_REENTRANT"
++ PROFILE="-pg -g -O3 -ffast-math -mfused-madd -D_REENTRANT";;
+ *-*-linux*)
+ DEBUG="-g -Wall -Wextra -D_REENTRANT -D__NO_MATH_INLINES -fsigned-char"
+ CFLAGS="-O20 -Wall -Wextra -ffast-math -D_REENTRANT -fsigned-char"
diff --git a/recipes/libvorbis/libvorbis.inc b/recipes/libvorbis/libvorbis.inc
new file mode 100644
index 0000000000..b3a154a346
--- /dev/null
+++ b/recipes/libvorbis/libvorbis.inc
@@ -0,0 +1,19 @@
+SECTION = "libs"
+DEPENDS = "libogg"
+DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
+that is free of intellectual property restrictions. libvorbis \
+is the main vorbis codec library."
+LICENSE = "BSD"
+INC_PR = "r2"
+
+inherit autotools
+
+# vorbisfile.c reveals a problem in the gcc register spilling for the
+# thumb instruction set...
+FULL_OPTIMIZATION_thumb = "-O0"
+
+EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
+ --with-ogg-includes=${STAGING_INCDIR}"
+
+
+LEAD_SONAME = "libvorbis.so.0"
diff --git a/recipes/libvorbis/libvorbis_1.0.1.bb b/recipes/libvorbis/libvorbis_1.0.1.bb
index 8a2d17a0ad..8b95421218 100644
--- a/recipes/libvorbis/libvorbis_1.0.1.bb
+++ b/recipes/libvorbis/libvorbis_1.0.1.bb
@@ -1,32 +1,8 @@
-SECTION = "libs"
-DEPENDS = "libogg"
-DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
-that is free of intellectual property restrictions. libvorbis \
-is the main vorbis codec library."
-LICENSE = "BSD"
-PR = "r2"
-SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libvorbis-${PV}.tar.gz \
-file://m4.patch;patch=1"
-
-inherit autotools pkgconfig
+require libvorbis.inc
-# vorbisfile.c reveals a problem in the gcc register spilling for the
-# thumb instruction set...
-FULL_OPTIMIZATION_thumb = "-O0"
+PR = ""${INC_PR}.1"
-EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
- --with-ogg-includes=${STAGING_INCDIR}"
-
-do_stage () {
- oe_libinstall -a -so -C lib libvorbis ${STAGING_LIBDIR}
- oe_libinstall -a -so -C lib libvorbisfile ${STAGING_LIBDIR}
- oe_libinstall -a -so -C lib libvorbisenc ${STAGING_LIBDIR}
+SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libvorbis-${PV}.tar.gz \
+file://m4.patch;patch=1"
- install -d ${STAGING_INCDIR}/vorbis
- install -m 0644 include/vorbis/vorbisenc.h \
- include/vorbis/vorbisfile.h \
- include/vorbis/codec.h ${STAGING_INCDIR}/vorbis/
- install -d ${STAGING_DATADIR}/aclocal
- install -m 0644 vorbis.m4 ${STAGING_DATADIR}/aclocal/
-}
diff --git a/recipes/libvorbis/libvorbis_1.2.0.bb b/recipes/libvorbis/libvorbis_1.2.0.bb
index cc7f00cceb..767a38a4de 100644
--- a/recipes/libvorbis/libvorbis_1.2.0.bb
+++ b/recipes/libvorbis/libvorbis_1.2.0.bb
@@ -1,10 +1,7 @@
-SECTION = "libs"
-DEPENDS = "libogg"
-DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
-that is free of intellectual property restrictions. libvorbis \
-is the main vorbis codec library."
-LICENSE = "BSD"
-PR = "2"
+
+require libvorbis.inc
+
+PR = "${INC_PR}.1"
SRC_URI = "http://downloads.xiph.org/releases/vorbis/libvorbis-${PV}.tar.gz \
file://configure_powerpc-no-fixed-cpu.patch;patch=1 \
@@ -13,24 +10,3 @@ SRC_URI = "http://downloads.xiph.org/releases/vorbis/libvorbis-${PV}.tar.gz \
file://r14602-CVE-2008-1423.patch;patch=1 \
"
-inherit autotools pkgconfig
-
-# vorbisfile.c reveals a problem in the gcc register spilling for the
-# thumb instruction set...
-FULL_OPTIMIZATION_thumb = "-O0"
-
-EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
- --with-ogg-includes=${STAGING_INCDIR}"
-
-do_stage () {
- oe_libinstall -a -so -C lib libvorbis ${STAGING_LIBDIR}
- oe_libinstall -a -so -C lib libvorbisfile ${STAGING_LIBDIR}
- oe_libinstall -a -so -C lib libvorbisenc ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/vorbis
- install -m 0644 include/vorbis/vorbisenc.h \
- include/vorbis/vorbisfile.h \
- include/vorbis/codec.h ${STAGING_INCDIR}/vorbis/
- install -d ${STAGING_DATADIR}/aclocal
- install -m 0644 vorbis.m4 ${STAGING_DATADIR}/aclocal/
-}
diff --git a/recipes/libvorbis/libvorbis_1.2.3.bb b/recipes/libvorbis/libvorbis_1.2.3.bb
new file mode 100644
index 0000000000..1173809d48
--- /dev/null
+++ b/recipes/libvorbis/libvorbis_1.2.3.bb
@@ -0,0 +1,11 @@
+
+require libvorbis.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI = "http://downloads.xiph.org/releases/vorbis/libvorbis-${PV}.tar.gz \
+ file://configure_powerpc-no-fixed-cpu.patch;patch=1 \
+ "
+
+# override should be handeld by pkgconfig now
+EXTRA_OECONF = ""