aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxmlccwrap/files
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-09-29 10:36:33 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-06 15:33:33 -0700
commitc1f4a7207b740b3b033a1dc4ae0da2bcfadbfa4e (patch)
tree0d0518375ea84992a784d9653d36f76883fee99d /recipes/libxmlccwrap/files
parent911d01afae01e22ac958065877ee310e47cfddfd (diff)
downloadopenembedded-c1f4a7207b740b3b033a1dc4ae0da2bcfadbfa4e.tar.gz
libxmlccwrap-0.0.12: initial recipe
Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/libxmlccwrap/files')
-rw-r--r--recipes/libxmlccwrap/files/disable_libxslt.patch96
-rw-r--r--recipes/libxmlccwrap/files/dont_build_unneeded.patch6
-rw-r--r--recipes/libxmlccwrap/files/fix_assignment_operator.patch10
3 files changed, 112 insertions, 0 deletions
diff --git a/recipes/libxmlccwrap/files/disable_libxslt.patch b/recipes/libxmlccwrap/files/disable_libxslt.patch
new file mode 100644
index 0000000000..b178641247
--- /dev/null
+++ b/recipes/libxmlccwrap/files/disable_libxslt.patch
@@ -0,0 +1,96 @@
+diff -Naur libxmlccwrap-0.0.12_org/configure.ac libxmlccwrap-0.0.12/configure.ac
+--- libxmlccwrap-0.0.12_org/configure.ac 2005-07-28 21:27:58.000000000 +0200
++++ libxmlccwrap-0.0.12/configure.ac 2007-10-29 15:36:49.000000000 +0100
+@@ -15,7 +15,7 @@
+ AM_PROG_LIBTOOL
+
+ AC_CHECK_LIB(xml2,main)
+-AC_CHECK_LIB(xslt,main)
++#AC_CHECK_LIB(xslt,main)
+
+ AC_OUTPUT([Makefile \
+ xmlccwrap/Makefile \
+diff -Naur libxmlccwrap-0.0.12_org/xmlccwrap/xmlccwrap.cc libxmlccwrap-0.0.12/xmlccwrap/xmlccwrap.cc
+--- libxmlccwrap-0.0.12_org/xmlccwrap/xmlccwrap.cc 2003-12-18 23:48:08.000000000 +0100
++++ libxmlccwrap-0.0.12/xmlccwrap/xmlccwrap.cc 2007-10-24 22:54:15.000000000 +0200
+@@ -23,8 +23,10 @@
+ #include <libxml/tree.h>
+ #include <libxml/HTMLparser.h>
+ #include <libxml/encoding.h>
++/*
+ #include <libxslt/xsltutils.h>
+ #include <libxslt/transform.h>
++*/
+ #include "xmlccwrap.h"
+ #include "libxmlexport.h"
+
+@@ -47,7 +49,7 @@
+ Element *readnode(xmlNodePtr);
+ void writenode(xmlDocPtr, Element *, xmlNodePtr, int = 0);
+
+-
++/*
+ XSLTTree::XSLTTree()
+ {
+ xsltP = 0;
+@@ -83,7 +85,7 @@
+ {
+ return xsltP;
+ }
+-
++*/
+
+ XMLTree::XMLTree() : _filename(), _root(), _compression(0)
+ { }
+@@ -380,7 +382,7 @@
+ return retval;
+ }
+
+-
++/*
+ bool XMLTree::xslt(const XSLTTree & xsltTree, const std::string & outputfile, ParameterMap & parameterMap)
+ {
+ bool ret = false;
+@@ -425,7 +427,7 @@
+ ParameterMap parameterMap;
+ return xslt(xsltTree, outputfile, parameterMap);
+ }
+-
++*/
+
+ const std::string & XMLTree::getErrorString()
+ {
+diff -Naur libxmlccwrap-0.0.12_org/xmlccwrap/xmlccwrap.h libxmlccwrap-0.0.12/xmlccwrap/xmlccwrap.h
+--- libxmlccwrap-0.0.12_org/xmlccwrap/xmlccwrap.h 2003-12-18 23:42:37.000000000 +0100
++++ libxmlccwrap-0.0.12/xmlccwrap/xmlccwrap.h 2007-10-24 22:54:15.000000000 +0200
+@@ -43,7 +41,7 @@
+ typedef std::multimap<std::string, std::string> ParameterMap;
+ typedef ParameterMap::value_type ValuePair;
+
+-
++/*
+ class XSLTTree
+ {
+ private:
+@@ -60,7 +58,7 @@
+ bool read(const std::string &fn);
+ const void * exportxsltStylesheetPtr() const;
+ };
+-
++*/
+
+ class XMLTree
+ {
+@@ -102,10 +100,10 @@
+ bool write(const std::string &fn);
+ const std::string & writeBuffer() const;
+
+-
++/*
+ bool xslt(const XSLTTree & xsltTree, const std::string & outputfile, ParameterMap & parameterMap);
+ bool xslt(const XSLTTree & xsltTree, const std::string & outputfile);
+-
++*/
+ const std::string & getErrorString();
+ };
+
diff --git a/recipes/libxmlccwrap/files/dont_build_unneeded.patch b/recipes/libxmlccwrap/files/dont_build_unneeded.patch
new file mode 100644
index 0000000000..69eaa15e17
--- /dev/null
+++ b/recipes/libxmlccwrap/files/dont_build_unneeded.patch
@@ -0,0 +1,6 @@
+diff -Naur libxmlccwrap-0.0.12_org/Makefile.am libxmlccwrap-0.0.12/Makefile.am
+--- libxmlccwrap-0.0.12_org/Makefile.am 2002-12-11 23:18:41.000000000 +0100
++++ libxmlccwrap-0.0.12/Makefile.am 2007-10-29 15:35:11.000000000 +0100
+@@ -1 +1 @@
+-SUBDIRS = xmlccwrap html testlib
++SUBDIRS = xmlccwrap
diff --git a/recipes/libxmlccwrap/files/fix_assignment_operator.patch b/recipes/libxmlccwrap/files/fix_assignment_operator.patch
new file mode 100644
index 0000000000..1d645901c0
--- /dev/null
+++ b/recipes/libxmlccwrap/files/fix_assignment_operator.patch
@@ -0,0 +1,10 @@
+--- libxmlccwrap-0.0.12_org/xmlccwrap/xmlccwrap.cc 2003-12-18 23:48:08.000000000 +0100
++++ libxmlccwrap-0.0.12/xmlccwrap/xmlccwrap.cc 2007-10-24 22:54:15.000000000 +0200
+@@ -498,6 +500,7 @@
+ for (ElementIterator curnode = nodes.begin(); curnode != nodes.end(); curnode++)
+ add
+ (**curnode);
++ return *this;
+ }
+
+