aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxsettings-client
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libxsettings-client
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libxsettings-client')
-rw-r--r--recipes/libxsettings-client/files/make_pkgconfig_x11.patch21
-rw-r--r--recipes/libxsettings-client/files/no-host-includes.patch13
-rw-r--r--recipes/libxsettings-client/libxsettings-client-0.16/Makefile-am.patch11
-rw-r--r--recipes/libxsettings-client/libxsettings-client.inc22
-rw-r--r--recipes/libxsettings-client/libxsettings-client_0.12.bb25
-rw-r--r--recipes/libxsettings-client/libxsettings-client_0.13.bb22
-rw-r--r--recipes/libxsettings-client/libxsettings-client_0.14.bb5
-rw-r--r--recipes/libxsettings-client/libxsettings-client_0.16.bb6
-rw-r--r--recipes/libxsettings-client/libxsettings-client_0.17.bb6
-rw-r--r--recipes/libxsettings-client/libxsettings-client_svn.bb10
10 files changed, 141 insertions, 0 deletions
diff --git a/recipes/libxsettings-client/files/make_pkgconfig_x11.patch b/recipes/libxsettings-client/files/make_pkgconfig_x11.patch
new file mode 100644
index 0000000000..3a386672d2
--- /dev/null
+++ b/recipes/libxsettings-client/files/make_pkgconfig_x11.patch
@@ -0,0 +1,21 @@
+--- libxsettings-client0-0.12/Makefile.old 2004-04-20 16:48:18.000000000 +1000
++++ libxsettings-client0-0.12/Makefile 2004-04-20 16:58:07.000000000 +1000
+@@ -20,6 +20,9 @@
+ CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
+ CPPFLAGS += -I../libxsettings
+
++CFLAGS += `pkg-config --cflags x11`
++LDFLAGS += `pkg-config --ldflags x11`
++
+ XSETTINGS_OBJS = $(patsubst %,%.os,$(XSETTINGS_MEMBERS))
+ DEPS = $(patsubst %,%.d,$(MEMBERS) $(XSETTINGS_MEMBERS))
+ SOURCES = $(patsubst %,%.c,$(MEMBERS) $(XSETTINGS_MEMBERS))
+@@ -39,7 +42,7 @@
+ ln -sf $^ $@
+
+ $(LIBXSETTINGS_SO): $(XSETTINGS_OBJS)
+- $(CC) -o $@ $^ -shared -Wl,-soname -Wl,$(LIBXSETTINGS_SO) -nostartfiles -L/usr/X11R6/lib -lX11 -L../libxsettings -lXsettings
++ $(CC) -o $@ $^ -shared -Wl,-soname -Wl,$(LIBXSETTINGS_SO) -nostartfiles $(LDFLAGS) -L../libxsettings -lXsettings
+
+ install-program: $(LIBXSETTINGS_SO)
+ install -d $(DESTDIR)$(PREFIX)/lib
diff --git a/recipes/libxsettings-client/files/no-host-includes.patch b/recipes/libxsettings-client/files/no-host-includes.patch
new file mode 100644
index 0000000000..137c5269f1
--- /dev/null
+++ b/recipes/libxsettings-client/files/no-host-includes.patch
@@ -0,0 +1,13 @@
+Index: libxsettings-client-0.17/Makefile.am
+===================================================================
+--- libxsettings-client-0.17.orig/Makefile.am 2006-05-19 23:14:46.557360552 +0200
++++ libxsettings-client-0.17/Makefile.am 2006-05-19 23:14:56.010923392 +0200
+@@ -3,7 +3,7 @@
+ source_h = xsettings-client.h xsettings-common.h
+ source_c = xsettings-client.c xsettings-common.c
+
+-INCLUDES = -I $(includedir) $(X_CFLAGS)
++INCLUDES = $(X_CFLAGS)
+
+ libxsincludedir = $(includedir)
+
diff --git a/recipes/libxsettings-client/libxsettings-client-0.16/Makefile-am.patch b/recipes/libxsettings-client/libxsettings-client-0.16/Makefile-am.patch
new file mode 100644
index 0000000000..fb5b1dbe65
--- /dev/null
+++ b/recipes/libxsettings-client/libxsettings-client-0.16/Makefile-am.patch
@@ -0,0 +1,11 @@
+--- libxsettings-client-0.16/Makefile.am.orig 2006-01-17 16:01:21.000000000 +0000
++++ libxsettings-client-0.16/Makefile.am 2006-01-17 16:01:30.000000000 +0000
+@@ -3,7 +3,7 @@
+ source_h = xsettings-client.h xsettings-common.h
+ source_c = xsettings-client.c xsettings-common.c
+
+-INCLUDES = -I $(includedir) $(X_CFLAGS)
++INCLUDES = $(X_CFLAGS)
+
+ libxsincludedir = $(includedir)
+
diff --git a/recipes/libxsettings-client/libxsettings-client.inc b/recipes/libxsettings-client/libxsettings-client.inc
new file mode 100644
index 0000000000..bfcf1245f6
--- /dev/null
+++ b/recipes/libxsettings-client/libxsettings-client.inc
@@ -0,0 +1,22 @@
+SECTION = "gpe/libs"
+LICENSE = "BSD-X"
+PRIORITY = "optional"
+DEPENDS = "libxsettings virtual/libx11 libxt"
+# libxt is required to stop configure breaking builds by
+# including system paths to find it if it isn't present.
+
+GPE_TARBALL_SUFFIX = "bz2"
+inherit autotools pkgconfig gpe
+
+SRC_URI = "${GPE_MIRROR}/libxsettings-client-${PV}.tar.bz2 \
+"
+
+headers = "xsettings-client.h xsettings-common.h"
+do_stage () {
+ oe_libinstall -so libXsettings-client ${STAGING_LIBDIR}
+ mkdir -p ${STAGING_INCDIR}
+ for h in ${headers}; do
+ install -m 0644 ${S}/$h ${STAGING_INCDIR}/$h
+ done
+}
+
diff --git a/recipes/libxsettings-client/libxsettings-client_0.12.bb b/recipes/libxsettings-client/libxsettings-client_0.12.bb
new file mode 100644
index 0000000000..8914c3d0c4
--- /dev/null
+++ b/recipes/libxsettings-client/libxsettings-client_0.12.bb
@@ -0,0 +1,25 @@
+SECTION = "gpe/libs"
+LICENSE = "BSD-X"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libxsettings virtual/libx11"
+
+inherit pkgconfig gpe
+
+SRC_URI += "file://make_pkgconfig_x11.patch;patch=1"
+
+S = "${WORKDIR}/libxsettings-client0-0.12"
+
+headers = "xsettings-client.h"
+do_stage () {
+ oe_libinstall -so libXsettings-client ${STAGING_LIBDIR}
+ mkdir -p ${STAGING_INCDIR}
+ for h in ${headers}; do
+ install -m 0644 ${S}/$h ${STAGING_INCDIR}/$h
+ done
+}
+
+do_install () {
+ gpe_do_install
+ install -d ${D}${includedir}/
+ install xsettings-client.h ${D}${includedir}/
+}
diff --git a/recipes/libxsettings-client/libxsettings-client_0.13.bb b/recipes/libxsettings-client/libxsettings-client_0.13.bb
new file mode 100644
index 0000000000..97ebe9c7ab
--- /dev/null
+++ b/recipes/libxsettings-client/libxsettings-client_0.13.bb
@@ -0,0 +1,22 @@
+SECTION = "gpe/libs"
+LICENSE = "BSD-X"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libxsettings virtual/libx11"
+
+inherit pkgconfig gpe
+
+SRC_URI += "file://make_pkgconfig_x11.patch;patch=1"
+
+headers = "xsettings-client.h"
+do_stage () {
+ oe_libinstall -so libXsettings-client ${STAGING_LIBDIR}
+ mkdir -p ${STAGING_INCDIR}
+ for h in ${headers}; do
+ install -m 0644 ${S}/$h ${STAGING_INCDIR}/$h
+ done
+}
+
+do_install () {
+ gpe_do_install
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
+}
diff --git a/recipes/libxsettings-client/libxsettings-client_0.14.bb b/recipes/libxsettings-client/libxsettings-client_0.14.bb
new file mode 100644
index 0000000000..35a2e5ec33
--- /dev/null
+++ b/recipes/libxsettings-client/libxsettings-client_0.14.bb
@@ -0,0 +1,5 @@
+require libxsettings-client.inc
+
+PR = "r1"
+
+SRC_URI = "${GPE_MIRROR}/xsettings-client-${PV}.tar.bz2"
diff --git a/recipes/libxsettings-client/libxsettings-client_0.16.bb b/recipes/libxsettings-client/libxsettings-client_0.16.bb
new file mode 100644
index 0000000000..c7904ba088
--- /dev/null
+++ b/recipes/libxsettings-client/libxsettings-client_0.16.bb
@@ -0,0 +1,6 @@
+require libxsettings-client.inc
+
+SRC_URI += " file://Makefile-am.patch;patch=1"
+
+
+PR ="r2"
diff --git a/recipes/libxsettings-client/libxsettings-client_0.17.bb b/recipes/libxsettings-client/libxsettings-client_0.17.bb
new file mode 100644
index 0000000000..87d65473f0
--- /dev/null
+++ b/recipes/libxsettings-client/libxsettings-client_0.17.bb
@@ -0,0 +1,6 @@
+require libxsettings-client.inc
+
+DEPENDS += "gtk-doc"
+PR ="r2"
+
+SRC_URI += "file://no-host-includes.patch;patch=1 "
diff --git a/recipes/libxsettings-client/libxsettings-client_svn.bb b/recipes/libxsettings-client/libxsettings-client_svn.bb
new file mode 100644
index 0000000000..c9705b5673
--- /dev/null
+++ b/recipes/libxsettings-client/libxsettings-client_svn.bb
@@ -0,0 +1,10 @@
+require libxsettings-client.inc
+
+DEPENDS += "gtk-doc"
+PV = "0.17+svn${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "${GPE_SVN}"
+S = "${WORKDIR}/${PN}"
+
+DEFAULT_PREFERENCE = "-1"