aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/links/links-x11_2.0+2.1pre30.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/links/links-x11_2.0+2.1pre30.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/links/links-x11_2.0+2.1pre30.bb')
-rw-r--r--recipes/links/links-x11_2.0+2.1pre30.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/links/links-x11_2.0+2.1pre30.bb b/recipes/links/links-x11_2.0+2.1pre30.bb
new file mode 100644
index 0000000000..9ee70d9ad4
--- /dev/null
+++ b/recipes/links/links-x11_2.0+2.1pre30.bb
@@ -0,0 +1,22 @@
+require links.inc
+
+DEPENDS += "virtual/libx11"
+RCONFLICTS = "links"
+PR = "r1"
+
+SRC_URI += " file://links2.desktop \
+ http://www.xora.org.uk/oe/links2.png"
+
+EXTRA_OECONF = "--enable-javascript --with-libfl --enable-graphics \
+ --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
+ --without-libtiff --without-svgalib --without-fb \
+ --without-directfb --without-pmshell --without-atheos \
+ --with-x --without-gpm --without-sdl"
+
+do_install_append() {
+ install -d ${D}/${datadir}/applications
+ install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps
+}
+