aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-atm
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux-atm
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux-atm')
-rw-r--r--recipes/linux-atm/linux-atm-2.4.1/gcc-3.4-fix54
-rw-r--r--recipes/linux-atm/linux-atm-2.4.1/qgen-cross28
-rw-r--r--recipes/linux-atm/linux-atm_2.4.1.bb49
3 files changed, 131 insertions, 0 deletions
diff --git a/recipes/linux-atm/linux-atm-2.4.1/gcc-3.4-fix b/recipes/linux-atm/linux-atm-2.4.1/gcc-3.4-fix
new file mode 100644
index 0000000000..dcd1b9e8b5
--- /dev/null
+++ b/recipes/linux-atm/linux-atm-2.4.1/gcc-3.4-fix
@@ -0,0 +1,54 @@
+patches to make code compile on gcc 3.4+
+
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- linux-atm-2.4.1/src/lib/sapequal.c~gcc-3.4-fix
++++ linux-atm-2.4.1/src/lib/sapequal.c
+@@ -64,7 +64,6 @@
+ CHECK(l2.itu.mode,1);
+ CHECK(l2.itu.window,a.l2.itu.window > b.l2.itu.window);
+ break;
+- default:
+ }
+ switch (a.l3_proto) {
+ case ATM_L3_X25:
+@@ -82,7 +81,7 @@
+ case ATM_L3_USER:
+ if (a.l3.user != b.l3.user) return 0;
+ break;
+- default:
++
+ }
+ return 1;
+ }
+--- linux-atm-2.4.1/src/sigd/proto.c~gcc-3.4-fix
++++ linux-atm-2.4.1/src/sigd/proto.c
+@@ -258,7 +258,6 @@
+ q_write(&dsc,QF_timer,buf,3);
+ break;
+ }
+- default:
+ }
+ va_end(ap);
+ if ((size = q_close(&dsc)) >= 0) to_signaling(sock->sig,q_buffer,size);
+@@ -287,7 +286,6 @@
+ q_write(&dsc,QF_ie_id6,&ie,1);
+ }
+ break;
+- default:
+ }
+ va_end(ap);
+ }
+--- linux-atm-2.4.1/src/maint/enitune.c~gcc-3.4-fix
++++ linux-atm-2.4.1/src/maint/enitune.c
+@@ -43,7 +43,6 @@
+ mult.rx = strtol(optarg,&end,0);
+ if (*end || mult.rx <= 100) usage(name);
+ break;
+- default:
+ }
+ if (argc != optind+1) usage(name);
+ sioc.number = strtol(argv[optind],&end,0);
diff --git a/recipes/linux-atm/linux-atm-2.4.1/qgen-cross b/recipes/linux-atm/linux-atm-2.4.1/qgen-cross
new file mode 100644
index 0000000000..f81ab8e843
--- /dev/null
+++ b/recipes/linux-atm/linux-atm-2.4.1/qgen-cross
@@ -0,0 +1,28 @@
+fix qgen makefile so we can build q.out.o and q.dump.o seperatly to the tools that need to be compiled for build architecture
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- linux-atm-2.4.1/src/qgen/Makefile.am~qgen-cross
++++ linux-atm-2.4.1/src/qgen/Makefile.am
+@@ -1,4 +1,5 @@
+ noinst_PROGRAMS = qgen q.dump # q40.out.o
++noinst_LIBRARIES = libqdump.a
+ check_PROGRAMS = q.test
+
+ qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
+@@ -7,10 +8,9 @@
+
+ q_dump_SOURCES = common.c
+ q_dump_LDADD = qd.dump.standalone.o
+-# FIXME: paulsch: We don't really depend on qd.dump.o or q.out.o here, but this
+-# trick will get it built with only a minor glitch in the dependency checking
+-# for q.dump.
+-q_dump_DEPENDENCIES = $(q_dump_LDADD) qd.dump.o q.out.o
++q_dump_DEPENDENCIES = $(q_dump_LDADD)
++libqdump_a_SOURCES =
++libqdump_a_DEPENDENCIES = qd.dump.o q.out.o
+ EXTRA_q_dump_SOURCES = op.h uni.h qlib.c qlib.h
+
+ q_test_SOURCES = qtest.c uni.h
diff --git a/recipes/linux-atm/linux-atm_2.4.1.bb b/recipes/linux-atm/linux-atm_2.4.1.bb
new file mode 100644
index 0000000000..2643c742d5
--- /dev/null
+++ b/recipes/linux-atm/linux-atm_2.4.1.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "Drivers and tools to support ATM networking under Linux"
+HOMEPAGE = "http://linux-atm.sourceforge.net/"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/kernel"
+PR = "r1"
+LICENSE = "GPL LGPL"
+
+SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/linux-atm/linux-atm-${PV}.tar.gz \
+ file://gcc-3.4-fix;patch=1 \
+ file://qgen-cross;patch=1"
+S = "${WORKDIR}/linux-atm-${PV}"
+
+inherit autotools pkgconfig flow-lossage
+
+
+headers_include="atmd.h atm.h atmsap.h"
+headers_arpd="atmarp.h atmarpd.h"
+
+binarys_sbin="maint/atmaddr maint/atmloop lane/bus ilmid/ilmid mpoad/mpcd arpd/atmarp sigd/atmsigd maint/enitune lane/lecs led/zeppelin arpd/atmarpd maint/atmtcp maint/esi lane/les maint/zntune"
+binarys_bin="test/aread maint/atmdiag maint/atmdump test/awrite maint/saaldump maint/sonetdiag test/ttcp_atm"
+
+
+do_compile_prepend() {
+ oe_runmake -C ${S}/src/qgen AR='${BUILD_AR}' CPP='${BUILD_CPP}' CC='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' DEFS='-I${S}/src -I. -I../.. -DHAVE_CONFIG_H' CPPFLAGS='${BUILD_CPPFLAGS}' LD='${BUILD_LD}' LDFLAGS='${BUILD_LDFLAGS}' qgen q.dump
+ oe_runmake -C ${S}/src/qgen DEFS='-I${S}/src -I. -I../.. -DHAVE_CONFIG_H' all
+}
+
+do_stage () {
+ oe_libinstall -so -C src/lib libatm ${STAGING_LIBDIR}
+
+ for i in ${headers_include}; do
+ install -m 0644 src/include/$i ${STAGING_INCDIR}/$i
+ done
+
+ for i in ${headers_arpd}; do
+ install -m 0644 src/arpd/$i ${STAGING_INCDIR}/$i
+ done
+
+ for i in ${binarys_sbin}; do
+ install -m 0755 src/$i ${STAGING_BINDIR}/`basename $i`
+ done
+
+ for i in ${binarys_bin}; do
+ install -m 0755 src/$i ${STAGING_BINDIR}/`basename $i`
+ done
+}
+
+