aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-ha/cluster-glue
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-09-30 23:52:00 -0700
committerKhem Raj <raj.khem@gmail.com>2010-09-30 23:52:00 -0700
commitd1b2d92a9246104f38b1ef87d3aca014524cde72 (patch)
tree0bfd53d2c007d263f55827168c604cd28d672cd7 /recipes/linux-ha/cluster-glue
parent1270911d790bb2e2399cdd5a5f2617aa222cea25 (diff)
downloadopenembedded-d1b2d92a9246104f38b1ef87d3aca014524cde72.tar.gz
cluster-glue_1.0.5.bb: Fix build warnings found with gcc 4.5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/linux-ha/cluster-glue')
-rw-r--r--recipes/linux-ha/cluster-glue/fix-const-cast.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/linux-ha/cluster-glue/fix-const-cast.patch b/recipes/linux-ha/cluster-glue/fix-const-cast.patch
new file mode 100644
index 0000000000..6532caa100
--- /dev/null
+++ b/recipes/linux-ha/cluster-glue/fix-const-cast.patch
@@ -0,0 +1,27 @@
+This patch gets rid of new warning introduced with gcc 4.5
+Warning is explained here
+http://gcc.gnu.org/viewcvs/trunk/gcc/doc/invoke.texi?r1=148037&r2=148053&diff_format=h
+
+
+Index: Reusable-Cluster-Components-glue-1.0.5/lib/plugins/stonith/apcsmart.c
+===================================================================
+--- Reusable-Cluster-Components-glue-1.0.5.orig/lib/plugins/stonith/apcsmart.c
++++ Reusable-Cluster-Components-glue-1.0.5/lib/plugins/stonith/apcsmart.c
+@@ -708,7 +708,6 @@ apcsmart_status(StonithPlugin * s)
+ /*
+ * return the list of hosts configured for this device
+ */
+-
+ static char **
+ apcsmart_hostlist(StonithPlugin * s)
+ {
+@@ -719,7 +718,8 @@ apcsmart_hostlist(StonithPlugin * s)
+ }
+ ERRIFNOTCONFIGED(s,NULL);
+
+- return OurImports->CopyHostList((const char **)ad->hostlist);
++/* return OurImports->CopyHostList((const char **)(ad->hostlist));*/
++ return OurImports->CopyHostList((__extension__(union {char ** a; const char** b;})(ad->hostlist)).b);
+ }
+
+ static gboolean