aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-hotplug/linux-hotplug_20040329.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux-hotplug/linux-hotplug_20040329.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux-hotplug/linux-hotplug_20040329.bb')
-rw-r--r--recipes/linux-hotplug/linux-hotplug_20040329.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes/linux-hotplug/linux-hotplug_20040329.bb b/recipes/linux-hotplug/linux-hotplug_20040329.bb
new file mode 100644
index 0000000000..80d6eca339
--- /dev/null
+++ b/recipes/linux-hotplug/linux-hotplug_20040329.bb
@@ -0,0 +1,50 @@
+SECTION = "base"
+DESCRIPTION = "This package contains the scripts necessary \
+for hotplug Linux support, and lets you plug in new devices \
+and use them immediately."
+LICENSE = "GPL"
+RPROVIDES_${PN} = "hotplug"
+RCONFLICTS_${PN} = "hotplug"
+RREPLACES_${PN} = "hotplug"
+PR = "r1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/hotplug-2004_03_29.tar.gz \
+ file://busybox.patch;patch=1 \
+ file://fix-net.agent \
+ file://update-usb.usermap \
+ file://logcheck-ignore \
+ file://sleeve.agent file://sleeve.rc file://mmc.agent \
+ file://usbd.agent"
+S = "${WORKDIR}/hotplug-2004_03_29"
+
+INITSCRIPT_NAME = "hotplug"
+INITSCRIPT_PARAMS = "start 40 S . stop 89 0 6 ."
+
+inherit update-rc.d
+
+do_compile () {
+ :
+}
+
+oldmandir := "${mandir}"
+oldsbindir := "${sbindir}"
+prefix = ""
+exec_prefix = ""
+FILES_hotplug_append = " ${oldsbindir}"
+FILES_hotplug-doc_append = " ${oldmandir}"
+
+export DEBFIX = "sed -e 's:sysconfig/usb:default/hotplug.usb:'"
+do_install () {
+ install -d ${D}${sysconfdir}/logcheck/ignore.d \
+ ${D}${oldmandir} ${D}${oldsbindir}
+ oe_runmake prefix=${D}${prefix} exec_prefix=${D}${exec_prefix} \
+ etcdir=${D}${sysconfdir} sbindir=${D}${sbindir} \
+ mandir=${D}${oldmandir} install
+ sh ${WORKDIR}/fix-net.agent ${D}
+ install -m 0755 ${WORKDIR}/update-usb.usermap ${D}${oldsbindir}/
+ install -m 0644 ${WORKDIR}/logcheck-ignore ${D}${sysconfdir}/logcheck/ignore.d/hotplug
+ install -m 0755 ${WORKDIR}/sleeve.agent ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/sleeve.rc ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/mmc.agent ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/usbd.agent ${D}${sysconfdir}/hotplug/
+}