aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-libc-headers
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-03-08 15:30:38 -0700
committerChris Larson <chris_larson@mentor.com>2010-03-08 15:30:42 -0700
commit4eb51d8d2cb8b68fe411ead09e279652d9c0a73d (patch)
treeb489aca8c23563f5676bcbc13bdbc9117bfe65a1 /recipes/linux-libc-headers
parentc77f216ab2a518229795b4ee42f76372df93fe7c (diff)
downloadopenembedded-4eb51d8d2cb8b68fe411ead09e279652d9c0a73d.tar.gz
linux-libc-headers: kill unneeded do_stage functions
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/linux-libc-headers')
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.11.1.bb10
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb10
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.18+2.6.19-rc1.bb21
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb40
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.20.bb20
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.22.bb20
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.23.bb20
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.25.bb20
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb7
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.30.bb7
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb7
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb7
12 files changed, 17 insertions, 172 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.11.1.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
index e316a2c6c1..75a6251038 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
# standard linux kernel license applies.
# since we assume GPL for linux i think we can also assume it here
INHIBIT_DEFAULT_DEPS = "1"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/linux-libc-headers-${PV}.tar.bz2 \
file://keyboard.patch;patch=1"
@@ -43,16 +43,8 @@ do_configure () {
fi
}
-do_stage () {
- install -d ${STAGING_INCDIR}
- rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm
- cp -pfLR include/linux ${STAGING_INCDIR}/
- cp -pfLR include/asm ${STAGING_INCDIR}/
-}
-
do_install() {
install -d ${D}${includedir}
cp -pfLR include/linux ${D}${includedir}/
cp -pfLR include/asm ${D}${includedir}/
}
-
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
index 0c61d2acc4..e8d59d8ecc 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
@@ -13,7 +13,7 @@ require linux-libc-headers.inc
# since we assume GPL for linux i think we can also assume it here
DEFAULT_PREFERENCE = "-1"
INHIBIT_DEFAULT_DEPS = "1"
-PR = "r5"
+PR = "r6"
SRC_URI = "http://ewi546.ewi.utwente.nl/OE/eabi/linux-libc-headers-${PV}.tar.bz2 \
file://keyboard.patch;patch=1 \
@@ -55,14 +55,6 @@ do_configure () {
fi
}
-do_stage () {
- install -d ${STAGING_INCDIR}
- rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
- cp -pfLR include/linux ${STAGING_INCDIR}/
- cp -pfLR include/asm ${STAGING_INCDIR}/
- cp -pfLR include/asm-generic ${STAGING_INCDIR}/
-}
-
do_install() {
install -d ${D}${includedir}
cp -pfLR include/linux ${D}${includedir}/
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.18+2.6.19-rc1.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.18+2.6.19-rc1.bb
index 3a6de1c72e..a07ff08740 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.18+2.6.19-rc1.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.18+2.6.19-rc1.bb
@@ -2,6 +2,7 @@ require linux-libc-headers.inc
DEFAULT_PREFERENCE = "-1"
INHIBIT_DEFAULT_DEPS = "1"
+PR = "r1"
SRC_URI = " \
${KERNELORG_MIRROR}/pub/linux/kernel/people/dwmw2/kernel-headers/snapshot/linux-kernel-headers-2.6.19-rc1.tar.bz2 \
@@ -38,23 +39,3 @@ do_install() {
cp -pfLR ${S}${includedir}/asm-${ARCH} ${D}${includedir}/asm
cp -pfLR ${S}${includedir}/asm-generic ${D}${includedir}/
}
-
-do_stage () {
- set_arch
- install -d ${STAGING_INCDIR}
- rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
- cp -pfLR ${S}${includedir}/linux ${STAGING_INCDIR}/
- cp -pfLR ${S}${includedir}/asm-${ARCH} ${STAGING_INCDIR}/asm
- cp -pfLR ${S}${includedir}/asm-generic ${STAGING_INCDIR}/
-}
-
-do_stage_append_nylon () {
- install -d ${STAGING_INCDIR}/asm/
- cp -vpPR include/asm-${ARCH}/* ${STAGING_INCDIR}/asm/
- install -d ${CROSS_DIR}/${TARGET_SYS}/include/asm/
- cp -vpPR include/asm-${ARCH}/* ${CROSS_DIR}/${TARGET_SYS}/include/asm/
- cp -vpPR include/linux/* ${STAGING_INCDIR}/linux/
- install -d ${CROSS_DIR}/${TARGET_SYS}/include/linux/
- cp -vpPR include/linux/* ${CROSS_DIR}/${TARGET_SYS}/include/linux/
-}
-
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb
index 60d621b1dc..60472165b7 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.18.bb
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r3"
+PR = "r4"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2 \
file://arm-syscall-define.patch;patch=1"
@@ -39,42 +39,14 @@ do_compile () {
do_install() {
set_arch
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=${ARCH}
-}
-
-do_install_append_arm() {
- cp include/asm-arm/procinfo.h ${D}${includedir}/asm
-}
-
-STAGE_TEMP="${WORKDIR}/temp-staging"
-
-do_stage () {
- set_arch
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}${exec_prefix} ARCH=${ARCH}
- if [ "${ARCH}" == "arm" ]; then
- cp include/asm-arm/procinfo.h ${STAGE_TEMP}${includedir}/asm
- fi
- install -d ${STAGING_INCDIR}
- rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
- cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
- # Add UTS_RELEASE to version.h. UTS_RELEASE was moved from version.h to
+ # Add UTS_RELEASE to version.h. UTS_RELEASE was moved from version.h to
# utsrelease.h in order to avoid recompiling a kernel every time a localversion
- # changed. Since the our headers are static and we're not compiling an
- # actual kernel, re-adding UTS_RELEASE does't hurt, and it allows uclibc to
+ # changed. Since the our headers are static and we're not compiling an
+ # actual kernel, re-adding UTS_RELEASE does't hurt, and it allows uclibc to
# compile with kernel headers that work with EABI on ARM
echo '#define UTS_RELEASE "2.6.18"' >> ${STAGING_INCDIR}/linux/version.h
}
-do_stage_append_nylon () {
- install -d ${STAGING_INCDIR}/asm/
- cp -vpPR include/asm-${ARCH}/* ${STAGING_INCDIR}/asm/
- install -d ${CROSS_DIR}/${TARGET_SYS}/include/asm/
- cp -vpPR include/asm-${ARCH}/* ${CROSS_DIR}/${TARGET_SYS}/include/asm/
- cp -vpPR include/linux/* ${STAGING_INCDIR}/linux/
- install -d ${CROSS_DIR}/${TARGET_SYS}/include/linux/
- cp -vpPR include/linux/* ${CROSS_DIR}/${TARGET_SYS}/include/linux/
+do_install_append_arm() {
+ cp include/asm-arm/procinfo.h ${D}${includedir}/asm
}
-
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.20.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.20.bb
index c826d138b6..420f889f11 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.20.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.20.bb
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r10"
+PR = "r11"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
file://procinfo.h \
@@ -48,21 +48,3 @@ do_install() {
do_install_append_arm() {
cp ${WORKDIR}/procinfo.h ${D}${includedir}/asm/
}
-
-STAGE_TEMP="${WORKDIR}/temp-staging"
-
-do_stage () {
- set_arch
- echo $ARCH
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}${exec_prefix} ARCH=$ARCH
- if [ "$ARCH" = "arm" ]; then
- cp ${WORKDIR}/procinfo.h ${STAGE_TEMP}${includedir}/asm/
- fi
- install -d ${STAGING_INCDIR}
- rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
- cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
-}
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.22.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.22.bb
index 0e5debcfa3..fc57465863 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.22.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.22.bb
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r2"
+PR = "r3"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
file://procinfo.h"
@@ -46,21 +46,3 @@ do_install() {
do_install_append_arm() {
cp ${WORKDIR}/procinfo.h ${D}${includedir}/asm/
}
-
-STAGE_TEMP="${WORKDIR}/temp-staging"
-
-do_stage () {
- set_arch
- echo $ARCH
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}${exec_prefix} ARCH=$ARCH
- if [ "$ARCH" = "arm" ]; then
- cp ${WORKDIR}/procinfo.h ${STAGE_TEMP}${includedir}/asm/
- fi
- install -d ${STAGING_INCDIR}
- rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
- cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
-}
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.23.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.23.bb
index 95152f1b22..1ff38f0dd2 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.23.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.23.bb
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r4"
+PR = "r5"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
file://procinfo.h \
@@ -47,21 +47,3 @@ do_install() {
do_install_append_arm() {
cp ${WORKDIR}/procinfo.h ${D}${includedir}/asm/
}
-
-STAGE_TEMP="${WORKDIR}/temp-staging"
-
-do_stage () {
- set_arch
- echo $ARCH
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}${exec_prefix} ARCH=$ARCH
- if [ "$ARCH" = "arm" ]; then
- cp ${WORKDIR}/procinfo.h ${STAGE_TEMP}${includedir}/asm/
- fi
- install -d ${STAGING_INCDIR}
- rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
- cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
-}
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.25.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.25.bb
index 9289d390c4..3f2306c477 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.25.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.25.bb
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r3"
+PR = "r4"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
file://reinstate-a.out.h.patch;patch=1 \
@@ -50,21 +50,3 @@ do_install() {
do_install_append_arm() {
cp ${WORKDIR}/procinfo.h ${D}${includedir}/asm/
}
-
-STAGE_TEMP="${WORKDIR}/temp-staging"
-
-do_stage () {
- set_arch
- echo $ARCH
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}${exec_prefix} ARCH=$ARCH
- if [ "$ARCH" = "arm" ]; then
- cp ${WORKDIR}/procinfo.h ${STAGE_TEMP}${includedir}/asm/
- fi
- install -d ${STAGING_INCDIR}
- rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
- cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
- cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
-}
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb
index 6caddc0c2f..37bab5592f 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r0"
+PR = "r1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
"
@@ -42,8 +42,3 @@ do_install() {
set_arch
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
}
-
-do_stage () {
- set_arch
- oe_runmake headers_install INSTALL_HDR_PATH=${STAGING_DIR_HOST}${layout_prefix} ARCH=$ARCH
-}
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.30.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.30.bb
index 5fa6670602..c29b8efb41 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.30.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.30.bb
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r0"
+PR = "r1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
file://uio-header.patch;patch=1 \
@@ -45,8 +45,3 @@ do_install() {
set_arch
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
}
-
-do_stage () {
- set_arch
- oe_runmake headers_install INSTALL_HDR_PATH=${STAGING_DIR_HOST}${layout_prefix} ARCH=$ARCH
-}
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb
index 33872e6f89..d18be34a6e 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r0"
+PR = "r1"
DEFAULT_PREFERENCE = "-1"
@@ -44,8 +44,3 @@ do_install() {
set_arch
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
}
-
-do_stage () {
- set_arch
- oe_runmake headers_install INSTALL_HDR_PATH=${STAGING_DIR_HOST}${layout_prefix} ARCH=$ARCH
-}
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb
index 4b98f055a4..e1914b3286 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb
@@ -2,7 +2,7 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r0"
+PR = "r1"
DEFAULT_PREFERENCE = "-1"
@@ -44,8 +44,3 @@ do_install() {
set_arch
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
}
-
-do_stage () {
- set_arch
- oe_runmake headers_install INSTALL_HDR_PATH=${STAGING_DIR_HOST}${layout_prefix} ARCH=$ARCH
-}