aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-libc-headers
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-04-28 10:09:11 -0700
committerTom Rini <tom_rini@mentor.com>2010-04-28 10:10:41 -0700
commit91d3d92a626da89dfe13d63e68a90dbafdbaef1d (patch)
treec5926e030ff9ab1dc23d8c06836ba7aca893ad01 /recipes/linux-libc-headers
parent31aa8d977dbc5503d9a122fe902334d5437921c7 (diff)
downloadopenembedded-91d3d92a626da89dfe13d63e68a90dbafdbaef1d.tar.gz
linux-libc-headers: Delete include/scsi/scsi.h
With 2.6.31, the kernel started exporting certain SCSI headers again and in particular scsi/scsi.h. After talking with Christoph Hellwig and James Bottemley (scsi maintainer) the kernel shouldn't export scsi/scsi.h. Removing this from the kernel, rather than trying to clean it up to be userland parseable is the right way to go. We bump the libc INC_PRs to make sure the end user has a sane <scsi/scsi.h> again. Signed-off-by: Tom Rini <tom_rini@mentor.com> Acked-By: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/linux-libc-headers')
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers-2.6.31/scsi-use-__u8.patch26
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers-2.6.32/scsi-use-__u8.patch26
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb4
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb4
4 files changed, 4 insertions, 56 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers-2.6.31/scsi-use-__u8.patch b/recipes/linux-libc-headers/linux-libc-headers-2.6.31/scsi-use-__u8.patch
deleted file mode 100644
index b75487965a..0000000000
--- a/recipes/linux-libc-headers/linux-libc-headers-2.6.31/scsi-use-__u8.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-This patch is from
-http://patchwork.kernel.org/patch/38102/
-It seems its still under discussion and it will involve glibc to get it fixed correctly.
-for now OE uses scsi headers from kernel and not from glibc.
-
--Khem
-
-Index: linux-2.6.31/include/scsi/scsi.h
-===================================================================
---- linux-2.6.31.orig/include/scsi/scsi.h 2010-03-11 19:44:49.134590561 -0800
-+++ linux-2.6.31/include/scsi/scsi.h 2010-03-11 19:45:12.744466326 -0800
-@@ -142,10 +142,10 @@ struct scsi_cmnd;
-
- /* defined in T10 SCSI Primary Commands-2 (SPC2) */
- struct scsi_varlen_cdb_hdr {
-- u8 opcode; /* opcode always == VARIABLE_LENGTH_CMD */
-- u8 control;
-- u8 misc[5];
-- u8 additional_cdb_length; /* total cdb length - 8 */
-+ __u8 opcode; /* opcode always == VARIABLE_LENGTH_CMD */
-+ __u8 control;
-+ __u8 misc[5];
-+ __u8 additional_cdb_length; /* total cdb length - 8 */
- __be16 service_action;
- /* service specific data follows */
- };
diff --git a/recipes/linux-libc-headers/linux-libc-headers-2.6.32/scsi-use-__u8.patch b/recipes/linux-libc-headers/linux-libc-headers-2.6.32/scsi-use-__u8.patch
deleted file mode 100644
index b75487965a..0000000000
--- a/recipes/linux-libc-headers/linux-libc-headers-2.6.32/scsi-use-__u8.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-This patch is from
-http://patchwork.kernel.org/patch/38102/
-It seems its still under discussion and it will involve glibc to get it fixed correctly.
-for now OE uses scsi headers from kernel and not from glibc.
-
--Khem
-
-Index: linux-2.6.31/include/scsi/scsi.h
-===================================================================
---- linux-2.6.31.orig/include/scsi/scsi.h 2010-03-11 19:44:49.134590561 -0800
-+++ linux-2.6.31/include/scsi/scsi.h 2010-03-11 19:45:12.744466326 -0800
-@@ -142,10 +142,10 @@ struct scsi_cmnd;
-
- /* defined in T10 SCSI Primary Commands-2 (SPC2) */
- struct scsi_varlen_cdb_hdr {
-- u8 opcode; /* opcode always == VARIABLE_LENGTH_CMD */
-- u8 control;
-- u8 misc[5];
-- u8 additional_cdb_length; /* total cdb length - 8 */
-+ __u8 opcode; /* opcode always == VARIABLE_LENGTH_CMD */
-+ __u8 control;
-+ __u8 misc[5];
-+ __u8 additional_cdb_length; /* total cdb length - 8 */
- __be16 service_action;
- /* service specific data follows */
- };
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb
index 2e4041f297..953b065233 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb
@@ -2,13 +2,12 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r3"
+PR = "r4"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
file://0001-implement-TIF_RESTORE_SIGMASK-support-and-enable-the.patch;patch=1 \
- file://scsi-use-__u8.patch;patch=1 \
"
S = "${WORKDIR}/linux-${PV}"
@@ -44,6 +43,7 @@ do_compile () {
do_install() {
set_arch
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+ rm -f ${D}${exec_prefix}/include/scsi/scsi.h
}
SRC_URI[md5sum] = "84c077a37684e4cbfa67b18154390d8a"
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb
index d82a749f0a..f1c371de1e 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb
@@ -2,13 +2,12 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r3"
+PR = "r4"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
file://export_sa_family_t.patch;patch=1 \
- file://scsi-use-__u8.patch;patch=1 \
"
S = "${WORKDIR}/linux-${PV}"
@@ -44,6 +43,7 @@ do_compile () {
do_install() {
set_arch
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+ rm -f ${D}${exec_prefix}/include/scsi/scsi.h
}
SRC_URI[md5sum] = "260551284ac224c3a43c4adac7df4879"