summaryrefslogtreecommitdiffstats
path: root/recipes/linux-uml
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 16:35:00 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 16:51:36 +0200
commit1699e27f6642a97adf23fafc74fd6ccc9d5d3d55 (patch)
tree539b8259dd387cc00ddb10be2a297b6b29e0972a /recipes/linux-uml
parent0a2d1e13ec1cc334aaa5dfd6be7a668723388279 (diff)
downloadopenembedded-1699e27f6642a97adf23fafc74fd6ccc9d5d3d55.tar.gz
recipes: add missing checksums
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/linux-uml')
-rw-r--r--recipes/linux-uml/linux-uml_2.4.26.bb9
-rw-r--r--recipes/linux-uml/linux-uml_2.6.11-rc2-mm1.bb13
2 files changed, 17 insertions, 5 deletions
diff --git a/recipes/linux-uml/linux-uml_2.4.26.bb b/recipes/linux-uml/linux-uml_2.4.26.bb
index 11b2a2261c..9732ac879a 100644
--- a/recipes/linux-uml/linux-uml_2.4.26.bb
+++ b/recipes/linux-uml/linux-uml_2.4.26.bb
@@ -4,8 +4,8 @@ LICENSE = "GPL"
UMLR = "2"
PR = "1"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${PV}.tar.bz2 \
- ${SOURCEFORGE_MIRROR}/user-mode-linux/uml-patch-${PV}-${UMLR}.bz2;patch=1 \
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${PV}.tar.bz2;name=kernel \
+ ${SOURCEFORGE_MIRROR}/user-mode-linux/uml-patch-${PV}-${UMLR}.bz2;patch=1;name=patch \
file://defconfig \
file://aio_abi.h"
S = "${WORKDIR}/linux-${PV}"
@@ -42,3 +42,8 @@ do_install() {
install -m 0644 System.map ${D}/boot/System.map-${PV}
install -m 0644 .config ${D}/boot/config-${PV}
}
+
+SRC_URI[kernel.md5sum] = "88d7aefa03c92739cb70298a0b486e2c"
+SRC_URI[kernel.sha256sum] = "dab39fb4431c1c6852b4197300b729c5d674906e71ebfada6fe9541fd452ec81"
+SRC_URI[patch.md5sum] = "e2d02412e5ea7e65f665cf19bc5c267c"
+SRC_URI[patch.sha256sum] = "5a557294b7d4aea69bb910c987c07af8889b9368927444437a65d47f6b3785c1"
diff --git a/recipes/linux-uml/linux-uml_2.6.11-rc2-mm1.bb b/recipes/linux-uml/linux-uml_2.6.11-rc2-mm1.bb
index 915378cb56..a3ef092d38 100644
--- a/recipes/linux-uml/linux-uml_2.6.11-rc2-mm1.bb
+++ b/recipes/linux-uml/linux-uml_2.6.11-rc2-mm1.bb
@@ -7,15 +7,22 @@ MMV = "${@bb.data.getVar('PV',d,True).split('-')[2]}"
LV = "2.6.10"
PR = "r3"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${LV}.tar.bz2 \
- ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/patch-${KV}-${RCV}.bz2;patch=1 \
- ${KERNELORG_MIRROR}/pub/linux/kernel/people/akpm/patches/2.6/${KV}-${RCV}/${KV}-${RCV}-${MMV}/${KV}-${RCV}-${MMV}.gz;patch=1 \
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${LV}.tar.bz2;name=kernel \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/patch-${KV}-${RCV}.bz2;patch=1;name=patch \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/people/akpm/patches/2.6/${KV}-${RCV}/${KV}-${RCV}-${MMV}/${KV}-${RCV}-${MMV}.gz;patch=1;name=akpmpatch \
file://defconfig"
#http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-core-on-panic;patch=1 \
#http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-pretend-to-be-i586;patch=1 \
#http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-general-protection-fault;patch=1 \
#http://www.suse.de/~kraxel/uml/patches/2.6.10-rc3/uml-x11-fb;patch=1 \
+SRC_URI[kernel.md5sum] = "cffcd2919d9c8ef793ce1ac07a440eda"
+SRC_URI[kernel.sha256sum] = "21646736755faee214f489b7388e6c47f5bcf6c2df64298ed2597104fabb8f0e"
+SRC_URI[patch.md5sum] = "c93568f10a6aa445184b005a0754aa71"
+SRC_URI[patch.sha256sum] = "82dd73b3db7abeadc33e9b2ede0406de35277a8b897a23d266af0614f15052f1"
+SRC_URI[akpmpatch.md5sum] = "0e34b11b54e99a4d1d058a711bfad3d4"
+SRC_URI[akpmpatch.sha256sum] = "189e355021a87d11bbc3caf65fa96b937d8da4060eb4f8773457c19519a079a4"
+
S = "${WORKDIR}/linux-${LV}"
inherit kernel