aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/handhelds-sa_2.4.19-rmk6-pxa1-hh42.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/handhelds-sa_2.4.19-rmk6-pxa1-hh42.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/handhelds-sa_2.4.19-rmk6-pxa1-hh42.bb')
-rw-r--r--recipes/linux/handhelds-sa_2.4.19-rmk6-pxa1-hh42.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes/linux/handhelds-sa_2.4.19-rmk6-pxa1-hh42.bb b/recipes/linux/handhelds-sa_2.4.19-rmk6-pxa1-hh42.bb
new file mode 100644
index 0000000000..adca8740de
--- /dev/null
+++ b/recipes/linux/handhelds-sa_2.4.19-rmk6-pxa1-hh42.bb
@@ -0,0 +1,56 @@
+SECTION = "kernel"
+DESCRIPTION = "handhelds.org Linux kernel for StrongArm processor based devices."
+LICENSE = "GPL"
+PR = "r0"
+DEFAULT_PREFERENCE = "-1"
+
+KERNEL_CCSUFFIX = "-3.3.4"
+COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = '(h3600|simpad)'
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-sa-${PV}"
+SRC_URI = "${HANDHELDS_CVS};module=linux/kernel;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
+ file://defconfig-${PACKAGE_ARCH} \
+ file://ipaq-hal.init"
+
+S = "${WORKDIR}/kernel"
+
+inherit kernel update-rc.d
+
+K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
+K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
+K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
+RMKV = "${@bb.data.getVar('PV',d,1).split('-')[1].split('rmk')[-1]}"
+PXAV = "${@bb.data.getVar('PV',d,1).split('-')[2].split('pxa')[-1]}"
+HHV = "${@bb.data.getVar('PV',d,1).split('-')[3].split('hh')[-1]}"
+
+KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + int(bb.data.getVar('RMKV',d,1)) * 1000 + int(bb.data.getVar('PXAV',d,1)) * 100 + float(bb.data.getVar('HHV',d,1)))}"
+
+module_conf_h3600_micro = "alias ipaq_hal_3600 h3600_micro"
+module_conf_h3600_asic = "alias ipaq_hal_3800 h3600_asic"
+module_conf_sa1100_ir = "alias irda0 sa1100_ir"
+module_conf_pcmcia_core = "options pcmcia_core ignore_cis_vcc=1"
+module_conf_ppp_async = "alias ppp0 ppp_async"
+module_conf_orinoco_cs = "options orinoco_cs ignore_cis_vcc=1"
+module_conf_hostap_cs = "options hostap_cs ignore_cis_vcc=1"
+module_conf_spectrum_cs = "options spectrum_cs ignore_cis_vcc=1"
+
+module_autoload_h3600_ts = "h3600_ts"
+module_autoload_apm = "apm"
+module_autoload_h3600-uda1341 = "h3600-uda1341"
+module_autoload_af_packet = "af_packet"
+module_autoload_ppp_async = "ppp_async"
+module_autoload_usb-eth = "usb-eth"
+
+FILES_kernel += "/etc/init.d/ipaq-hal"
+INITSCRIPT_NAME = "ipaq-hal"
+INITSCRIPT_PARAMS = "start 21 S ."
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig-${PACKAGE_ARCH} ${S}/.config
+}
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install ${WORKDIR}/ipaq-hal.init ${D}${sysconfdir}/init.d/ipaq-hal
+}