aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/ixp4xx-kernel.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 10:39:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 20:16:13 +0200
commit16f464bd8cff6b6a27d9bfe691f7adc875d01ac2 (patch)
treed235ad1dba36225ca211cc7c606ecaab4ff883c5 /recipes/linux/ixp4xx-kernel.inc
parent44985d56bc556786812a0a02d6219afd31a7381d (diff)
downloadopenembedded-16f464bd8cff6b6a27d9bfe691f7adc875d01ac2.tar.gz
recipes: move checksums to recipes from checksums.ini, part 2 manual adjustement
* all: multiple checked items in SRC_URI (needs name= param) * other fixes like non-existent URL, checksums moved ot .inc or included .bb (ie for -native) * ... * tested with micro/micro-uclibc/Angstrom/SHR with SOURCE_MIRROR_FETCH="True" (ignoring COMPATIBLE_* * also tested -c fetch with s/SRC_URI_append_[^ ]*/SRC_URI_append/g and s/SRC_URI_[^ ]*/SRC_URI_append/g to catch all URLs used only for distro/machine/virtual override (see http://build.shr-project.org/tests/jama/SRC_URI.removeOverrides.patch) * in case I downloaded different checksum then what was in checksums.ini I used the old one from checksums.ini and put my checksum in comment * I'll send to ML list of recipes which cannot be downloaded (weren't converted) and where I got different checksums Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/linux/ixp4xx-kernel.inc')
-rw-r--r--recipes/linux/ixp4xx-kernel.inc10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes/linux/ixp4xx-kernel.inc b/recipes/linux/ixp4xx-kernel.inc
index 6422177f34..aa58635770 100644
--- a/recipes/linux/ixp4xx-kernel.inc
+++ b/recipes/linux/ixp4xx-kernel.inc
@@ -92,7 +92,7 @@ python () {
name.append(patch)
pname = '-'.join(name)
if patch[0:2] == "rc" or patch[0:3] == "pre":
- patch_uri.append("${KERNELORG_MIRROR}/pub/linux/kernel/v%s/testing/patch-%s.bz2;patch=1;pname=%s" % (major, pname, pname))
+ patch_uri.append("${KERNELORG_MIRROR}/pub/linux/kernel/v%s/testing/patch-%s.bz2;patch=1;pname=%s;name=rcpatch" % (major, pname, pname))
kernel[-1] = str(int(kernel[-1]) - 1)
if patch[0:2] == "rc" and pref == 10:
pref = 6
@@ -101,14 +101,14 @@ python () {
else:
pref = 2
elif patch[0:2] == "bk" or patch[0:3] == "git":
- patch_uri.append("${KERNELORG_MIRROR}/pub/linux/kernel/v%s/snapshots/patch-%s.bz2;patch=1;pname=%s" % (major, pname, pname))
+ patch_uri.append("${KERNELORG_MIRROR}/pub/linux/kernel/v%s/snapshots/patch-%s.bz2;patch=1;pname=%s;name=gitpatch" % (major, pname, pname))
pref = 2
elif patch[0:2] == "ac":
- patch_uri.append("${KERNELORG_MIRROR}/pub/linux/kernel/people/alan/linux-%s/%s/patch-%s" % (major, base, pname))
+ patch_uri.append("${KERNELORG_MIRROR}/pub/linux/kernel/people/alan/linux-%s/%s/patch-%s;name=acpatch" % (major, base, pname))
mmac = 2
filepath[0:0] = [ filedir % (name[0] + "-ac") ]
elif patch[0:2] == "mm":
- patch_uri.append("${KERNELORG_MIRROR}/pub/linux/kernel/people/akpm/patches/%s/%s/%s/%s.bz2;patch=1;pname=%s" % (major, base, pname, pname, pname))
+ patch_uri.append("${KERNELORG_MIRROR}/pub/linux/kernel/people/akpm/patches/%s/%s/%s/%s.bz2;patch=1;pname=%s;name=mmpatch" % (major, base, pname, pname, pname))
mmac = 2
filepath[0:0] = [ filedir % (name[0] + "-mm") ]
else:
@@ -117,7 +117,7 @@ python () {
base = pname
base = '.'.join(kernel)
- patch_uri[0] = "${KERNELORG_MIRROR}/pub/linux/kernel/v%s/linux-%s.tar.bz2" % (major, base)
+ patch_uri[0] = "${KERNELORG_MIRROR}/pub/linux/kernel/v%s/linux-%s.tar.bz2;name=kernel" % (major, base)
filepath[-1:-1] = [ filedir % base ]
if base != minor:
filepath[-1:-1] = [ filedir % minor ]