aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-h1940_2.6.17-h1940.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-h1940_2.6.17-h1940.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-h1940_2.6.17-h1940.bb')
-rw-r--r--recipes/linux/linux-h1940_2.6.17-h1940.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/linux/linux-h1940_2.6.17-h1940.bb b/recipes/linux/linux-h1940_2.6.17-h1940.bb
new file mode 100644
index 0000000000..f7ad0185f3
--- /dev/null
+++ b/recipes/linux/linux-h1940_2.6.17-h1940.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Linux kernel for h1940 devices."
+SECTION = "kernel"
+LICENSE = "GPL"
+
+PR = "r1"
+
+COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = "h1940"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.17.tar.bz2 \
+ http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/v2.6.17-gitcurrent.patch;patch=1 \
+ http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/full.patch;patch=1 \
+ http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/WIP/serial_sparse.patch;patch=1 \
+ http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/WIP/h1940_leds.patch;patch=1 \
+ http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/WIP/bluetooth.patch;patch=1 \
+ http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/WIP/h1940_batt.patch;patch=1 \
+ http://rtpnet.nerim.net/ipaq/patches/2.6.17-1/WIP/mtd_partition.patch;patch=1 \
+ http://anymore.nl/ipaq/usbgadget_fixups.patch;patch=1 \
+ http://anymore.nl/ipaq/udc_usb_gadget_register_driver_fix.patch;patch=1 \
+ http://anymore.nl/ipaq/udc_unbind.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-2.6.17"
+
+inherit kernel
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ yes '' | oe_runmake oldconfig
+}