aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-omap-2.6.29/omap3-touchbook/aufs-1.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-13 16:30:10 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-15 19:26:15 +0200
commitd861047e32eacf91974108a5eeba1f847bad5b9f (patch)
treeac07eaf5fe935b4f58aae20528f3cf101b712549 /recipes/linux/linux-omap-2.6.29/omap3-touchbook/aufs-1.patch
parent72c1fd8a2b6ab59a28467c033ec7fa18cfb67225 (diff)
downloadopenembedded-d861047e32eacf91974108a5eeba1f847bad5b9f.tar.gz
linux-omap 2.6.29: add support for the omap3-touchbook
Diffstat (limited to 'recipes/linux/linux-omap-2.6.29/omap3-touchbook/aufs-1.patch')
-rw-r--r--recipes/linux/linux-omap-2.6.29/omap3-touchbook/aufs-1.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap-2.6.29/omap3-touchbook/aufs-1.patch b/recipes/linux/linux-omap-2.6.29/omap3-touchbook/aufs-1.patch
new file mode 100644
index 0000000000..3b54e71791
--- /dev/null
+++ b/recipes/linux/linux-omap-2.6.29/omap3-touchbook/aufs-1.patch
@@ -0,0 +1,35 @@
+aufs2 kbuild patch for linux-2.6.29
+
+diff --git a/fs/Kconfig b/fs/Kconfig
+index 93945dd..75156dd 100644
+--- a/fs/Kconfig
++++ b/fs/Kconfig
+@@ -222,6 +222,7 @@ source "fs/qnx4/Kconfig"
+ source "fs/romfs/Kconfig"
+ source "fs/sysv/Kconfig"
+ source "fs/ufs/Kconfig"
++source "fs/aufs/Kconfig"
+
+ endif # MISC_FILESYSTEMS
+
+diff --git a/fs/Makefile b/fs/Makefile
+index dc20db3..a4e9a65 100644
+--- a/fs/Makefile
++++ b/fs/Makefile
+@@ -124,3 +124,4 @@ obj-$(CONFIG_DEBUG_FS) += debugfs/
+ obj-$(CONFIG_OCFS2_FS) += ocfs2/
+ obj-$(CONFIG_BTRFS_FS) += btrfs/
+ obj-$(CONFIG_GFS2_FS) += gfs2/
++obj-$(CONFIG_AUFS_FS) += aufs/
+diff --git a/include/linux/Kbuild b/include/linux/Kbuild
+index 106c3ba..d0c7262 100644
+--- a/include/linux/Kbuild
++++ b/include/linux/Kbuild
+@@ -34,6 +34,7 @@ header-y += atmppp.h
+ header-y += atmsap.h
+ header-y += atmsvc.h
+ header-y += atm_zatm.h
++header-y += aufs_type.h
+ header-y += auto_fs4.h
+ header-y += ax25.h
+ header-y += b1lli.h