aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-omap-pm_2.6.29.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-26 19:34:08 +0100
committerKoen Kooi <koen@openembedded.org>2009-10-26 19:51:27 +0100
commit0bee6a2ed81ffcedaecbb96a64b694d289cfe5f6 (patch)
treeb616a45dc27241553c0a6bf87bef906146798ed8 /recipes/linux/linux-omap-pm_2.6.29.bb
parentced897b1749014a08b0627de84ba086afab002f8 (diff)
downloadopenembedded-0bee6a2ed81ffcedaecbb96a64b694d289cfe5f6.tar.gz
linux-omap-pm 2.6.29: sync touchbook patches with linux-omap kernel
Diffstat (limited to 'recipes/linux/linux-omap-pm_2.6.29.bb')
-rw-r--r--recipes/linux/linux-omap-pm_2.6.29.bb26
1 files changed, 18 insertions, 8 deletions
diff --git a/recipes/linux/linux-omap-pm_2.6.29.bb b/recipes/linux/linux-omap-pm_2.6.29.bb
index b635f2154f..1c7f778a66 100644
--- a/recipes/linux/linux-omap-pm_2.6.29.bb
+++ b/recipes/linux/linux-omap-pm_2.6.29.bb
@@ -165,8 +165,8 @@ SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
file://tincantools-zippy.diff;patch=1 \
"
-SRC_URI_append_omap3-touchbook = " \
- file://beagle-asoc.patch;patch=1 \
+SRC_URI_append_omap3-touchbook = " file://logo_linux_clut224.ppm \
+ file://../beagleboard/beagle-asoc.patch;patch=1 \
file://accelerometer-mma7455l.patch;patch=1 \
file://accelerometer-touchscreen-mux-spi.patch;patch=1 \
file://touchscreen-ads7846-export-settings.patch;patch=1 \
@@ -175,7 +175,6 @@ SRC_URI_append_omap3-touchbook = " \
file://battery2-bq27200-no-error-message.patch;patch=1 \
file://sound-headphone-detection.patch;patch=1 \
file://dss2-fix-XY-coordinates-when-rotating.patch;patch=1 \
- file://screen-backlight.patch;patch=1 \
file://battery1-tps65950-charging-management-1.patch;patch=1 \
file://dss2-fix-scaling-when-rotating.patch;patch=1 \
file://dss2-export-status.patch;patch=1 \
@@ -191,19 +190,30 @@ SRC_URI_append_omap3-touchbook = " \
file://boot-no-power-message.patch;patch=1 \
file://usb-lower-current-consumption-upon-insertion.patch;patch=1 \
file://battery2-bq27200-gpio-charged.patch;patch=1 \
- file://board-omap3beagle.c \
+ file://keyboard-special-keys.patch;patch=1 \
+ file://dss2-fix-rotation-offsets.patch;patch=1 \
+ file://touchbook-config.patch;patch=1 \
+ file://board-omap3touchbook.c \
+# file://boot-trace-for-optimization.patch;patch=1 \
"
-do_configure_prepend_omap3-touchbook() {
- cp ${WORKDIR}/board-omap3beagle.c ${S}/arch/arm/mach-omap2
-}
-
SRC_URI_append_omap3evm = " \
file://evm-mcspi-ts.diff;patch=1 \
"
S = "${WORKDIR}/git"
+do_configure_prepend_omap3-touchbook() {
+ cp ${WORKDIR}/board-omap3touchbook.c ${S}/arch/arm/mach-omap2
+}
+
+do_install_append() {
+ install -d ${D}/boot
+ install -m 0644 Documentation/arm/OMAP/DSS ${D}/boot || true
+}
+
+PACKAGES =+ "omap-dss-doc"
+FILES_omap-dss-doc = "/boot/DSS"
module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"