aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-openmoko-2.6.29_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-26 15:05:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-26 15:12:26 +0200
commit8bb53d3f261c59353652f0328bfd887d6aa1c112 (patch)
tree99e66d9e168fe70b3de5e12a1879adda6971ac39 /recipes/linux/linux-openmoko-2.6.29_git.bb
parentfa8b49b614644b3b02cf2e962fed95cf41f6e6f3 (diff)
downloadopenembedded-8bb53d3f261c59353652f0328bfd887d6aa1c112.tar.gz
linux-openmoko: partial revert of rename to PN_PV sheme
* details in http://thread.gmane.org/gmane.comp.handhelds.openembedded/32950 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/linux/linux-openmoko-2.6.29_git.bb')
-rw-r--r--recipes/linux/linux-openmoko-2.6.29_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.29_git.bb b/recipes/linux/linux-openmoko-2.6.29_git.bb
new file mode 100644
index 0000000000..a7140ee70c
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.29_git.bb
@@ -0,0 +1,24 @@
+require linux.inc
+require linux-openmoko.inc
+
+KERNEL_RELEASE = "2.6.29"
+KERNEL_VERSION = "2.6.29-rc3"
+
+SRCREV = "973a41fce60e5f6edfcf0eaf94056a57eee65e16"
+OMV = "oe11"
+PV = "${KERNEL_RELEASE}-${OMV}+gitr${SRCPV}"
+PR = "r8"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
+ file://fix-install.patch \
+ file://0007-Enable-UBI-UBIFS.patch \
+"
+S = "${WORKDIR}/git"
+
+CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
+CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
+}