aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-sgh-i900_2.6.32.bb
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2009-12-13 16:44:13 +0200
committerStefan Schmidt <stefan@datenfreihafen.org>2009-12-13 18:30:33 +0100
commit4f72f2f578a65af51daca59b164eb20497797eab (patch)
tree752fbe03fef0bd23228dc1fb0946aa4333328621 /recipes/linux/linux-sgh-i900_2.6.32.bb
parent5b4ef2a7e318a04fbbf523cd62a570cdb8a41de5 (diff)
downloadopenembedded-4f72f2f578a65af51daca59b164eb20497797eab.tar.gz
linux-sgh-i900: Update kernel recipe to 2.6.32
Diffstat (limited to 'recipes/linux/linux-sgh-i900_2.6.32.bb')
-rw-r--r--recipes/linux/linux-sgh-i900_2.6.32.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/linux/linux-sgh-i900_2.6.32.bb b/recipes/linux/linux-sgh-i900_2.6.32.bb
new file mode 100644
index 0000000000..4b5df5b7aa
--- /dev/null
+++ b/recipes/linux/linux-sgh-i900_2.6.32.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Linux 2.6.32 kernel for the Samsung Omnia SGH-i900."
+SECTION = "kernel"
+LICENSE = "GPL"
+
+RDEPENDS += "marvell-gspi-fw"
+
+COMPATIBLE_MACHINE = "sgh-i900"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://sgh-i900-support.patch;patch=1 \
+ file://sgh_i900_defconfig"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/sgh_i900_defconfig ${S}/.config
+} \ No newline at end of file