aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-turbostation_2.6.20.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-turbostation_2.6.20.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-turbostation_2.6.20.2.bb')
-rw-r--r--recipes/linux/linux-turbostation_2.6.20.2.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/linux/linux-turbostation_2.6.20.2.bb b/recipes/linux/linux-turbostation_2.6.20.2.bb
new file mode 100644
index 0000000000..308c5e7a46
--- /dev/null
+++ b/recipes/linux/linux-turbostation_2.6.20.2.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Linux Kernel for the QNAP TurboStation platform"
+SECTION = "kernel"
+LICENSE = "GPL"
+DEPENDS = "u-boot-utils-native"
+PR = "r2"
+
+COMPATIBLE_MACHINE = "turbostation"
+
+RDEPENDS_kernel-module-zd1211rw += "zd1211-firmware"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://001_r1000.diff;patch=1 \
+ file://linux-2.6.16_arch_ppc_platforms_sandpoint.h;patch=1 \
+ file://002_qnap-pic.diff;patch=1 \
+ file://linux-2.6.16_arch_ppc_syslib_Makefile;patch=1 \
+ file://linux-2.6.16_drivers_mtd_maps_physmap.c;patch=1 \
+ file://linux-2.6.16_arch_ppc_syslib_mpc10x_common.c;patch=1 \
+ file://linux-2.6.16_arch_ppc_platforms_Makefile;patch=1 \
+ file://linux-2.6.16_include_asm-ppc_mpc10x.h;patch=1 \
+ file://linux-2.6.16_arch_ppc_platforms_sandpoint.c;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "uImage"
+KERNEL_OUTPUT = "arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}"
+# Override arch. The kernel stuff is in arch/ppc, not arch/powerpc in our case
+ARCH = ppc
+
+do_configure() {
+ install -m 644 ${WORKDIR}/defconfig ${S}/.config
+ make ARCH=ppc oldconfig
+}
+
+#ppc build leaves the kernel in a different place
+#do_movekernel() {
+#
+#}