aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-wrt_2.4.20.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-wrt_2.4.20.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-wrt_2.4.20.bb')
-rw-r--r--recipes/linux/linux-wrt_2.4.20.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes/linux/linux-wrt_2.4.20.bb b/recipes/linux/linux-wrt_2.4.20.bb
new file mode 100644
index 0000000000..23a5d4f203
--- /dev/null
+++ b/recipes/linux/linux-wrt_2.4.20.bb
@@ -0,0 +1,50 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for the Linksys WRT54 devices"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-2.4.20.tar.bz2 \
+ file://linux-2.4.20-mipscvs.patch;patch=1 \
+ file://2.4.20_broadcom_3_37_2_1109_US.patch;patch=1 \
+ file://110-sch_htb.patch;patch=1 \
+ file://120-openwrt.patch;patch=1 \
+ file://130-nfsswap.patch;patch=1 \
+ file://140-ebtables-brnf-5.patch;patch=1 \
+ file://150-mppe-mppc-0.98.patch;patch=1 \
+ file://160-expr.patch;patch=1 \
+ file://linux-2.4.24-attribute-used.patch;patch=1 \
+ file://gcc_mtune.patch;patch=1 \
+ file://gcc3.patch;patch=1 \
+ file://nobcom.patch;patch=1 \
+ file://compressed-20040531.tar.bz2 \
+ file://diag.c \
+ file://defconfig"
+S = "${WORKDIR}/linux-2.4.20"
+
+
+COMPATIBLE_HOST = 'mipsel.*-linux'
+
+inherit kernel
+
+CMDLINE_CONSOLE ?= "ttyS0,115200n8"
+CMDLINE_ROOT ?= "root=/dev/mtdblock2 noinitrd"
+# CMDLINE_INIT = "init=/bin/busybox ash"
+CMDLINE_INIT ?= " "
+CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE} ${CMDLINE_INIT}"
+EXTRA_OEMAKE += "'SRCBASE=${STAGING_LIBDIR}/bcom'"
+
+do_unpack_extra(){
+ install -m 0644 ${WORKDIR}/diag.c ${S}/drivers/net/diag/diag_led.c
+ if [ -e ${WORKDIR}/compressed ]; then
+ rm -rf ${S}/arch/mips/brcm-boards/bcm947xx/compressed
+ mv ${WORKDIR}/compressed ${S}/arch/mips/brcm-boards/bcm947xx/compressed
+ fi
+}
+addtask unpack_extra after do_patch before do_configure
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
+}
+
+COMPATIBLE_MACHINE = "wrt54"