aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_2.6.31.bb
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-10-19 17:46:01 +0200
committerJeremy Lainé <jeremy.laine@m4x.org>2009-10-19 17:46:01 +0200
commit83396675e812ff3022426c0065fb9d8b52b4d35e (patch)
tree1712c6270955311e6ca5fd90259193ee08a659fb /recipes/linux/linux_2.6.31.bb
parent47e3f7bc0ec31948832e410f2a4cc201c81e04a2 (diff)
downloadopenembedded-83396675e812ff3022426c0065fb9d8b52b4d35e.tar.gz
linux-2.6.31: initial port of boc01 patches
Diffstat (limited to 'recipes/linux/linux_2.6.31.bb')
-rw-r--r--recipes/linux/linux_2.6.31.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/linux/linux_2.6.31.bb b/recipes/linux/linux_2.6.31.bb
index 455ff19adc..30b152c8fd 100644
--- a/recipes/linux/linux_2.6.31.bb
+++ b/recipes/linux/linux_2.6.31.bb
@@ -13,6 +13,32 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
http://maxim.org.za/AT91RM9200/2.6/2.6.31-at91.patch.gz;patch=1 \
file://defconfig"
+SRC_URI_append_boc01 = "\
+ file://boc01.dts \
+ file://boc01.dts.v1 \
+ file://004-081205-usb.patch;patch=1 \
+ file://005-091008-isl12024.patch;patch=1 \
+ file://007-091005-lm73.patch;patch=1 \
+ file://008-091005-spi.patch;patch=1 \
+ file://011-090115-gpio.patch;patch=1 \
+ file://012-091019-capsense.patch;patch=1 \
+ file://013-091015-lcd.patch;patch=1 \
+ "
+
SRC_URI_append_ep93xx = " \
file://edb9301-fix-machine-id.patch;patch=1 \
"
+
+do_devicetree_image_append_boc01() {
+ dtc -I dts -O dtb ${KERNEL_DEVICETREE_FLAGS} -o devicetree.v1 ${KERNEL_DEVICETREE}.v1
+ install -m 0644 devicetree.v1 ${D}/boot/devicetree-${KERNEL_VERSION}.v1
+}
+
+pkg_postinst_kernel-devicetree_append_boc01 () {
+ cd /${KERNEL_IMAGEDEST}; update-alternatives --install /${KERNEL_IMAGEDEST}/devicetree.v1 devicetree.v1 devicetree-${KERNEL_VERSION}.v1 ${KERNEL_PRIORITY} || true
+}
+
+pkg_postrm_kernel-devicetree_append_boc01 () {
+ cd /${KERNEL_IMAGEDEST}; update-alternatives --remove devicetree.v1 devicetree-${KERNEL_VERSION}.v1 || true
+}
+