aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_2.6.32.bb
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2010-03-03 20:43:18 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-04 15:11:11 +0100
commitedac9ba83634d92469910535544613c3bc4e88c4 (patch)
tree5af88869c918e634ef2732c0a1af2156acaaaed5 /recipes/linux/linux_2.6.32.bb
parentd9ff02605906452e0c4946d4591d5ef6172fe5e5 (diff)
downloadopenembedded-edac9ba83634d92469910535544613c3bc4e88c4.tar.gz
linux 2.6.32: add support for ts72xx boards
Signed-off-by: Petr Štetiar <ynezz@true.cz> Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/linux/linux_2.6.32.bb')
-rw-r--r--recipes/linux/linux_2.6.32.bb22
1 files changed, 21 insertions, 1 deletions
diff --git a/recipes/linux/linux_2.6.32.bb b/recipes/linux/linux_2.6.32.bb
index fdc22e3bfd..d0043c5f50 100644
--- a/recipes/linux/linux_2.6.32.bb
+++ b/recipes/linux/linux_2.6.32.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r8"
+PR = "r9"
S = "${WORKDIR}/linux-${PV}"
@@ -20,6 +20,7 @@ DEFAULT_PREFERENCE_tosa = "-1"
DEFAULT_PREFERENCE_ben-nanonote = "-1"
DEFAULT_PREFERENCE_jornada6xx = "-1"
DEFAULT_PREFERENCE_jornada7xx = "-1"
+DEFAULT_PREFERENCE_ts72xx = "-1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.9.bz2;patch=1 \
@@ -45,6 +46,25 @@ SRC_URI_append_simone = " \
file://ep93xx/ep93xx-spi.patch;patch=1 \
file://ep93xx/ep93xx-cpuinfo.patch;patch=1 "
+SRC_URI_append_ts72xx = " \
+ file://0001-ts72xx_base.patch;patch=1 \
+ file://0002-ts72xx_force_machine-id.patch;patch=1 \
+ file://0003-ep93xx_cpuinfo.patch;patch=1 \
+ file://0004-ts72xx_sbcinfo.patch;patch=1 \
+ file://0005-ep93xx_eth.patch;patch=1 \
+ file://0006-ts72xx_ts_ser1.patch;patch=1 \
+ file://0007-ts72xx_rs485.patch;patch=1 \
+ file://0008-ts72xx_ts_eth100.patch;patch=1 \
+ file://0009-ts7200_cf_ide.patch;patch=1 \
+ file://0010-ts72xx_pata.patch;patch=1 \
+ file://0011-ep93xx_pm.patch;patch=1 \
+ file://0012-ts72xx_gpio_i2c.patch;patch=1 \
+ file://0013-ts72xx_dio_keypad.patch;patch=1 \
+ file://0014-ep93xx_spi.patch;patch=1 \
+ file://0015-ep93xx_cpufreq.patch;patch=1 \
+ file://0016-ts7200_nor_flash.patch;patch=1 \
+ "
+
# Zaurus family bootloader patches
RPSRC = "http://www.rpsys.net/openzaurus/patches/archive"
ZAURUSPATCHES = " ${RPSRC}/pxa-linking-bug-r1.patch;patch=1;status=unmergable;name=pxa-linking-bug-r1 "