aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-10-26 15:43:03 +0000
committerMichael Smith <msmith@cbnco.com>2010-11-14 18:36:53 -0500
commit24de831d82d165c9455b9e0fe5dd128635bcd714 (patch)
tree6a79cbda93e9266f0e5af8424b233946228dbfb8 /recipes/linux
parent150f8915cdeb72af681a93c8f3d122ffb3086139 (diff)
downloadopenembedded-24de831d82d165c9455b9e0fe5dd128635bcd714.tar.gz
linux: fix sh equality operator
Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Acked-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb2
-rw-r--r--recipes/linux/ep93xx-kernel_2.6.19+2.6.20-rc7.bb2
-rw-r--r--recipes/linux/gumstix-linux.inc2
-rw-r--r--recipes/linux/ixp4xx-kernel.inc2
-rw-r--r--recipes/linux/linux-bd-neon-2.6_2.6.22.bb2
-rw-r--r--recipes/linux/linux-hackndev-2.6_git.bb2
-rw-r--r--recipes/linux/linux-handhelds-2.6.inc4
-rw-r--r--recipes/linux/linux-magicbox-2.6.19.2/209-mini_fo.patch8
-rw-r--r--recipes/linux/linux-mtx-1_2.4.27.bb2
-rw-r--r--recipes/linux/linux-mtx-2_2.4.27.bb2
-rw-r--r--recipes/linux/linux-mtx-3_2.6.15.4.bb2
-rw-r--r--recipes/linux/linux-mtx-3_2.6.15.bb2
-rw-r--r--recipes/linux/linux-navman_2.6.18.bb2
-rw-r--r--recipes/linux/linux-palm-omap1_2.6.22-omap1.bb2
-rw-r--r--recipes/linux/linux-tornado-omap2_2.6.16.16.bb2
-rw-r--r--recipes/linux/mx21ads-kernel_2.6.19rc6.bb2
-rw-r--r--recipes/linux/netbook-pro-kernel_2.6.17.bb2
17 files changed, 21 insertions, 21 deletions
diff --git a/recipes/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb b/recipes/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb
index 4e3c858140..fa49df7645 100644
--- a/recipes/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb
+++ b/recipes/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb
@@ -27,7 +27,7 @@ do_configure() {
fi
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
echo "CONFIG_AEABI=y" >> ${S}/.config
echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
else
diff --git a/recipes/linux/ep93xx-kernel_2.6.19+2.6.20-rc7.bb b/recipes/linux/ep93xx-kernel_2.6.19+2.6.20-rc7.bb
index b17b5f7c2b..1c74f825b7 100644
--- a/recipes/linux/ep93xx-kernel_2.6.19+2.6.20-rc7.bb
+++ b/recipes/linux/ep93xx-kernel_2.6.19+2.6.20-rc7.bb
@@ -26,7 +26,7 @@ do_configure() {
fi
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
echo "CONFIG_AEABI=y" >> ${S}/.config
echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
else
diff --git a/recipes/linux/gumstix-linux.inc b/recipes/linux/gumstix-linux.inc
index e6d7bec43a..5fae245d89 100644
--- a/recipes/linux/gumstix-linux.inc
+++ b/recipes/linux/gumstix-linux.inc
@@ -15,7 +15,7 @@ do_deploy[dirs] = "${S}"
do_configure_prepend() {
echo "" > ${S}/.config
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
echo "CONFIG_AEABI=y" >> ${S}/.config
echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
else
diff --git a/recipes/linux/ixp4xx-kernel.inc b/recipes/linux/ixp4xx-kernel.inc
index cd5a952381..201a1a8fcd 100644
--- a/recipes/linux/ixp4xx-kernel.inc
+++ b/recipes/linux/ixp4xx-kernel.inc
@@ -192,7 +192,7 @@ do_configure_prepend() {
echo 'CONFIG_CPU_BIG_ENDIAN=y' >>'${S}/.config'
fi
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
echo "CONFIG_AEABI=y" >> ${S}/.config
echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
else
diff --git a/recipes/linux/linux-bd-neon-2.6_2.6.22.bb b/recipes/linux/linux-bd-neon-2.6_2.6.22.bb
index a029044151..83782d7c5b 100644
--- a/recipes/linux/linux-bd-neon-2.6_2.6.22.bb
+++ b/recipes/linux/linux-bd-neon-2.6_2.6.22.bb
@@ -22,7 +22,7 @@ ALLOW_EMPTY = "1"
do_configure() {
cp arch/arm/configs/neon_defconfig .config || die "No default configuration for ${MACHINE} available."
-# if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+# if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
# echo "CONFIG_AEABI=y" >> ${S}/.config
# echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
# else
diff --git a/recipes/linux/linux-hackndev-2.6_git.bb b/recipes/linux/linux-hackndev-2.6_git.bb
index a302bee06c..ac05b6197c 100644
--- a/recipes/linux/linux-hackndev-2.6_git.bb
+++ b/recipes/linux/linux-hackndev-2.6_git.bb
@@ -30,7 +30,7 @@ do_configure() {
|| die "No default configuration for ${MACHINE} available."
fi
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
echo "CONFIG_AEABI=y" >> ${S}/.config
echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
else
diff --git a/recipes/linux/linux-handhelds-2.6.inc b/recipes/linux/linux-handhelds-2.6.inc
index 7c5949e813..acd1ee0266 100644
--- a/recipes/linux/linux-handhelds-2.6.inc
+++ b/recipes/linux/linux-handhelds-2.6.inc
@@ -50,7 +50,7 @@ do_configure() {
echo "CONFIG_INITRAMFS_SOURCE=\"${WORKDIR}/initramfs.cpio\"" >> ${S}/.config
fi
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
echo "CONFIG_AEABI=y" >> ${S}/.config
echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
else
@@ -74,7 +74,7 @@ do_deploy_append() {
echo "${MACHINE}-kernel-${DATETIME} ${KERNEL_IMAGE_BASE_NAME} - kernel" >> ${DEPLOY_DIR_IMAGE}/reflash.ctl
gen_haret_startup
- if [ -n "${KERNEL_INITRAMFS_PATH}" -a "${ANGSTROMLIBC}" == "glibc" ]; then
+ if [ -n "${KERNEL_INITRAMFS_PATH}" -a "${ANGSTROMLIBC}" = "glibc" ]; then
cp ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.bin ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-$(basename ${KERNEL_INITRAMFS_PATH} | awk -F. '{print $1}')-${PV}-${PR}-${MACHINE}.bin
fi
}
diff --git a/recipes/linux/linux-magicbox-2.6.19.2/209-mini_fo.patch b/recipes/linux/linux-magicbox-2.6.19.2/209-mini_fo.patch
index a8e6d88d63..c7d3b3e988 100644
--- a/recipes/linux/linux-magicbox-2.6.19.2/209-mini_fo.patch
+++ b/recipes/linux/linux-magicbox-2.6.19.2/209-mini_fo.patch
@@ -5680,10 +5680,10 @@ diff -urN linux-2.6.19.old/fs/mini_fo/mini_fo-merge linux-2.6.19.dev/fs/mini_fo/
+COMMAND=
+exec_command()
+{
-+ if [ x$DRYRUN == "xset" ]; then
++ if [ x$DRYRUN = "xset" ]; then
+ echo " would run: $COMMAND"
+ elif ! [ x$DRYRUN == "xset" ]; then
-+ if [ x$VERBOSE == "xset" ]; then
++ if [ x$VERBOSE = "xset" ]; then
+ echo " running: $COMMAND"
+ fi
+ eval $COMMAND
@@ -5737,7 +5737,7 @@ diff -urN linux-2.6.19.old/fs/mini_fo/mini_fo-merge linux-2.6.19.dev/fs/mini_fo/
+ esac
+done
+
-+if [ "x$HELP" == "xset" ]; then
++if [ "x$HELP" = "xset" ]; then
+ usage
+ exit -1
+fi
@@ -5908,7 +5908,7 @@ diff -urN linux-2.6.19.old/fs/mini_fo/mini_fo-overlay linux-2.6.19.dev/fs/mini_f
+
+BASE="$1"
+
-+if [ "x$HELP" == "xset" ]; then
++if [ "x$HELP" = "xset" ]; then
+ usage
+ exit -1
+fi
diff --git a/recipes/linux/linux-mtx-1_2.4.27.bb b/recipes/linux/linux-mtx-1_2.4.27.bb
index a20099f6ba..f5bd6ed0fa 100644
--- a/recipes/linux/linux-mtx-1_2.4.27.bb
+++ b/recipes/linux/linux-mtx-1_2.4.27.bb
@@ -59,7 +59,7 @@ MTX_KERNEL_NON_PCI_OHCI = "yes"
do_configure_prepend() {
install -m 0644 ${WORKDIR}/defconfig-mtx-1 ${S}/.config
- if [ "x${MTX_KERNEL_NON_PCI_OHCI}" == "xyes" ]; then
+ if [ "x${MTX_KERNEL_NON_PCI_OHCI}" = "xyes" ]; then
echo "CONFIG_USB_NON_PCI_OHCI=y" >> ${S}/.config
fi
}
diff --git a/recipes/linux/linux-mtx-2_2.4.27.bb b/recipes/linux/linux-mtx-2_2.4.27.bb
index fb4c1041ae..02ddeca42b 100644
--- a/recipes/linux/linux-mtx-2_2.4.27.bb
+++ b/recipes/linux/linux-mtx-2_2.4.27.bb
@@ -67,7 +67,7 @@ PACKAGE_ARCH = "mtx-2"
do_configure_prepend() {
install -m 0644 ${WORKDIR}/defconfig-mtx-2 ${S}/.config
- if [ "x${MTX_KERNEL_NON_PCI_OHCI}" == "xyes" ]; then
+ if [ "x${MTX_KERNEL_NON_PCI_OHCI}" = "xyes" ]; then
echo "CONFIG_USB_NON_PCI_OHCI=y" >> ${S}/.config
fi
}
diff --git a/recipes/linux/linux-mtx-3_2.6.15.4.bb b/recipes/linux/linux-mtx-3_2.6.15.4.bb
index 25ed27ed33..32e57cce94 100644
--- a/recipes/linux/linux-mtx-3_2.6.15.4.bb
+++ b/recipes/linux/linux-mtx-3_2.6.15.4.bb
@@ -40,7 +40,7 @@ PACKAGE_ARCH = "mtx-3"
do_configure_prepend() {
install -m 0644 ${WORKDIR}/defconfig-mtx-3 ${S}/.config
- if [ "x${MTX_KERNEL_NON_PCI_OHCI}" == "xyes" ]; then
+ if [ "x${MTX_KERNEL_NON_PCI_OHCI}" = "xyes" ]; then
echo "CONFIG_USB_NON_PCI_OHCI=y" >> ${S}/.config
fi
}
diff --git a/recipes/linux/linux-mtx-3_2.6.15.bb b/recipes/linux/linux-mtx-3_2.6.15.bb
index 8bb3a821e2..98cad228e4 100644
--- a/recipes/linux/linux-mtx-3_2.6.15.bb
+++ b/recipes/linux/linux-mtx-3_2.6.15.bb
@@ -32,7 +32,7 @@ PACKAGE_ARCH = "mtx-3"
do_configure_prepend() {
install -m 0644 ${WORKDIR}/defconfig-mtx-3 ${S}/.config
- if [ "x${MTX_KERNEL_NON_PCI_OHCI}" == "xyes" ]; then
+ if [ "x${MTX_KERNEL_NON_PCI_OHCI}" = "xyes" ]; then
echo "CONFIG_USB_NON_PCI_OHCI=y" >> ${S}/.config
fi
}
diff --git a/recipes/linux/linux-navman_2.6.18.bb b/recipes/linux/linux-navman_2.6.18.bb
index 14bd10f11f..491a42489d 100644
--- a/recipes/linux/linux-navman_2.6.18.bb
+++ b/recipes/linux/linux-navman_2.6.18.bb
@@ -26,7 +26,7 @@ do_configure() {
fi
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
echo "CONFIG_AEABI=y" >> ${S}/.config
echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
else
diff --git a/recipes/linux/linux-palm-omap1_2.6.22-omap1.bb b/recipes/linux/linux-palm-omap1_2.6.22-omap1.bb
index fc1e974940..0c3705db97 100644
--- a/recipes/linux/linux-palm-omap1_2.6.22-omap1.bb
+++ b/recipes/linux/linux-palm-omap1_2.6.22-omap1.bb
@@ -25,7 +25,7 @@ do_configure() {
fi
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
echo "CONFIG_AEABI=y" >> ${S}/.config
echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
else
diff --git a/recipes/linux/linux-tornado-omap2_2.6.16.16.bb b/recipes/linux/linux-tornado-omap2_2.6.16.16.bb
index bea99a73e1..64f223d198 100644
--- a/recipes/linux/linux-tornado-omap2_2.6.16.16.bb
+++ b/recipes/linux/linux-tornado-omap2_2.6.16.16.bb
@@ -24,7 +24,7 @@ do_configure() {
fi
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
echo "CONFIG_AEABI=y" >> ${S}/.config
echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
else
diff --git a/recipes/linux/mx21ads-kernel_2.6.19rc6.bb b/recipes/linux/mx21ads-kernel_2.6.19rc6.bb
index 6891d7f4cf..19003def8d 100644
--- a/recipes/linux/mx21ads-kernel_2.6.19rc6.bb
+++ b/recipes/linux/mx21ads-kernel_2.6.19rc6.bb
@@ -26,7 +26,7 @@ RPROVIDES_kernel-image += "hostap-modules"
do_configure_prepend() {
install -m 0644 ${WORKDIR}/mx21ads_defconfig ${S}/defconfig
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
echo "CONFIG_AEABI=y" >> ${S}/.config
echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
else
diff --git a/recipes/linux/netbook-pro-kernel_2.6.17.bb b/recipes/linux/netbook-pro-kernel_2.6.17.bb
index 151a649889..f7dd4412ae 100644
--- a/recipes/linux/netbook-pro-kernel_2.6.17.bb
+++ b/recipes/linux/netbook-pro-kernel_2.6.17.bb
@@ -27,7 +27,7 @@ do_configure() {
fi
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-gnueabi" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
echo "CONFIG_AEABI=y" >> ${S}/.config
echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
else