aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorKhem Raj <kraj@leto.(none)>2010-12-24 08:30:13 -0800
committerKhem Raj <kraj@leto.(none)>2010-12-24 08:32:39 -0800
commit77ed93ab0e253c8df5d3761a373bd7d5ef61809d (patch)
tree48f04fd3a0ae754ac93be80534b4072894317a38 /recipes/linux
parent749b70fe1f310b4048c96ad887e1269040d56c3e (diff)
downloadopenembedded-77ed93ab0e253c8df5d3761a373bd7d5ef61809d.tar.gz
linux-efikamx: Use the tars from sources mirror.
* Original source is gone. * For git recipe use the gitorious repo ( fetch fails from gitorious for now) Signed-off-by: Khem Raj <kraj@leto.(none)>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-efikamx_2.6.31.bb20
-rw-r--r--recipes/linux/linux-efikamx_git+2.6.31.14.bb16
-rw-r--r--recipes/linux/linux-efikamx_git+2.6.36-rc7.bb16
3 files changed, 20 insertions, 32 deletions
diff --git a/recipes/linux/linux-efikamx_2.6.31.bb b/recipes/linux/linux-efikamx_2.6.31.bb
index e01e6c2949..0484a5b172 100644
--- a/recipes/linux/linux-efikamx_2.6.31.bb
+++ b/recipes/linux/linux-efikamx_2.6.31.bb
@@ -4,17 +4,7 @@ DESCRIPTION = "Linux kernel for EfikaMX platform"
KERNEL_IMAGETYPE = "uImage"
COMPATIBLE_MACHINE = "efikamx"
-
-python do_fetch () {
- import os,shutil
- bb.build.exec_func("base_do_fetch", d)
- if os.access(bb.data.expand("${DL_DIR}/73", d), os.R_OK):
- shutil.copy(bb.data.expand("${DL_DIR}/73", d), bb.data.expand("${DL_DIR}/${PN}-${PV}.tar.lzma", d))
-
- if os.access(bb.data.expand("${DL_DIR}/83", d), os.R_OK):
- shutil.copy(bb.data.expand("${DL_DIR}/83", d), bb.data.expand("${DL_DIR}/patch-${PV}.tar.lzma", d))
-}
-
+DEFAULT_PREFERENCE = "1"
python do_unpack () {
bb.build.exec_func('efikamx_kernel_do_unpack', d)
}
@@ -35,15 +25,13 @@ efikamx_kernel_do_patch (){
( cd ${S}; quilt push -a)
}
-SRC_URI += "http://www.powerdeveloper.org/asset/by-id/73;name=kernel \
- http://www.powerdeveloper.org/asset/by-id/83;name=patch \
+
+SRC_URI += "http://sources.openembedded.org/${P}.tar.lzma;name=kernel \
+ http://sources.openembedded.org/patch-${PV}.tar.lzma;name=patch \
file://remove-localversion.patch;apply=no \
"
SRC_URI[kernel.md5sum] = "c70ce0549cf85de79d5b28db7b552868"
SRC_URI[kernel.sha256sum] = "658395072352cd38477d80c105f00d824c73bf437f0843579d1e0bf41066617f"
-
SRC_URI[patch.md5sum] = "6c04416bce74dd413f3e82cd17378419"
SRC_URI[patch.sha256sum] = "5c15cffa02089d286fc07ba734b1f33a81d1f7ceaf70e596bd8b82ddd5e73ec2"
-
-S = "${WORKDIR}/${PN}-${PV}"
diff --git a/recipes/linux/linux-efikamx_git+2.6.31.14.bb b/recipes/linux/linux-efikamx_git+2.6.31.14.bb
new file mode 100644
index 0000000000..e0b98abe3e
--- /dev/null
+++ b/recipes/linux/linux-efikamx_git+2.6.31.14.bb
@@ -0,0 +1,16 @@
+require linux.inc
+
+FILESPATHPKG =. "linux-efikamx-git/${MACHINE}:"
+
+SRCREV = "efikasb-10.08.00-20101205"
+PV = "2.6.31.14"
+
+PR = "r0"
+
+#SRC_URI = "git://git.linaro.org/people/amitk/linux-2.6.git;branch=wip-efikamx-cleanup3;protocol=git \
+SRC_URI = "git://gitorious.org/efikamx/linux-kernel.git;branch=efikasb-10.08.00;protocol=git \
+ file://defconfig"
+
+COMPATIBLE_MACHINE = "(efikamx)"
+
+S = "${WORKDIR}/git"
diff --git a/recipes/linux/linux-efikamx_git+2.6.36-rc7.bb b/recipes/linux/linux-efikamx_git+2.6.36-rc7.bb
deleted file mode 100644
index 11e920196b..0000000000
--- a/recipes/linux/linux-efikamx_git+2.6.36-rc7.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-require linux.inc
-
-DEFAULT_PREFERENCE = "-1"
-FILESPATHPKG =. "linux-efikamx-git/${MACHINE}:"
-
-SRCREV = "85d9835be629110084a518f3c02ce852929fbff7"
-PV = "2.6.36-rc7"
-
-PR = "r0"
-
-SRC_URI = "git://git.linaro.org/people/amitk/linux-2.6.git;branch=wip-efikamx-cleanup3;protocol=git \
- file://defconfig"
-
-COMPATIBLE_MACHINE = "(efikamx)"
-
-S = "${WORKDIR}/git"