aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-06 20:55:58 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-07 00:26:59 +0200
commit840cae74251316150a6d7f0ef6466a66a7fd3757 (patch)
tree4793e7a0725e8447b1073b8bf60e358b1c06f115 /recipes/linux
parent4c29054b774675a3ac931ed3fe15ffc9f2ed7a60 (diff)
downloadopenembedded-840cae74251316150a6d7f0ef6466a66a7fd3757.tar.gz
linux-leviathan: bump; remove patch that has been applied upstream
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-leviathan/defconfig20
-rw-r--r--recipes/linux/linux-leviathan/restore-previous-backlight-level-on-resume.patch61
-rw-r--r--recipes/linux/linux-leviathan_git.bb8
3 files changed, 19 insertions, 70 deletions
diff --git a/recipes/linux/linux-leviathan/defconfig b/recipes/linux/linux-leviathan/defconfig
index 6f05a756d8..2330b5e850 100644
--- a/recipes/linux/linux-leviathan/defconfig
+++ b/recipes/linux/linux-leviathan/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.32
-# Mon Apr 5 16:18:45 2010
+# Mon Apr 5 16:42:35 2010
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -781,7 +781,6 @@ CONFIG_BLK_DEV_LOOP=y
# CONFIG_CDROM_PKTCDVD is not set
# CONFIG_ATA_OVER_ETH is not set
CONFIG_MISC_DEVICES=y
-CONFIG_ANDROID_PMEM=y
# CONFIG_ICS932S401 is not set
# CONFIG_ENCLOSURE_SERVICES is not set
# CONFIG_KERNEL_DEBUGGER_CORE is not set
@@ -852,7 +851,20 @@ CONFIG_NETDEV_1000=y
CONFIG_NETDEV_10000=y
CONFIG_WLAN=y
# CONFIG_WLAN_PRE80211 is not set
-# CONFIG_WLAN_80211 is not set
+CONFIG_WLAN_80211=y
+# CONFIG_LIBERTAS is not set
+# CONFIG_LIBERTAS_THINFIRM is not set
+# CONFIG_MAC80211_HWSIM is not set
+# CONFIG_P54_COMMON is not set
+# CONFIG_ATH_COMMON is not set
+# CONFIG_HOSTAP is not set
+# CONFIG_B43 is not set
+# CONFIG_B43LEGACY is not set
+# CONFIG_RT2X00 is not set
+CONFIG_WL12XX=m
+CONFIG_WL1251=m
+CONFIG_WL1251_SDIO=m
+# CONFIG_IWM is not set
#
# Enable WiMAX (Networking options) to see the WiMAX drivers
@@ -1770,7 +1782,7 @@ CONFIG_CRC16=y
# CONFIG_CRC_T10DIF is not set
# CONFIG_CRC_ITU_T is not set
CONFIG_CRC32=y
-# CONFIG_CRC7 is not set
+CONFIG_CRC7=m
CONFIG_LIBCRC32C=m
CONFIG_ZLIB_INFLATE=y
CONFIG_ZLIB_DEFLATE=y
diff --git a/recipes/linux/linux-leviathan/restore-previous-backlight-level-on-resume.patch b/recipes/linux/linux-leviathan/restore-previous-backlight-level-on-resume.patch
deleted file mode 100644
index a070d1adf0..0000000000
--- a/recipes/linux/linux-leviathan/restore-previous-backlight-level-on-resume.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-#
-# Restore previous backlight level as set by userland on resume.
-#
-# Signed-off-by: Michael 'Mickey' Lauer <mlauer@vanille-media.de>
-#
-diff --git a/arch/arm/mach-msm/board-trout-panel.c b/arch/arm/mach-msm/board-trout-panel.c
-index abee24d..1c896ab 100644
---- a/arch/arm/mach-msm/board-trout-panel.c
-+++ b/arch/arm/mach-msm/board-trout-panel.c
-@@ -22,11 +22,11 @@
- #include "proc_comm.h"
- #include "devices.h"
-
--#define TROUT_DEFAULT_BACKLIGHT_BRIGHTNESS 255
-+#define TROUT_DEFAULT_BACKLIGHT_BRIGHTNESS 127
-
- static struct clk *gp_clk;
- static int trout_backlight_off;
--static int trout_backlight_brightness = TROUT_DEFAULT_BACKLIGHT_BRIGHTNESS;
-+static int trout_backlight_resume_level = TROUT_DEFAULT_BACKLIGHT_BRIGHTNESS;
- static int trout_new_backlight = 1;
- static uint8_t trout_backlight_last_level = 33;
- static DEFINE_MUTEX(trout_backlight_lock);
-@@ -443,7 +443,7 @@ static int trout_mddi_panel_unblank(
- {
-
- int panel_id, ret = 0;
--
-+
- trout_set_backlight_level(0);
- client_data->auto_hibernate(client_data, 0);
- trout_process_mddi_table(client_data, mddi_toshiba_panel_init_table,
-@@ -467,7 +467,7 @@ static int trout_mddi_panel_unblank(
- ret = -1;
- };
- mutex_lock(&trout_backlight_lock);
-- trout_set_backlight_level(trout_backlight_brightness);
-+ trout_set_backlight_level(trout_backlight_resume_level);
- trout_backlight_off = 0;
- mutex_unlock(&trout_backlight_lock);
- client_data->auto_hibernate(client_data, 1);
-@@ -517,6 +517,10 @@ static int trout_brightness_set(struct backlight_device *bd)
- int intensity;
- mutex_lock(&trout_backlight_lock);
- intensity = bd->props.brightness;
-+
-+ /* remember last backlight level as requested by user */
-+ trout_backlight_resume_level = intensity;
-+
- if(!trout_backlight_off)
- trout_set_backlight_level(intensity);
- mutex_unlock(&trout_backlight_lock);
-@@ -534,7 +538,7 @@ static struct backlight_ops trout_backlight_ops = {
- };
-
- static int trout_backlight_probe(struct platform_device *pdev)
--{
-+{
- struct backlight_device *bd;
- bd = backlight_device_register("trout-backlight", &pdev->dev, NULL, &trout_backlight_ops);
- bd->props.max_brightness = TROUT_DEFAULT_BACKLIGHT_BRIGHTNESS;
diff --git a/recipes/linux/linux-leviathan_git.bb b/recipes/linux/linux-leviathan_git.bb
index 98259feeb5..3d4607144f 100644
--- a/recipes/linux/linux-leviathan_git.bb
+++ b/recipes/linux/linux-leviathan_git.bb
@@ -2,21 +2,19 @@ require linux.inc
DEPENDS = "android-image-utils-native"
PV = "2.6.32+${PR}+gitr${SRCREV}"
-PR = "r9"
+PR = "r11"
COMPATIBLE_MACHINE = "htcdream"
-CMDLINE = "console=tty1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M"
+CMDLINE = "console=tty1 no_console_suspend=1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M"
#CMDLINE = "console=tty1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M earlysuspend.debug_mask=3"
SRCREV_LAST_GOOD = "00243f441ef12bd6823007759c7c1fc91ecda55d"
-SRCREV = "6da1f24ce9110b49866304ad5eaa29bfbdc248df"
+SRCREV = "e94465547ea4b765024ff08c36afffb5664f3121"
SRC_URI = "\
git://gitorious.org/htc-msm-2-6-32/leviathan-incoming.git;protocol=git;branch=msm-gnuconform \
file://defconfig \
- \
- file://restore-previous-backlight-level-on-resume.patch;patch=1 \
"
S = "${WORKDIR}/git"