aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-04 22:56:55 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-04 22:57:28 +0200
commitfb1c323ad65b29db806758fc6839f8d76ef3783c (patch)
treeb65507bec24fe0ebd4eb7041b7177b6c8e3da6f5 /recipes/linux
parent0ed84776ef76c430c5c4cbd27812c8426813360f (diff)
downloadopenembedded-fb1c323ad65b29db806758fc6839f8d76ef3783c.tar.gz
linux-leviathan: apply patch to restore backlight level to previous version
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-leviathan/defconfig10
-rw-r--r--recipes/linux/linux-leviathan/restore-previous-backlight-level-on-resume.patch61
-rw-r--r--recipes/linux/linux-leviathan_git.bb6
3 files changed, 72 insertions, 5 deletions
diff --git a/recipes/linux/linux-leviathan/defconfig b/recipes/linux/linux-leviathan/defconfig
index db0def5437..e189a83a15 100644
--- a/recipes/linux/linux-leviathan/defconfig
+++ b/recipes/linux/linux-leviathan/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.32
-# Wed Mar 31 18:39:17 2010
+# Sun Apr 4 22:06:41 2010
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -315,7 +315,7 @@ CONFIG_ALIGNMENT_TRAP=y
#
CONFIG_ZBOOT_ROM_TEXT=0x0
CONFIG_ZBOOT_ROM_BSS=0x0
-CONFIG_CMDLINE="console=tty0 no_console_suspend=1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M debug "
+CONFIG_CMDLINE="console=tty1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M debug "
# CONFIG_XIP_KERNEL is not set
# CONFIG_KEXEC is not set
@@ -362,8 +362,10 @@ CONFIG_HAVE_AOUT=y
#
CONFIG_PM=y
# CONFIG_PM_DEBUG is not set
+# CONFIG_PM_VERBOSE is not set
CONFIG_PM_SLEEP=y
CONFIG_SUSPEND=y
+# CONFIG_PM_TEST_SUSPEND is not set
CONFIG_SUSPEND_FREEZER=y
CONFIG_HAS_WAKELOCK=y
CONFIG_HAS_EARLYSUSPEND=y
@@ -371,8 +373,8 @@ CONFIG_WAKELOCK=y
CONFIG_WAKELOCK_STAT=y
CONFIG_USER_WAKELOCK=y
CONFIG_EARLYSUSPEND=y
-# CONFIG_NO_USER_SPACE_SCREEN_ACCESS_CONTROL is not set
-CONFIG_CONSOLE_EARLYSUSPEND=y
+CONFIG_NO_USER_SPACE_SCREEN_ACCESS_CONTROL=y
+# CONFIG_CONSOLE_EARLYSUSPEND is not set
# CONFIG_FB_EARLYSUSPEND is not set
# CONFIG_APM_EMULATION is not set
# CONFIG_PM_RUNTIME is not set
diff --git a/recipes/linux/linux-leviathan/restore-previous-backlight-level-on-resume.patch b/recipes/linux/linux-leviathan/restore-previous-backlight-level-on-resume.patch
new file mode 100644
index 0000000000..a070d1adf0
--- /dev/null
+++ b/recipes/linux/linux-leviathan/restore-previous-backlight-level-on-resume.patch
@@ -0,0 +1,61 @@
+#
+# Restore previous backlight level as set by userland on resume.
+#
+# Signed-off-by: Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+#
+diff --git a/arch/arm/mach-msm/board-trout-panel.c b/arch/arm/mach-msm/board-trout-panel.c
+index abee24d..1c896ab 100644
+--- a/arch/arm/mach-msm/board-trout-panel.c
++++ b/arch/arm/mach-msm/board-trout-panel.c
+@@ -22,11 +22,11 @@
+ #include "proc_comm.h"
+ #include "devices.h"
+
+-#define TROUT_DEFAULT_BACKLIGHT_BRIGHTNESS 255
++#define TROUT_DEFAULT_BACKLIGHT_BRIGHTNESS 127
+
+ static struct clk *gp_clk;
+ static int trout_backlight_off;
+-static int trout_backlight_brightness = TROUT_DEFAULT_BACKLIGHT_BRIGHTNESS;
++static int trout_backlight_resume_level = TROUT_DEFAULT_BACKLIGHT_BRIGHTNESS;
+ static int trout_new_backlight = 1;
+ static uint8_t trout_backlight_last_level = 33;
+ static DEFINE_MUTEX(trout_backlight_lock);
+@@ -443,7 +443,7 @@ static int trout_mddi_panel_unblank(
+ {
+
+ int panel_id, ret = 0;
+-
++
+ trout_set_backlight_level(0);
+ client_data->auto_hibernate(client_data, 0);
+ trout_process_mddi_table(client_data, mddi_toshiba_panel_init_table,
+@@ -467,7 +467,7 @@ static int trout_mddi_panel_unblank(
+ ret = -1;
+ };
+ mutex_lock(&trout_backlight_lock);
+- trout_set_backlight_level(trout_backlight_brightness);
++ trout_set_backlight_level(trout_backlight_resume_level);
+ trout_backlight_off = 0;
+ mutex_unlock(&trout_backlight_lock);
+ client_data->auto_hibernate(client_data, 1);
+@@ -517,6 +517,10 @@ static int trout_brightness_set(struct backlight_device *bd)
+ int intensity;
+ mutex_lock(&trout_backlight_lock);
+ intensity = bd->props.brightness;
++
++ /* remember last backlight level as requested by user */
++ trout_backlight_resume_level = intensity;
++
+ if(!trout_backlight_off)
+ trout_set_backlight_level(intensity);
+ mutex_unlock(&trout_backlight_lock);
+@@ -534,7 +538,7 @@ static struct backlight_ops trout_backlight_ops = {
+ };
+
+ static int trout_backlight_probe(struct platform_device *pdev)
+-{
++{
+ struct backlight_device *bd;
+ bd = backlight_device_register("trout-backlight", &pdev->dev, NULL, &trout_backlight_ops);
+ bd->props.max_brightness = TROUT_DEFAULT_BACKLIGHT_BRIGHTNESS;
diff --git a/recipes/linux/linux-leviathan_git.bb b/recipes/linux/linux-leviathan_git.bb
index c5f168d8cd..34a01a6245 100644
--- a/recipes/linux/linux-leviathan_git.bb
+++ b/recipes/linux/linux-leviathan_git.bb
@@ -2,17 +2,21 @@ require linux.inc
DEPENDS = "android-image-utils-native"
PV = "2.6.32+${PR}+gitr${SRCREV}"
-PR = "r6"
+PR = "r7"
COMPATIBLE_MACHINE = "htcdream"
CMDLINE = "console=tty1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M"
+#CMDLINE = "console=tty1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M earlysuspend.debug_mask=3"
+
SRCREV_LAST_GOOD = "48afbaf19428893b7aec0a385970f300c38300c3"
SRCREV = "00243f441ef12bd6823007759c7c1fc91ecda55d"
SRC_URI = "\
git://gitorious.org/htc-msm-2-6-32/leviathan-incoming.git;protocol=git;branch=msm-gnuconform \
file://defconfig \
+ \
+ file://restore-previous-backlight-level-on-resume.patch;patch=1 \
"
S = "${WORKDIR}/git"