aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-29 12:56:54 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-29 17:18:10 +0200
commit538436ae6d7f0e48d93d9d6d5c219fb1788bb820 (patch)
treec9189dc0fa3fc446c4db6f8faa27d1e3b670cc51 /recipes/linux
parente17c4225387fc46e6687c4e19d04d169d801d280 (diff)
downloadopenembedded-538436ae6d7f0e48d93d9d6d5c219fb1788bb820.tar.gz
linux-openmoko-2.6.34: add patch for resume
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch24
-rw-r--r--recipes/linux/linux-openmoko-2.6.34_git.bb4
2 files changed, 27 insertions, 1 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch b/recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch
new file mode 100644
index 0000000000..fa3b1389a5
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch
@@ -0,0 +1,24 @@
+From ceee4a77574ebb8fe211043731f64f585f87b7de Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Tue, 29 Jun 2010 12:54:03 +0200
+Subject: [PATCH] glamo-mci: add MMC_CAP_NONREMOVABLE
+
+---
+ drivers/mmc/host/glamo-mci.c | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/drivers/mmc/host/glamo-mci.c b/drivers/mmc/host/glamo-mci.c
+index b2442c2..7c96b4c 100644
+--- a/drivers/mmc/host/glamo-mci.c
++++ b/drivers/mmc/host/glamo-mci.c
+@@ -811,6 +811,7 @@ static int glamo_mci_probe(struct platform_device *pdev)
+ mmc->ocr_avail = mmc_regulator_get_ocrmask(host->regulator);
+ mmc->caps = MMC_CAP_4_BIT_DATA |
+ MMC_CAP_MMC_HIGHSPEED |
++ MMC_CAP_NONREMOVABLE |
+ MMC_CAP_SD_HIGHSPEED;
+ mmc->f_min = host->clk_rate / 256;
+ mmc->f_max = sd_max_clk;
+--
+1.7.1
+
diff --git a/recipes/linux/linux-openmoko-2.6.34_git.bb b/recipes/linux/linux-openmoko-2.6.34_git.bb
index 73d8be4341..7381123c6e 100644
--- a/recipes/linux/linux-openmoko-2.6.34_git.bb
+++ b/recipes/linux/linux-openmoko-2.6.34_git.bb
@@ -4,7 +4,7 @@ require linux-openmoko.inc
KERNEL_RELEASE="2.6.34"
SRCREV = "4ce5f33cd4bcde2e25d50ae0880eb39213e2b6d2"
-OEV = "oe4"
+OEV = "oe4.1"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
SRC_URI = "\
@@ -29,6 +29,8 @@ SRC_URI = "\
file://0002-usbhost.patch.patch \
file://0003-ar6000_delay.patch.patch \
file://0004-save_regs.patch.patch \
+# possible resume fix
+ file://0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch \
file://defconfig \
"