aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-06-26 02:10:20 +0200
committerAndrea Adami <andrea.adami@gmail.com>2010-06-26 02:10:20 +0200
commit9e6b31163c44c6b4a306ad5961dda55ee847ffaa (patch)
tree0b08f7b8f42c7bdc9ba99a34ae1e0e54881352e4 /recipes/linux
parentd0f0af2e646b607c1121af5292e8f809a2c47aec (diff)
downloadopenembedded-9e6b31163c44c6b4a306ad5961dda55ee847ffaa.tar.gz
linux: add pending patch for c7x0 to 2.6.34
* unbreak corgi mmc/sd detection. Signed-off-by: Eric Miao <eric.y.miao@gmail.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-2.6.34/c7x0/fix-corgi-card-detection.patch17
-rw-r--r--recipes/linux/linux_2.6.34.bb6
2 files changed, 21 insertions, 2 deletions
diff --git a/recipes/linux/linux-2.6.34/c7x0/fix-corgi-card-detection.patch b/recipes/linux/linux-2.6.34/c7x0/fix-corgi-card-detection.patch
new file mode 100644
index 0000000000..7ef01de119
--- /dev/null
+++ b/recipes/linux/linux-2.6.34/c7x0/fix-corgi-card-detection.patch
@@ -0,0 +1,17 @@
+[PATCH] [ARM] pxa/corgi: fix MMC/SD card detection failure
+
+Reported-by: Andrea Adami <andrea.adami@gmail.com>
+Signed-off-by: Eric Miao <eric.y.miao@gmail.com>
+---
+--- a/arch/arm/mach-pxa/corgi.c
++++ b/arch/arm/mach-pxa/corgi.c
+@@ -438,7 +438,7 @@
+ */
+ static struct pxamci_platform_data corgi_mci_platform_data = {
+ .ocr_mask = MMC_VDD_32_33|MMC_VDD_33_34,
+- .gpio_card_detect = -1,
++ .gpio_card_detect = CORGI_GPIO_nSD_DETECT,
+ .gpio_card_ro = CORGI_GPIO_nSD_WP,
+ .gpio_power = CORGI_GPIO_SD_PWR,
+ };
+
diff --git a/recipes/linux/linux_2.6.34.bb b/recipes/linux/linux_2.6.34.bb
index 6c2b4ea26b..c001d1b6b7 100644
--- a/recipes/linux/linux_2.6.34.bb
+++ b/recipes/linux/linux_2.6.34.bb
@@ -2,7 +2,7 @@ require linux.inc
PR = "r1"
-module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
+module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
@@ -16,8 +16,10 @@ DEFAULT_PREFERENCE_omap5912osk = "1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/${P}.tar.bz2;name=kernel \
file://ARM-Add-support-for-LZMA-compressed-kernel-images.patch;status=pending \
- file://use-noclone-attribute-for-naked.patch;status=pending \
+ file://use-noclone-attribute-for-naked.patch;status=pending \
file://defconfig"
+SRC_URI_append_c7x0 = " file://fix-corgi-card-detection.patch;status=pending "
+
SRC_URI[kernel.md5sum] = "10eebcb0178fb4540e2165bfd7efc7ad"
SRC_URI[kernel.sha256sum] = "fa395fec7de633df1cb85b6248b8f35af98380ed128a8bc465fb48bc4d252633"