aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-30 15:11:39 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-07-14 02:19:19 +0200
commitc7c2d15ab69075992f26d3f0ba31a0e2b8805e8b (patch)
treedbb7f2964bda3f288c6fade96f721894bf624b5f /recipes/linux
parent1a35b6063591e39cb54f30188a0f8baa36c5f61b (diff)
downloadopenembedded-c7c2d15ab69075992f26d3f0ba31a0e2b8805e8b.tar.gz
linux-openmoko-2.6.34: bump SRCREV, try to disable UBI debug and reenable background thread (seems to work now)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch37
-rw-r--r--recipes/linux/linux-openmoko-2.6.34/om-gta02/defconfig10
-rw-r--r--recipes/linux/linux-openmoko-2.6.34_git.bb6
3 files changed, 7 insertions, 46 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch b/recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch
deleted file mode 100644
index 1f996fafaf..0000000000
--- a/recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 10e7f7b2132aaac8e3ebc549d3837cc2df888df7 Mon Sep 17 00:00:00 2001
-From: Thibaut Girka <thib@sitedethib.com>
-Date: Tue, 29 Jun 2010 12:54:03 +0200
-Subject: [PATCH] glamo-mci: add MMC_CAP_NONREMOVABLE and move enable_irq to right place
-
----
- drivers/mmc/host/glamo-mci.c | 5 +++--
- 1 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/drivers/mmc/host/glamo-mci.c b/drivers/mmc/host/glamo-mci.c
-index b2442c2..11deb7d 100644
---- a/drivers/mmc/host/glamo-mci.c
-+++ b/drivers/mmc/host/glamo-mci.c
-@@ -811,6 +811,7 @@ static int glamo_mci_probe(struct platform_device *pdev)
- mmc->ocr_avail = mmc_regulator_get_ocrmask(host->regulator);
- mmc->caps = MMC_CAP_4_BIT_DATA |
- MMC_CAP_MMC_HIGHSPEED |
-+ MMC_CAP_NONREMOVABLE |
- MMC_CAP_SD_HIGHSPEED;
- mmc->f_min = host->clk_rate / 256;
- mmc->f_max = sd_max_clk;
-@@ -930,10 +931,10 @@ static int glamo_mci_resume(struct device *dev)
- glamo_mci_reset(host);
- mdelay(10);
-
-- ret = mmc_resume_host(host->mmc);
--
- enable_irq(host->irq);
-
-+ ret = mmc_resume_host(host->mmc);
-+
- mmc_host_lazy_disable(host->mmc);
-
- return ret;
---
-1.7.1
-
diff --git a/recipes/linux/linux-openmoko-2.6.34/om-gta02/defconfig b/recipes/linux/linux-openmoko-2.6.34/om-gta02/defconfig
index 1ef24e5437..c54bd40a46 100644
--- a/recipes/linux/linux-openmoko-2.6.34/om-gta02/defconfig
+++ b/recipes/linux/linux-openmoko-2.6.34/om-gta02/defconfig
@@ -907,10 +907,10 @@ CONFIG_MTD_UBI_GLUEBI=y
#
# UBI debugging options
#
-CONFIG_MTD_UBI_DEBUG=y
+# CONFIG_MTD_UBI_DEBUG is not set
# CONFIG_MTD_UBI_DEBUG_MSG is not set
# CONFIG_MTD_UBI_DEBUG_PARANOID is not set
-CONFIG_MTD_UBI_DEBUG_DISABLE_BGT=y
+# CONFIG_MTD_UBI_DEBUG_DISABLE_BGT is not set
# CONFIG_MTD_UBI_DEBUG_EMULATE_BITFLIPS is not set
# CONFIG_MTD_UBI_DEBUG_EMULATE_WRITE_FAILURES is not set
# CONFIG_MTD_UBI_DEBUG_EMULATE_ERASE_FAILURES is not set
@@ -1951,9 +1951,9 @@ CONFIG_UBIFS_FS_XATTR=y
CONFIG_UBIFS_FS_ADVANCED_COMPR=y
CONFIG_UBIFS_FS_LZO=y
CONFIG_UBIFS_FS_ZLIB=y
-CONFIG_UBIFS_FS_DEBUG=y
-CONFIG_UBIFS_FS_DEBUG_MSG_LVL=0
-CONFIG_UBIFS_FS_DEBUG_CHKS=y
+# CONFIG_UBIFS_FS_DEBUG is not set
+# CONFIG_UBIFS_FS_DEBUG_MSG_LVL is not set
+# CONFIG_UBIFS_FS_DEBUG_CHKS is not set
# CONFIG_LOGFS is not set
# CONFIG_CRAMFS is not set
CONFIG_SQUASHFS=m
diff --git a/recipes/linux/linux-openmoko-2.6.34_git.bb b/recipes/linux/linux-openmoko-2.6.34_git.bb
index 5ba2196ce8..6b21e01a0d 100644
--- a/recipes/linux/linux-openmoko-2.6.34_git.bb
+++ b/recipes/linux/linux-openmoko-2.6.34_git.bb
@@ -3,8 +3,8 @@ require linux-openmoko.inc
KERNEL_RELEASE="2.6.34"
-SRCREV = "4ce5f33cd4bcde2e25d50ae0880eb39213e2b6d2"
-OEV = "oe4.2"
+SRCREV = "3f6725d43021d2d7597027e36020df5b44d0667e"
+OEV = "oe4.3"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
SRC_URI = "\
@@ -29,8 +29,6 @@ SRC_URI = "\
file://0002-usbhost.patch.patch \
file://0003-ar6000_delay.patch.patch \
file://0004-save_regs.patch.patch \
-# possible resume fix
- file://0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch \
file://defconfig \
"