aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorSteffen Sledz <sledz@dresearch.de>2010-09-28 10:11:33 +0200
committerSteffen Sledz <sledz@dresearch.de>2010-09-28 10:11:33 +0200
commitcc233c9bee7ad2361b20ac4e332dc2431badda50 (patch)
tree027766e8880e6eedf3aa60d5566a28612775b6a5 /recipes/linux
parent1c8fbc364a52d64731cbc092c7b97bd54a9098d4 (diff)
downloadopenembedded-cc233c9bee7ad2361b20ac4e332dc2431badda50.tar.gz
ubifs-v2.6.24: avoid kernel error if ubifs superblock read fails
original commit comment from ubifs-2.6.git: .get_sb is called on mounts with automatic fs detection too, so this function should print an error if it cannot read the superblock in debug mode only (new behaviour conforms the other fs types) Signed-off-by: Steffen Sledz <sledz@dresearch.de>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-2.6.24/ubifs-v2.6.24-silent-get-sb.patch33
-rw-r--r--recipes/linux/linux_2.6.24.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes/linux/linux-2.6.24/ubifs-v2.6.24-silent-get-sb.patch b/recipes/linux/linux-2.6.24/ubifs-v2.6.24-silent-get-sb.patch
new file mode 100644
index 0000000000..c32544bc63
--- /dev/null
+++ b/recipes/linux/linux-2.6.24/ubifs-v2.6.24-silent-get-sb.patch
@@ -0,0 +1,33 @@
+From 54dd55a406f6e9cb5ae208f258b907455162e045 Mon Sep 17 00:00:00 2001
+From: Steffen Sledz <sledz@dresearch.de>
+Date: Mon, 27 Sep 2010 14:20:26 +0200
+Subject: [PATCH] UBIFS: avoid kernel error if ubifs superblock read fails
+
+.get_sb is called on mounts with automatic fs detection too, so this
+function should print an error if it cannot read the superblock in
+debug mode only (new behaviour conforms the other fs types)
+
+Signed-off-by: Steffen Sledz <sledz@dresearch.de>
+Signed-off-by: Artem Bityutskiy <Artem.Bityutskiy@nokia.com>
+---
+ fs/ubifs/super.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/fs/ubifs/super.c b/fs/ubifs/super.c
+index 4e5bf3f..bb6ed5d 100644
+--- a/fs/ubifs/super.c
++++ b/fs/ubifs/super.c
+@@ -2054,8 +2054,8 @@ static int ubifs_get_sb(struct file_system_type *fs_type, int flags,
+ */
+ ubi = open_ubi(name, UBI_READONLY);
+ if (IS_ERR(ubi)) {
+- ubifs_err("cannot open \"%s\", error %d",
+- name, (int)PTR_ERR(ubi));
++ dbg_err("cannot open \"%s\", error %d",
++ name, (int)PTR_ERR(ubi));
+ return PTR_ERR(ubi);
+ }
+ ubi_get_volume_info(ubi, &vi);
+--
+1.7.2.2
+
diff --git a/recipes/linux/linux_2.6.24.bb b/recipes/linux/linux_2.6.24.bb
index 9f3655c585..982038bf75 100644
--- a/recipes/linux/linux_2.6.24.bb
+++ b/recipes/linux/linux_2.6.24.bb
@@ -17,6 +17,7 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2;name=k
${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.7.bz2;apply=yes;name=stablepatch \
file://squashfs-lzma-2.6.24.patch \
file://ubifs-v2.6.24.patch \
+ file://ubifs-v2.6.24-silent-get-sb.patch \
file://defconfig"
# Moved away temporarely until committed properly (work in progress).