aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-09-10 08:58:20 +0200
committerKoen Kooi <koen@openembedded.org>2010-09-10 08:58:20 +0200
commit5a7d77d927a934a6c8ce0cb6fb552f679f34877a (patch)
tree127c4338b41562e153b465d21431044b775836e1 /recipes/linux
parente2715ccb6846f77e63fd4701f0886f2c0011e057 (diff)
downloadopenembedded-5a7d77d927a934a6c8ce0cb6fb552f679f34877a.tar.gz
linux-omap-psp 2.6.32: OMAP: DSS2: OMAPFB: swap front and back porches for both hsync and vsync
Framebuffer's left and right margins are relative to the active pixel area. Front and back porches are relative to the sync area. Left margin was wrongly assigned to front porch (and right to back), this patch fixes it.
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/porches.patch55
-rw-r--r--recipes/linux/linux-omap-psp_2.6.32.bb1
2 files changed, 56 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap-psp-2.6.32/porches.patch b/recipes/linux/linux-omap-psp-2.6.32/porches.patch
new file mode 100644
index 0000000000..630af6f1bd
--- /dev/null
+++ b/recipes/linux/linux-omap-psp-2.6.32/porches.patch
@@ -0,0 +1,55 @@
+From 00a84122fd2c1974f6dc79fce11a34154caab848 Mon Sep 17 00:00:00 2001
+From: Tasslehoff Kjappfot <tasskjapp@gmail.com>
+Date: Wed, 8 Sep 2010 12:46:14 +0200
+Subject: [PATCH] OMAP: DSS2: OMAPFB: swap front and back porches for both hsync and vsync
+
+Framebuffer's left and right margins are relative to the active pixel
+area. Front and back porches are relative to the sync area.
+
+Left margin was wrongly assigned to front porch (and right to back),
+this patch fixes it.
+
+Signed-off-by: tasskjapp@gmail.com
+Reviewed-by: Russ.Dill@gmail.com
+Signed-off-by: Tomi Valkeinen <tomi.valkeinen@nokia.com>
+---
+ drivers/video/omap2/omapfb/omapfb-main.c | 16 ++++++++--------
+ 1 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/drivers/video/omap2/omapfb/omapfb-main.c b/drivers/video/omap2/omapfb/omapfb-main.c
+index 39f53b1..bddfca6 100644
+--- a/drivers/video/omap2/omapfb/omapfb-main.c
++++ b/drivers/video/omap2/omapfb/omapfb-main.c
+@@ -714,10 +714,10 @@ int check_fb_var(struct fb_info *fbi, struct fb_var_screeninfo *var)
+ var->pixclock = timings.pixel_clock != 0 ?
+ KHZ2PICOS(timings.pixel_clock) :
+ 0;
+- var->left_margin = timings.hfp;
+- var->right_margin = timings.hbp;
+- var->upper_margin = timings.vfp;
+- var->lower_margin = timings.vbp;
++ var->left_margin = timings.hbp;
++ var->right_margin = timings.hfp;
++ var->upper_margin = timings.vbp;
++ var->lower_margin = timings.vfp;
+ var->hsync_len = timings.hsw;
+ var->vsync_len = timings.vsw;
+ } else {
+@@ -2059,10 +2059,10 @@ static int omapfb_mode_to_timings(const char *mode_str,
+
+ if (r != 0) {
+ timings->pixel_clock = PICOS2KHZ(var.pixclock);
+- timings->hfp = var.left_margin;
+- timings->hbp = var.right_margin;
+- timings->vfp = var.upper_margin;
+- timings->vbp = var.lower_margin;
++ timings->hbp = var.left_margin;
++ timings->hfp = var.right_margin;
++ timings->vbp = var.upper_margin;
++ timings->vfp = var.lower_margin;
+ timings->hsw = var.hsync_len;
+ timings->vsw = var.vsync_len;
+ timings->x_res = var.xres;
+--
+1.6.1
+
diff --git a/recipes/linux/linux-omap-psp_2.6.32.bb b/recipes/linux/linux-omap-psp_2.6.32.bb
index 2a49dbe8c0..3d31f7d973 100644
--- a/recipes/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes/linux/linux-omap-psp_2.6.32.bb
@@ -133,6 +133,7 @@ SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=gi
file://cam/0001-Move-sensor-rest-to-after-applying-power.patch \
file://0001-BeagleBoard-Adjust-USER-button-pin-for-xM.patch \
file://cam/0001-omap3beagle-Add-camera-bootarg.patch \
+ file://porches.patch \
file://defconfig"
SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \