aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-10-05 19:17:56 +0200
committerJeremy Lainé <jeremy.laine@m4x.org>2009-10-05 19:17:56 +0200
commit5d021e5237305dbcc2004816dbaf9cb5f273442f (patch)
tree0e49220db147ec322a91a33c58b550339d440fda /recipes/linux
parent280be5d65abd35492163f78c602c695cecf7c43c (diff)
downloadopenembedded-5d021e5237305dbcc2004816dbaf9cb5f273442f.tar.gz
linux-2.6.29: update SPI patch for boc01
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-2.6.29/boc01/001-090114-sqn11x0-usb-hack.patch17
-rw-r--r--recipes/linux/linux-2.6.29/boc01/008-091005-spi.patch (renamed from recipes/linux/linux-2.6.29/boc01/008-081208-spi.patch)24
-rw-r--r--recipes/linux/linux_2.6.29.bb2
3 files changed, 8 insertions, 35 deletions
diff --git a/recipes/linux/linux-2.6.29/boc01/001-090114-sqn11x0-usb-hack.patch b/recipes/linux/linux-2.6.29/boc01/001-090114-sqn11x0-usb-hack.patch
deleted file mode 100644
index 4bd44e25db..0000000000
--- a/recipes/linux/linux-2.6.29/boc01/001-090114-sqn11x0-usb-hack.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -ur linux-2.6.27.orig/drivers/usb/host/ehci-q.c linux-2.6.27/drivers/usb/host/ehci-q.c
---- linux-2.6.27.orig/drivers/usb/host/ehci-q.c 2008-10-10 00:13:53.000000000 +0200
-+++ linux-2.6.27/drivers/usb/host/ehci-q.c 2009-01-06 18:31:38.000000000 +0100
-@@ -799,7 +799,12 @@
- * to help them do so. So now people expect to use
- * such nonconformant devices with Linux too; sigh.
- */
-- info1 |= max_packet(maxp) << 16;
-+ struct usb_device_descriptor *desc = &urb->dev->descriptor;
-+ if (desc->idVendor == cpu_to_le16(0x148e) && desc->idProduct == cpu_to_le16(0x0900)) {
-+ info1 |= 256 << 16;
-+ } else {
-+ info1 |= max_packet(maxp) << 16;
-+ }
- info2 |= (EHCI_TUNE_MULT_HS << 30);
- } else { /* PIPE_INTERRUPT */
- info1 |= max_packet (maxp) << 16;
diff --git a/recipes/linux/linux-2.6.29/boc01/008-081208-spi.patch b/recipes/linux/linux-2.6.29/boc01/008-091005-spi.patch
index 9c9e402ea3..dce5b59f85 100644
--- a/recipes/linux/linux-2.6.29/boc01/008-081208-spi.patch
+++ b/recipes/linux/linux-2.6.29/boc01/008-091005-spi.patch
@@ -1,8 +1,8 @@
Index: linux-2.6.29/arch/powerpc/platforms/83xx/mpc831x_rdb.c
===================================================================
---- linux-2.6.29.orig/arch/powerpc/platforms/83xx/mpc831x_rdb.c 2009-03-24 00:12:14.000000000 +0100
-+++ linux-2.6.29/arch/powerpc/platforms/83xx/mpc831x_rdb.c 2009-04-01 17:37:53.000000000 +0200
-@@ -15,17 +15,87 @@
+--- linux-2.6.29.orig/arch/powerpc/platforms/83xx/mpc831x_rdb.c 2009-10-05 18:55:57.000000000 +0200
++++ linux-2.6.29/arch/powerpc/platforms/83xx/mpc831x_rdb.c 2009-10-05 18:57:15.000000000 +0200
+@@ -15,17 +15,78 @@
#include <linux/pci.h>
#include <linux/of_platform.h>
@@ -32,7 +32,6 @@ Index: linux-2.6.29/arch/powerpc/platforms/83xx/mpc831x_rdb.c
+
+static void mpc83xx_spi_activate_cs(u8 cs, u8 polarity)
+{
-+ //printk(KERN_INFO "%s %d %d\n", __func__, cs, polarity);
+ if (polarity)
+ setbits32(&gpio_regs->gpdat, 1 << (31 - 14));
+ else
@@ -41,7 +40,6 @@ Index: linux-2.6.29/arch/powerpc/platforms/83xx/mpc831x_rdb.c
+
+static void mpc83xx_spi_deactivate_cs(u8 cs, u8 polarity)
+{
-+//printk(KERN_INFO "%s %d %d\n", __func__, cs, polarity);
+ if (polarity)
+ clrbits32(&gpio_regs->gpdat, 1 << (31 - 14));
+ else
@@ -49,16 +47,11 @@ Index: linux-2.6.29/arch/powerpc/platforms/83xx/mpc831x_rdb.c
+
+}
+
-+//static struct mmc_spi_platform_data mpc8313_mmc_pdata = {
-+// .ocr_mask = MMC_VDD_33_34,
-+//};
-+
+static struct spi_board_info mpc8313_spi_boardinfo = {
+ .bus_num = 0x7000,
+ .chip_select = 0,
+ .max_speed_hz = 50000000,
+ .modalias = "spidev",
-+// .platform_data = &mpc8313_mmc_pdata,
+};
+
+static int __init mpc8313_spi_init(void)
@@ -85,24 +78,21 @@ Index: linux-2.6.29/arch/powerpc/platforms/83xx/mpc831x_rdb.c
+ mpc83xx_spi_deactivate_cs);
+}
+
-+device_initcall(mpc8313_spi_init);
-+
static void __init mpc831x_rdb_setup_arch(void)
{
#ifdef CONFIG_PCI
-@@ -40,6 +110,8 @@
+@@ -40,6 +101,7 @@
mpc83xx_add_bridge(np);
#endif
mpc831x_usb_cfg();
-+
+ mpc8313_spi_init();
}
static void __init mpc831x_rdb_init_IRQ(void)
Index: linux-2.6.29/drivers/spi/spi_mpc83xx.c
===================================================================
---- linux-2.6.29.orig/drivers/spi/spi_mpc83xx.c 2009-03-24 00:12:14.000000000 +0100
-+++ linux-2.6.29/drivers/spi/spi_mpc83xx.c 2009-04-01 17:37:53.000000000 +0200
+--- linux-2.6.29.orig/drivers/spi/spi_mpc83xx.c 2009-10-05 18:55:57.000000000 +0200
++++ linux-2.6.29/drivers/spi/spi_mpc83xx.c 2009-10-05 18:59:01.000000000 +0200
@@ -280,7 +280,9 @@
if (pm)
pm--;
@@ -141,7 +131,7 @@ Index: linux-2.6.29/drivers/spi/spi_mpc83xx.c
mpc83xx_spi->workqueue = create_singlethread_workqueue(
- master->dev.parent->bus_id);
-+ dev->dev.bus_id);
++ dev->dev.bus_id);
if (mpc83xx_spi->workqueue == NULL) {
ret = -EBUSY;
goto free_irq;
diff --git a/recipes/linux/linux_2.6.29.bb b/recipes/linux/linux_2.6.29.bb
index eb6b8b98bf..a172b6d074 100644
--- a/recipes/linux/linux_2.6.29.bb
+++ b/recipes/linux/linux_2.6.29.bb
@@ -27,7 +27,7 @@ SRC_URI_append_boc01 = "\
file://004-081205-usb.patch;patch=1 \
file://005-090226-isl12024.patch;patch=1 \
file://007-091005-lm73.patch;patch=1 \
- file://008-081208-spi.patch;patch=1 \
+ file://008-091005-spi.patch;patch=1 \
file://011-090115-gpio.patch;patch=1 \
file://012-090219-capsense.patch;patch=1 \
file://013-090306-lcd.patch;patch=1 \