aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-10-12 17:46:10 +0200
committerKoen Kooi <koen@openembedded.org>2010-10-12 17:46:10 +0200
commit88335ada413098838c3c8315b90183eef1ccd0d3 (patch)
tree75af2499b971d166eaed8b6ecdeb840b71a088ee /recipes/linux
parent6dd461ca4077d1ec5a7261f39916531936edd236 (diff)
downloadopenembedded-88335ada413098838c3c8315b90183eef1ccd0d3.tar.gz
linux.inc: add knob to turn off cortex a8 fixups
linux-sakoman 2.6.35: use above knob
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-sakoman_2.6.35.bb2
-rw-r--r--recipes/linux/linux.inc4
2 files changed, 5 insertions, 1 deletions
diff --git a/recipes/linux/linux-sakoman_2.6.35.bb b/recipes/linux/linux-sakoman_2.6.35.bb
index 6647d874b0..9933af4c34 100644
--- a/recipes/linux/linux-sakoman_2.6.35.bb
+++ b/recipes/linux/linux-sakoman_2.6.35.bb
@@ -1,3 +1,5 @@
+CORTEXA8FIXUP = "no"
+
require linux.inc
DESCRIPTION = "Linux kernel for OMAP processors"
diff --git a/recipes/linux/linux.inc b/recipes/linux/linux.inc
index 34deebbe55..0409ebf08a 100644
--- a/recipes/linux/linux.inc
+++ b/recipes/linux/linux.inc
@@ -52,6 +52,8 @@ KERNEL_DEVICETREE_xilinx-ml507 = "arch/${ARCH}/boot/dts/virtex440-ml507.dts"
KERNEL_DEVICETREE_FLAGS = "-R 8 -S 0x3000"
+CORTEXA8FIXUP ?= "yes"
+
python __anonymous () {
import bb
@@ -108,7 +110,7 @@ do_configure_prepend() {
fi
# Enable thumb2 fixup for specific issue in angstrom toolchains when used on A8 r1p[012] silicon
- if [ "${DISTRO_NAME}" = "Angstrom" ] ; then
+ if [ "${DISTRO_NAME}" = "Angstrom" -o "${CORTEXA8FIXUP}" = "yes"] ; then
sed -i -e /CONFIG_ARM_ERRATA_430973/d ${WORKDIR}/defconfig
echo "CONFIG_ARM_ERRATA_430973=y" >> ${S}/.config
fi