summaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-05-04 09:05:07 +0200
committerKoen Kooi <koen@openembedded.org>2010-05-04 09:10:50 +0200
commit402a721af66dd49e6ae99c1b2544c5976a70bc79 (patch)
tree3bc0d04d68fa53fe9038ec75427961bf1e6d11ee /recipes/linux
parent88eae52b1cd9eefce3903c88e265b9ddac7f670f (diff)
downloadopenembedded-402a721af66dd49e6ae99c1b2544c5976a70bc79.tar.gz
linux-omap-psp 2.6.32: refresh touchbook defconfig, add disabled patch to enable 800MHz operation
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0017-ARM-OMAP-add-800MHz-OPP-and-remove-125MHz-one.patch48
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/defconfig10
-rw-r--r--recipes/linux/linux-omap-psp_2.6.32.bb1
3 files changed, 55 insertions, 4 deletions
diff --git a/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0017-ARM-OMAP-add-800MHz-OPP-and-remove-125MHz-one.patch b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0017-ARM-OMAP-add-800MHz-OPP-and-remove-125MHz-one.patch
new file mode 100644
index 0000000000..48f61b5e93
--- /dev/null
+++ b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/0017-ARM-OMAP-add-800MHz-OPP-and-remove-125MHz-one.patch
@@ -0,0 +1,48 @@
+From 0e43db0084633476e60f686627594042ca5cfe3a Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Tue, 4 May 2010 09:01:21 +0200
+Subject: [PATCH 17/17] ARM: OMAP: add 800MHz OPP and remove 125MHz one
+
+---
+ arch/arm/mach-omap2/pm34xx.c | 6 ++++--
+ 1 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/pm34xx.c b/arch/arm/mach-omap2/pm34xx.c
+index d1cc528..42fbcdd 100644
+--- a/arch/arm/mach-omap2/pm34xx.c
++++ b/arch/arm/mach-omap2/pm34xx.c
+@@ -120,7 +120,7 @@ static struct prm_setup_vc prm_setup = {
+ struct omap_opp omap35x_mpu_rate_table[] = {
+ {0, 0, 0},
+ /*OPP1*/
+- {S125M, VDD1_OPP1, 0x1E},
++// {S125M, VDD1_OPP1, 0x1E},
+ /*OPP2*/
+ {S250M, VDD1_OPP2, 0x26},
+ /*OPP3*/
+@@ -131,12 +131,13 @@ struct omap_opp omap35x_mpu_rate_table[] = {
+ {S600M, VDD1_OPP5, 0x3C},
+ /*OPP6*/
+ {S720M, VDD1_OPP6, 0x3C},
++ {S800M, VDD1_OPP6, 0x3F},
+ };
+
+ struct omap_opp omap35x_dsp_rate_table[] = {
+ {0, 0, 0},
+ /*OPP1*/
+- {S90M, VDD1_OPP1, 0x1E},
++// {S90M, VDD1_OPP1, 0x1E},
+ /*OPP2*/
+ {S180M, VDD1_OPP2, 0x26},
+ /*OPP3*/
+@@ -147,6 +148,7 @@ struct omap_opp omap35x_dsp_rate_table[] = {
+ {S430M, VDD1_OPP5, 0x3C},
+ /*OPP5*/
+ {S520M, VDD1_OPP6, 0x3C},
++ {S600M, VDD1_OPP6, 0x3F},
+ };
+
+ struct omap_opp omap35x_l3_rate_table[] = {
+--
+1.6.6.1
+
diff --git a/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/defconfig b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/defconfig
index 991279b605..4165d4cf74 100644
--- a/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/defconfig
+++ b/recipes/linux/linux-omap-psp-2.6.32/omap3-touchbook/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.32
-# Wed Mar 31 11:43:52 2010
+# Tue May 4 08:42:43 2010
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -306,6 +306,8 @@ CONFIG_ARM_THUMBEE=y
# CONFIG_CPU_BPREDICT_DISABLE is not set
CONFIG_HAS_TLS_REG=y
CONFIG_ARM_L1_CACHE_SHIFT=6
+# CONFIG_USER_L2_PLE is not set
+# CONFIG_USER_PMON is not set
CONFIG_ARM_ERRATA_430973=y
# CONFIG_ARM_ERRATA_458693 is not set
# CONFIG_ARM_ERRATA_460075 is not set
@@ -356,6 +358,7 @@ CONFIG_DEFAULT_MMAP_MIN_ADDR=4096
CONFIG_LEDS=y
CONFIG_ALIGNMENT_TRAP=y
# CONFIG_UACCESS_WITH_MEMCPY is not set
+CONFIG_CPU_V7_SYSFS=y
#
# Boot options
@@ -375,9 +378,9 @@ CONFIG_CPU_FREQ_TABLE=y
# CONFIG_CPU_FREQ_DEBUG is not set
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
-# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
+CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
-CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE=y
+# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
@@ -1712,7 +1715,6 @@ CONFIG_VIDEO_KS0127=m
CONFIG_VIDEO_MT9V011=m
CONFIG_VIDEO_TCM825X=m
CONFIG_VIDEO_MT9P012=m
-# CONFIG_VIDEO_MT9T111 is not set
CONFIG_VIDEO_DW9710=m
# CONFIG_VIDEO_OV3640 is not set
CONFIG_VIDEO_IMX046=m
diff --git a/recipes/linux/linux-omap-psp_2.6.32.bb b/recipes/linux/linux-omap-psp_2.6.32.bb
index 1e63107070..e060e36242 100644
--- a/recipes/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes/linux/linux-omap-psp_2.6.32.bb
@@ -79,6 +79,7 @@ SRC_URI_append_omap3-touchbook = " \
file://0014-ASoC-add-driver-for-omap3-touchbook.patch;patch=1 \
file://0015-backlight-add-PWM-support.patch;patch=1 \
file://0016-ARM-OMAP-omap3-touchbook-update-boardfile.patch;patch=1 \
+# file://0017-ARM-OMAP-add-800MHz-OPP-and-remove-125MHz-one.patch;patch=1 \
"
addtask quiltfixup before do_patch after do_unpack