summaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-26 15:05:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-26 15:12:26 +0200
commit8bb53d3f261c59353652f0328bfd887d6aa1c112 (patch)
tree99e66d9e168fe70b3de5e12a1879adda6971ac39 /recipes/linux
parentfa8b49b614644b3b02cf2e962fed95cf41f6e6f3 (diff)
downloadopenembedded-8bb53d3f261c59353652f0328bfd887d6aa1c112.tar.gz
linux-openmoko: partial revert of rename to PN_PV sheme
* details in http://thread.gmane.org/gmane.comp.handhelds.openembedded/32950 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-openmoko-2.6.24_git.bb (renamed from recipes/linux/linux-openmoko_2.6.24.bb)8
-rw-r--r--recipes/linux/linux-openmoko-2.6.28_git.bb (renamed from recipes/linux/linux-openmoko_2.6.28.bb)8
-rw-r--r--recipes/linux/linux-openmoko-2.6.29_git.bb (renamed from recipes/linux/linux-openmoko_2.6.29.bb)8
-rw-r--r--recipes/linux/linux-openmoko-2.6.32_git.bb (renamed from recipes/linux/linux-openmoko_2.6.32.bb)8
-rw-r--r--recipes/linux/linux-openmoko-2.6.34_git.bb (renamed from recipes/linux/linux-openmoko_2.6.34.bb)6
5 files changed, 27 insertions, 11 deletions
diff --git a/recipes/linux/linux-openmoko_2.6.24.bb b/recipes/linux/linux-openmoko-2.6.24_git.bb
index 4c87ef96ad..877c5637e8 100644
--- a/recipes/linux/linux-openmoko_2.6.24.bb
+++ b/recipes/linux/linux-openmoko-2.6.24_git.bb
@@ -1,9 +1,13 @@
require linux.inc
require linux-openmoko.inc
+KERNEL_RELEASE = "2.6.24"
+KERNEL_VERSION = "${KERNEL_RELEASE}"
+
SRCREV = "fb42ce6724576fc173faf8abfb04aa2c36d213b7"
-PR = "r2"
-PR_append = "+gitr${SRCPV}"
+OEV = "oe5"
+PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
+PR = "r1"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=stable \
diff --git a/recipes/linux/linux-openmoko_2.6.28.bb b/recipes/linux/linux-openmoko-2.6.28_git.bb
index 687990b7a3..ae5b3e5369 100644
--- a/recipes/linux/linux-openmoko_2.6.28.bb
+++ b/recipes/linux/linux-openmoko-2.6.28_git.bb
@@ -1,9 +1,13 @@
require linux.inc
require linux-openmoko.inc
+KERNEL_RELEASE = "2.6.28"
+KERNEL_VERSION = "${KERNEL_RELEASE}"
+
SRCREV = "8c65792a5c83c76d662a617a7c4e1ae8104bb6a5"
-PR = "r1"
-PR_append = "+gitr${SRCPV}"
+OEV = "oe2"
+PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
+PR = "r0"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=stable \
diff --git a/recipes/linux/linux-openmoko_2.6.29.bb b/recipes/linux/linux-openmoko-2.6.29_git.bb
index da23a40716..a7140ee70c 100644
--- a/recipes/linux/linux-openmoko_2.6.29.bb
+++ b/recipes/linux/linux-openmoko-2.6.29_git.bb
@@ -1,9 +1,13 @@
require linux.inc
require linux-openmoko.inc
+KERNEL_RELEASE = "2.6.29"
+KERNEL_VERSION = "2.6.29-rc3"
+
SRCREV = "973a41fce60e5f6edfcf0eaf94056a57eee65e16"
-PR = "r9"
-PR_append = "+gitr${SRCPV}"
+OMV = "oe11"
+PV = "${KERNEL_RELEASE}-${OMV}+gitr${SRCPV}"
+PR = "r8"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
diff --git a/recipes/linux/linux-openmoko_2.6.32.bb b/recipes/linux/linux-openmoko-2.6.32_git.bb
index bee6570904..499c4a085e 100644
--- a/recipes/linux/linux-openmoko_2.6.32.bb
+++ b/recipes/linux/linux-openmoko-2.6.32_git.bb
@@ -1,15 +1,17 @@
require linux.inc
require linux-openmoko.inc
+KERNEL_RELEASE="2.6.32.13"
+
SRCREV = "a9254be10ac2294ea20165a87c09ea6afcf66d94"
-PR = "r1"
-PR_append = "+gitr${SRCPV}"
+OEV = "oe2"
+PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-gta02-2.6.32 \
file://0001-Revert-s3cmci-initialize-default-platform-data-no_wp.patch \
# latest stable patch for ubi fix 943e167cb3e8fb191894bde8a4a75db78531a7c8
- ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.32.13.bz2;patch=1;name=stablepatch \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${KERNEL_RELEASE}.bz2;apply=yes;name=stablepatch \
# build fix
file://0001-wm8753-fix-build-with-gcc-4.4.2-which-works-ok-with-.patch \
# patches from Radek Polak used in qtmoko
diff --git a/recipes/linux/linux-openmoko_2.6.34.bb b/recipes/linux/linux-openmoko-2.6.34_git.bb
index 87efa06368..22fa3970a3 100644
--- a/recipes/linux/linux-openmoko_2.6.34.bb
+++ b/recipes/linux/linux-openmoko-2.6.34_git.bb
@@ -1,9 +1,11 @@
require linux.inc
require linux-openmoko.inc
+KERNEL_RELEASE="2.6.34"
+
SRCREV = "dd1225cc08c3375bf80289ac1965c724881b149a"
-PR = "r1"
-PR_append = "+gitr${SRCPV}"
+OEV = "oe2"
+PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-gta02-2.6.34 \