summaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/linux
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-mtx-1_2.4.27.bb2
-rw-r--r--recipes/linux/linux-mtx-2_2.4.27.bb2
-rw-r--r--recipes/linux/linux-mtx-3_2.6.15.4.bb2
-rw-r--r--recipes/linux/linux-mtx-3_2.6.15.bb2
-rw-r--r--recipes/linux/linux-sgh-i900_2.6.32.bb2
5 files changed, 5 insertions, 5 deletions
diff --git a/recipes/linux/linux-mtx-1_2.4.27.bb b/recipes/linux/linux-mtx-1_2.4.27.bb
index 3927520b92..d43fa74ffc 100644
--- a/recipes/linux/linux-mtx-1_2.4.27.bb
+++ b/recipes/linux/linux-mtx-1_2.4.27.bb
@@ -6,7 +6,7 @@ PR = "r11"
inherit module-base kernel
PROVIDES = "virtual/kernel"
-RDEPENDS = "mtd-utils"
+RDEPENDS_${PN} = "mtd-utils"
SRC_URI = "cvs://cvs:cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_4_27 \
file://01-mtd-2004-01-27.diff \
diff --git a/recipes/linux/linux-mtx-2_2.4.27.bb b/recipes/linux/linux-mtx-2_2.4.27.bb
index 90a0dff9d1..e919577db6 100644
--- a/recipes/linux/linux-mtx-2_2.4.27.bb
+++ b/recipes/linux/linux-mtx-2_2.4.27.bb
@@ -6,7 +6,7 @@ PR = "r11"
inherit module-base kernel
PROVIDES = "virtual/kernel"
-RDEPENDS = "mtd-utils"
+RDEPENDS_${PN} = "mtd-utils"
SRC_URI += "cvs://cvs:cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_4_27 \
file://00-mtx-2.diff \
diff --git a/recipes/linux/linux-mtx-3_2.6.15.4.bb b/recipes/linux/linux-mtx-3_2.6.15.4.bb
index 772e573351..1f831f4565 100644
--- a/recipes/linux/linux-mtx-3_2.6.15.4.bb
+++ b/recipes/linux/linux-mtx-3_2.6.15.4.bb
@@ -9,7 +9,7 @@ inherit kernel
# PROVIDES = "virtual/kernel"
DEPENDS = "u-boot"
-RDEPENDS = "mtd-utils"
+RDEPENDS_${PN} = "mtd-utils"
SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${KV}.tar.bz2;name=kernel \
file://00-mtx-3.diff \
diff --git a/recipes/linux/linux-mtx-3_2.6.15.bb b/recipes/linux/linux-mtx-3_2.6.15.bb
index 1fc44f4354..af2934d6ef 100644
--- a/recipes/linux/linux-mtx-3_2.6.15.bb
+++ b/recipes/linux/linux-mtx-3_2.6.15.bb
@@ -6,7 +6,7 @@ PR = "r11"
inherit module-base kernel
PROVIDES = "virtual/kernel"
-RDEPENDS = "mtd-utils"
+RDEPENDS_${PN} = "mtd-utils"
SRC_URI += "cvs://cvs:cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_6_15 \
file://defconfig-mtx-3"
diff --git a/recipes/linux/linux-sgh-i900_2.6.32.bb b/recipes/linux/linux-sgh-i900_2.6.32.bb
index f45da3f0e8..c9c31a9686 100644
--- a/recipes/linux/linux-sgh-i900_2.6.32.bb
+++ b/recipes/linux/linux-sgh-i900_2.6.32.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Linux 2.6.32 kernel for the Samsung Omnia SGH-i900."
SECTION = "kernel"
LICENSE = "GPLv2"
-RDEPENDS += "marvell-gspi-fw"
+RDEPENDS_${PN} += "marvell-gspi-fw"
COMPATIBLE_MACHINE = "sgh-i900"