aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-05-08 16:20:13 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-05-08 16:20:13 +0200
commit1bff258e44b63c1c532f922cf6d80a8f364e2889 (patch)
tree227bc4bb4fd1cdd61b3e05d1fac2e07b0d43e706 /recipes/llvm
parent60607cdba1c0d0fbe1591125093d17898fd03635 (diff)
downloadopenembedded-1bff258e44b63c1c532f922cf6d80a8f364e2889.tar.gz
llvm2.6-native 2.5+svnr20090504: New recipe.
llvm2.6 2.5+svnr20090504: New recipe.
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb18
-rw-r--r--recipes/llvm/llvm2.6/fix-build.patch13
-rw-r--r--recipes/llvm/llvm2.6/llvm-debugonly-zeroormore.patch13
-rw-r--r--recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch29
-rw-r--r--recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch14
-rw-r--r--recipes/llvm/llvm2.6_2.5+svnr20090504.bb21
6 files changed, 108 insertions, 0 deletions
diff --git a/recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb b/recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb
new file mode 100644
index 0000000000..86397c9920
--- /dev/null
+++ b/recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb
@@ -0,0 +1,18 @@
+require llvm-native.inc
+
+SRCREV = "70854"
+
+PV = "2.5+svnr${SRCREV}"
+
+PR = "r0"
+
+SRC_URI = "\
+ svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
+ file://fix-build.patch;patch=1 \
+ file://llvm-enable-threads-macro.patch;patch=1;pnum=0 \
+ file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
+"
+
+S = "${WORKDIR}/trunk"
+
+LLVM_RELEASE = "2.6"
diff --git a/recipes/llvm/llvm2.6/fix-build.patch b/recipes/llvm/llvm2.6/fix-build.patch
new file mode 100644
index 0000000000..553965608a
--- /dev/null
+++ b/recipes/llvm/llvm2.6/fix-build.patch
@@ -0,0 +1,13 @@
+Index: tools/llvm-config/CMakeLists.txt
+===================================================================
+--- a/tools.orig/llvm-config/CMakeLists.txt 2009-04-09 10:45:01.000000000 +0200
++++ b/tools/llvm-config/CMakeLists.txt 2009-04-09 10:43:52.000000000 +0200
+@@ -90,7 +90,7 @@
+ add_custom_command(OUTPUT ${LLVM_CONFIG}
+ COMMAND echo 's!@LLVM_CPPFLAGS@!${CPP_FLGS}!' > temp.sed
+ COMMAND echo 's!@LLVM_CFLAGS@!${C_FLGS}!' >> temp.sed
+- COMMAND echo 's!@LLVM_CXXFLAGS@!${CXX_FLGS}!' >> temp.sed
++ COMMAND echo 's!@LLVM_CXXFLAGS@!${CXX_FLGS} -fpermissive -fvisibility-inlines-hidden!' >> temp.sed
+ # TODO: Use general flags for linking! not just for shared libs:
+ COMMAND echo 's!@LLVM_LDFLAGS@!${CMAKE_SHARED_LINKER_FLAGS}!' >> temp.sed
+ COMMAND echo 's!@LIBS@!!' >> temp.sed # TODO: System libs
diff --git a/recipes/llvm/llvm2.6/llvm-debugonly-zeroormore.patch b/recipes/llvm/llvm2.6/llvm-debugonly-zeroormore.patch
new file mode 100644
index 0000000000..8888884ea5
--- /dev/null
+++ b/recipes/llvm/llvm2.6/llvm-debugonly-zeroormore.patch
@@ -0,0 +1,13 @@
+Index: lib/Support/Debug.cpp
+===================================================================
+--- lib/Support/Debug.cpp (Revision 71077)
++++ lib/Support/Debug.cpp (Arbeitskopie)
+@@ -48,7 +48,7 @@
+ static cl::opt<DebugOnlyOpt, true, cl::parser<std::string> >
+ DebugOnly("debug-only", cl::desc("Enable a specific type of debug output"),
+ cl::Hidden, cl::value_desc("debug string"),
+- cl::location(DebugOnlyOptLoc), cl::ValueRequired);
++ cl::location(DebugOnlyOptLoc), cl::ValueRequired, cl::ZeroOrMore);
+ #endif
+ }
+
diff --git a/recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch b/recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch
new file mode 100644
index 0000000000..f1072d9af9
--- /dev/null
+++ b/recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch
@@ -0,0 +1,29 @@
+Index: trunk/include/llvm/Config/config.h.cmake
+===================================================================
+--- trunk.orig/include/llvm/Config/config.h.cmake 2009-05-06 16:39:19.957841609 +0200
++++ trunk/include/llvm/Config/config.h.cmake 2009-05-06 16:39:20.185842055 +0200
+@@ -194,7 +194,7 @@
+ #cmakedefine HAVE_LIBPSAPI ${HAVE_LIBPSAPI}
+
+ /* Define to 1 if you have the `pthread' library (-lpthread). */
+-#undef HAVE_LIBPTHREAD
++#cmakedefine HAVE_LIBPTHREAD ${HAVE_LIBPTHREAD}
+
+ /* Define to 1 if you have the `udis86' library (-ludis86). */
+ #undef HAVE_LIBUDIS86
+Index: trunk/cmake/config-ix.cmake
+===================================================================
+--- trunk.orig/cmake/config-ix.cmake 2009-05-06 16:49:45.121841057 +0200
++++ trunk/cmake/config-ix.cmake 2009-05-06 16:50:25.738552620 +0200
+@@ -98,6 +98,11 @@
+ if( HAVE_PTHREAD_H OR WIN32 )
+ set(ENABLE_THREADS 1)
+ endif()
++
++# FIXME: Actually check for the library
++ if( HAVE_PTHREAD_H )
++ set(HAVE_LIBPTHREAD 1)
++ endif()
+ endif()
+
+ if( ENABLE_THREADS )
diff --git a/recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch b/recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch
new file mode 100644
index 0000000000..6f17b850f6
--- /dev/null
+++ b/recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch
@@ -0,0 +1,14 @@
+Index: include/llvm/Config/config.h.cmake
+===================================================================
+--- include/llvm/Config/config.h.cmake (Revision 71077)
++++ include/llvm/Config/config.h.cmake (Arbeitskopie)
+@@ -276,6 +276,9 @@
+ /* Define to have the %a format string */
+ #undef HAVE_PRINTF_A
+
++/* Have pthread.h */
++#cmakedefine HAVE_PTHREAD_H ${HAVE_PTHREAD_H}
++
+ /* Have pthread_mutex_lock */
+ #cmakedefine HAVE_PTHREAD_MUTEX_LOCK ${HAVE_PTHREAD_MUTEX_LOCK}
+
diff --git a/recipes/llvm/llvm2.6_2.5+svnr20090504.bb b/recipes/llvm/llvm2.6_2.5+svnr20090504.bb
new file mode 100644
index 0000000000..9ba13ceadc
--- /dev/null
+++ b/recipes/llvm/llvm2.6_2.5+svnr20090504.bb
@@ -0,0 +1,21 @@
+require llvm.inc
+
+SRCREV = "70854"
+
+PV = "2.5+svnr${SRCREV}"
+
+PR = "r0"
+
+DEPENDS = "llvm-common llvm2.6-native"
+
+SRC_URI = "\
+ svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
+ file://fix-build.patch;patch=1 \
+ file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
+ file://llvm-fix-pthreads_h.patch;patch=1;pnum=0 \
+ file://llvm-fix-have_libpthread.patch;patch=1 \
+"
+
+S = "${WORKDIR}/trunk"
+
+LLVM_RELEASE = "2.6"