aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2010-07-13 11:58:02 +0200
committerRobert Schuster <robertschuster@fsfe.org>2010-07-14 07:59:41 +0200
commit5dfb4130a58f9b2a8b551bbfb98ee15fc7c11c86 (patch)
tree610588de55ed1e676611e7e43f4ca39c4f4735a4 /recipes/llvm
parent5ce3d5e328aceacbc17a099e8db8a7d4bf9452a0 (diff)
downloadopenembedded-5dfb4130a58f9b2a8b551bbfb98ee15fc7c11c86.tar.gz
llvm-common: Fixed installation path of helper script (led to issues in OpenJDK build), bumped PR.
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm-common.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/llvm/llvm-common.bb b/recipes/llvm/llvm-common.bb
index a2dad52b43..3de8f7f7b2 100644
--- a/recipes/llvm/llvm-common.bb
+++ b/recipes/llvm/llvm-common.bb
@@ -2,6 +2,8 @@ PR = "r1"
DESCRIPTION = "Helper script for OE's llvm support"
+PR = "r1"
+
BBCLASSEXTEND = "native"
SRC_URI = "file://llvm-config"
@@ -14,3 +16,15 @@ do_install() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
}
+
+# For llvm-common the script should end up in STAGING_BINDIR_CROSS
+# and for llvm-common-native it should be in STAGING_BINDIR. The
+# script works together with a script that is installed by a
+# corresponding llvm(-native) package.
+DESTINATION = "${STAGING_BINDIR_CROSS}"
+DESTINATION_virtclass-native = "${STAGING_BINDIR}"
+
+do_stage() {
+ install -d ${DESTINATION}
+ install -m 0755 ${WORKDIR}/llvm-config ${DESTINATION}
+}