aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2010-04-30 15:12:42 +0200
committerRobert Schuster <robertschuster@fsfe.org>2010-04-30 15:15:20 +0200
commit6db59c439e2bcf07187b522c09a5b455df46287d (patch)
tree7e6477f1a1c7ab4c5a2c25823d0b0bc8aef71cdf /recipes/llvm
parent6da4ed714f269373271a14149b131bf1ff7a6def (diff)
downloadopenembedded-6db59c439e2bcf07187b522c09a5b455df46287d.tar.gz
llvm.inc: Added path for nm.
llvm2.7 2.6+svnr20091007: Removed prerelease version. llvm2.7-native 2.6+svnr20091007: Dito. llvm2.7 2.7: New recipe. llvm2.7-native 2.7: New recipe.
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm.inc1
-rw-r--r--recipes/llvm/llvm2.7-native_2.6+svnr20091007.bb16
-rw-r--r--recipes/llvm/llvm2.7-native_2.7.bb12
-rw-r--r--recipes/llvm/llvm2.7/BX_to_BLX.patch12
-rw-r--r--recipes/llvm/llvm2.7/llvm-debugonly-zeroormore.patch13
-rw-r--r--recipes/llvm/llvm2.7_2.7.bb21
6 files changed, 40 insertions, 35 deletions
diff --git a/recipes/llvm/llvm.inc b/recipes/llvm/llvm.inc
index 1046bd737e..3c22318e33 100644
--- a/recipes/llvm/llvm.inc
+++ b/recipes/llvm/llvm.inc
@@ -53,6 +53,7 @@ EXTRA_OECMAKE = "\
-DCMAKE_OBJDUMP:FILEPATH=${OBJDUMP} \
-DCMAKE_RANLIB:FILEPATH=${RANLIB} \
-DCMAKE_STRIP:FILEPATH=${STRIP} \
+ -DNM_PATH:FILEPATH=${NM} \
-DLLVM_ENABLE_PIC:BOOL=ON \
"
diff --git a/recipes/llvm/llvm2.7-native_2.6+svnr20091007.bb b/recipes/llvm/llvm2.7-native_2.6+svnr20091007.bb
deleted file mode 100644
index ada81c625d..0000000000
--- a/recipes/llvm/llvm2.7-native_2.6+svnr20091007.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-require llvm-native.inc
-
-SRCREV = "83459"
-
-PV = "2.6+svnr${SRCPV}"
-
-PR = "r0"
-
-SRC_URI = "\
- svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
- file://llvm-debugonly-zeroormore.patch;patch=1 \
-"
-
-S = "${WORKDIR}/trunk"
-
-LLVM_RELEASE = "2.7"
diff --git a/recipes/llvm/llvm2.7-native_2.7.bb b/recipes/llvm/llvm2.7-native_2.7.bb
new file mode 100644
index 0000000000..e438702d9a
--- /dev/null
+++ b/recipes/llvm/llvm2.7-native_2.7.bb
@@ -0,0 +1,12 @@
+require llvm-native.inc
+
+PR = "r0"
+
+SRC_URI = "\
+ http://llvm.org/releases/${PV}/llvm-${PV}.tgz \
+"
+
+LLVM_RELEASE = "2.7"
+
+SRC_URI[md5sum] = "ac322661f20e7d6c810b1869f886ad9b"
+SRC_URI[sha256sum] = "99664bdc8503a306038166af33f28eb426d99e297575a59d74a1a0dcbddbbca5"
diff --git a/recipes/llvm/llvm2.7/BX_to_BLX.patch b/recipes/llvm/llvm2.7/BX_to_BLX.patch
index 7cf36766af..2e34c623b4 100644
--- a/recipes/llvm/llvm2.7/BX_to_BLX.patch
+++ b/recipes/llvm/llvm2.7/BX_to_BLX.patch
@@ -1,11 +1,11 @@
Index: llvm/lib/Target/ARM/ARMInstrInfo.td
===================================================================
---- llvm.orig/lib/Target/ARM/ARMInstrInfo.td 2009-10-06 12:35:26.000000000 +0000
-+++ llvm/lib/Target/ARM/ARMInstrInfo.td 2009-10-06 12:36:03.000000000 +0000
-@@ -645,7 +645,7 @@
- IIC_Br, "mov lr, pc\n\tbx $func",
- [(ARMcall_nolink GPR:$func)]>,
- Requires<[IsARM, IsNotDarwin]> {
+--- llvm.orig/lib/Target/ARM/ARMInstrInfo.td 2010-03-08 16:07:25.000000000 +0100
++++ llvm/lib/Target/ARM/ARMInstrInfo.td 2010-03-08 16:10:21.000000000 +0100
+@@ -942,7 +942,7 @@
+ IIC_Br, "mov\tlr, pc\n\tbx\t$func",
+ [(ARMcall_nolink tGPR:$func)]>,
+ Requires<[IsARM, HasV4T, IsNotDarwin]> {
- let Inst{7-4} = 0b0001;
+ let Inst{7-4} = 0b0011;
let Inst{19-8} = 0b111111111111;
diff --git a/recipes/llvm/llvm2.7/llvm-debugonly-zeroormore.patch b/recipes/llvm/llvm2.7/llvm-debugonly-zeroormore.patch
deleted file mode 100644
index ee32a7966c..0000000000
--- a/recipes/llvm/llvm2.7/llvm-debugonly-zeroormore.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: trunk/lib/Support/Debug.cpp
-===================================================================
---- trunk.orig/lib/Support/Debug.cpp 2009-09-17 10:41:42.000000000 +0200
-+++ trunk/lib/Support/Debug.cpp 2009-09-17 10:42:55.000000000 +0200
-@@ -48,7 +48,7 @@
- static cl::opt<DebugOnlyOpt, true, cl::parser<std::string> >
- DebugOnly("debug-only", cl::desc("Enable a specific type of debug output"),
- cl::Hidden, cl::value_desc("debug string"),
-- cl::location(DebugOnlyOptLoc), cl::ValueRequired);
-+ cl::location(DebugOnlyOptLoc), cl::ValueRequired, cl::ZeroOrMore);
-
- // isCurrentDebugType - Return true if the specified string is the debug type
- // specified on the command line, or if none was specified on the command line
diff --git a/recipes/llvm/llvm2.7_2.7.bb b/recipes/llvm/llvm2.7_2.7.bb
new file mode 100644
index 0000000000..587bffb29b
--- /dev/null
+++ b/recipes/llvm/llvm2.7_2.7.bb
@@ -0,0 +1,21 @@
+require llvm.inc
+
+PR = "r0"
+
+DEPENDS = "llvm-common llvm2.7-native"
+
+SRC_URI = "\
+ http://llvm.org/releases/${PV}/llvm-${PV}.tgz \
+ file://BX_to_BLX.patch;patch=1 \
+ "
+
+EXTRA_OECMAKE += "\
+ -DLLVM_TARGET_ARCH:STRING=${LLVM_ARCH} \
+ -DLLVM_ENABLE_ASSERTIONS:BOOL=ON \
+ -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
+ "
+
+LLVM_RELEASE = "2.7"
+
+SRC_URI[md5sum] = "ac322661f20e7d6c810b1869f886ad9b"
+SRC_URI[sha256sum] = "99664bdc8503a306038166af33f28eb426d99e297575a59d74a1a0dcbddbbca5"