aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
authorXerxes Rånby <xerxes@zafena.se>2009-11-17 16:59:49 +0100
committerXerxes Rånby <xerxes@zafena.se>2009-11-17 17:06:56 +0100
commit3b4c9f8d74d6414e8e8e52142d788fa919a28e5e (patch)
tree2b1915ae44452da60d5ec98682fc8be5b4122609 /recipes/llvm
parent424ea26ab4650d83495e4eeae72ea1f3a7b379cf (diff)
downloadopenembedded-3b4c9f8d74d6414e8e8e52142d788fa919a28e5e.tar.gz
llvm2.6: Added BX_to_BLX.patch inorder to stabilize LLVM JIT on ARM
llvm2.7: Updated to newer SVN snapshot Added BX_to_BLX.patch inorder to stabilize LLVM JIT on ARM
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm2.6/BX_to_BLX.patch13
-rw-r--r--recipes/llvm/llvm2.6_2.6.bb3
-rw-r--r--recipes/llvm/llvm2.7-native_2.6+svnr20091007.bb (renamed from recipes/llvm/llvm2.7-native_2.6+svnr20090916.bb)2
-rw-r--r--recipes/llvm/llvm2.7/BX_to_BLX.patch13
-rw-r--r--recipes/llvm/llvm2.7_2.6+svnr20091007.bb (renamed from recipes/llvm/llvm2.7_2.6+svnr20090916.bb)5
5 files changed, 32 insertions, 4 deletions
diff --git a/recipes/llvm/llvm2.6/BX_to_BLX.patch b/recipes/llvm/llvm2.6/BX_to_BLX.patch
new file mode 100644
index 0000000000..7cf36766af
--- /dev/null
+++ b/recipes/llvm/llvm2.6/BX_to_BLX.patch
@@ -0,0 +1,13 @@
+Index: llvm/lib/Target/ARM/ARMInstrInfo.td
+===================================================================
+--- llvm.orig/lib/Target/ARM/ARMInstrInfo.td 2009-10-06 12:35:26.000000000 +0000
++++ llvm/lib/Target/ARM/ARMInstrInfo.td 2009-10-06 12:36:03.000000000 +0000
+@@ -645,7 +645,7 @@
+ IIC_Br, "mov lr, pc\n\tbx $func",
+ [(ARMcall_nolink GPR:$func)]>,
+ Requires<[IsARM, IsNotDarwin]> {
+- let Inst{7-4} = 0b0001;
++ let Inst{7-4} = 0b0011;
+ let Inst{19-8} = 0b111111111111;
+ let Inst{27-20} = 0b00010010;
+ }
diff --git a/recipes/llvm/llvm2.6_2.6.bb b/recipes/llvm/llvm2.6_2.6.bb
index 40dabb4fba..909bb95b00 100644
--- a/recipes/llvm/llvm2.6_2.6.bb
+++ b/recipes/llvm/llvm2.6_2.6.bb
@@ -1,12 +1,13 @@
require llvm.inc
-PR = "r0"
+PR = "r1"
DEPENDS = "llvm-common llvm2.6-native"
SRC_URI += "\
file://fix-build.patch;patch=1 \
file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
+ file://BX_to_BLX.patch;patch=1 \
"
LLVM_RELEASE = "2.6"
diff --git a/recipes/llvm/llvm2.7-native_2.6+svnr20090916.bb b/recipes/llvm/llvm2.7-native_2.6+svnr20091007.bb
index a0cf7c5fb2..ada81c625d 100644
--- a/recipes/llvm/llvm2.7-native_2.6+svnr20090916.bb
+++ b/recipes/llvm/llvm2.7-native_2.6+svnr20091007.bb
@@ -1,6 +1,6 @@
require llvm-native.inc
-SRCREV = "82130"
+SRCREV = "83459"
PV = "2.6+svnr${SRCPV}"
diff --git a/recipes/llvm/llvm2.7/BX_to_BLX.patch b/recipes/llvm/llvm2.7/BX_to_BLX.patch
new file mode 100644
index 0000000000..7cf36766af
--- /dev/null
+++ b/recipes/llvm/llvm2.7/BX_to_BLX.patch
@@ -0,0 +1,13 @@
+Index: llvm/lib/Target/ARM/ARMInstrInfo.td
+===================================================================
+--- llvm.orig/lib/Target/ARM/ARMInstrInfo.td 2009-10-06 12:35:26.000000000 +0000
++++ llvm/lib/Target/ARM/ARMInstrInfo.td 2009-10-06 12:36:03.000000000 +0000
+@@ -645,7 +645,7 @@
+ IIC_Br, "mov lr, pc\n\tbx $func",
+ [(ARMcall_nolink GPR:$func)]>,
+ Requires<[IsARM, IsNotDarwin]> {
+- let Inst{7-4} = 0b0001;
++ let Inst{7-4} = 0b0011;
+ let Inst{19-8} = 0b111111111111;
+ let Inst{27-20} = 0b00010010;
+ }
diff --git a/recipes/llvm/llvm2.7_2.6+svnr20090916.bb b/recipes/llvm/llvm2.7_2.6+svnr20091007.bb
index 4c4aac3968..142e15ea4f 100644
--- a/recipes/llvm/llvm2.7_2.6+svnr20090916.bb
+++ b/recipes/llvm/llvm2.7_2.6+svnr20091007.bb
@@ -1,6 +1,6 @@
require llvm.inc
-SRCREV = "82130"
+SRCREV = "83459"
PV = "2.6+svnr${SRCPV}"
@@ -11,7 +11,8 @@ DEPENDS = "llvm-common llvm2.7-native"
SRC_URI = "\
svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
file://llvm-debugonly-zeroormore.patch;patch=1 \
-"
+ file://BX_to_BLX.patch;patch=1 \
+ "
EXTRA_OECMAKE += "\
-DLLVM_TARGET_ARCH:STRING=${LLVM_ARCH} \