aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
authorXerxes Rånby <xerxes@zafena.se>2009-09-17 11:27:17 +0200
committerXerxes Rånby <xerxes@zafena.se>2009-09-17 11:37:41 +0200
commit718a561ceb1e9668678faaa863b65f670bf7015e (patch)
treef2b14937b53db7f4f700cdfe532c4ba3023d949d /recipes/llvm
parent05a753b24b94d4b1db756356820e3913a2e702bb (diff)
downloadopenembedded-718a561ceb1e9668678faaa863b65f670bf7015e.tar.gz
llvm 2.7: New recipe.
llvm-native 2.7: Likewise.
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm2.7-native_2.6+svnr20090916.bb16
-rw-r--r--recipes/llvm/llvm2.7/llvm-debugonly-zeroormore.patch13
-rw-r--r--recipes/llvm/llvm2.7_2.6+svnr20090916.bb24
3 files changed, 53 insertions, 0 deletions
diff --git a/recipes/llvm/llvm2.7-native_2.6+svnr20090916.bb b/recipes/llvm/llvm2.7-native_2.6+svnr20090916.bb
new file mode 100644
index 0000000000..ab0bbc5aa8
--- /dev/null
+++ b/recipes/llvm/llvm2.7-native_2.6+svnr20090916.bb
@@ -0,0 +1,16 @@
+require llvm-native.inc
+
+SRCREV = "82130"
+
+PV = "2.6+svnr${SRCREV}"
+
+PR = "r0"
+
+SRC_URI = "\
+ svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
+ file://llvm-debugonly-zeroormore.patch;patch=1 \
+"
+
+S = "${WORKDIR}/trunk"
+
+LLVM_RELEASE = "2.7"
diff --git a/recipes/llvm/llvm2.7/llvm-debugonly-zeroormore.patch b/recipes/llvm/llvm2.7/llvm-debugonly-zeroormore.patch
new file mode 100644
index 0000000000..ee32a7966c
--- /dev/null
+++ b/recipes/llvm/llvm2.7/llvm-debugonly-zeroormore.patch
@@ -0,0 +1,13 @@
+Index: trunk/lib/Support/Debug.cpp
+===================================================================
+--- trunk.orig/lib/Support/Debug.cpp 2009-09-17 10:41:42.000000000 +0200
++++ trunk/lib/Support/Debug.cpp 2009-09-17 10:42:55.000000000 +0200
+@@ -48,7 +48,7 @@
+ static cl::opt<DebugOnlyOpt, true, cl::parser<std::string> >
+ DebugOnly("debug-only", cl::desc("Enable a specific type of debug output"),
+ cl::Hidden, cl::value_desc("debug string"),
+- cl::location(DebugOnlyOptLoc), cl::ValueRequired);
++ cl::location(DebugOnlyOptLoc), cl::ValueRequired, cl::ZeroOrMore);
+
+ // isCurrentDebugType - Return true if the specified string is the debug type
+ // specified on the command line, or if none was specified on the command line
diff --git a/recipes/llvm/llvm2.7_2.6+svnr20090916.bb b/recipes/llvm/llvm2.7_2.6+svnr20090916.bb
new file mode 100644
index 0000000000..022657c5ff
--- /dev/null
+++ b/recipes/llvm/llvm2.7_2.6+svnr20090916.bb
@@ -0,0 +1,24 @@
+require llvm.inc
+
+SRCREV = "82130"
+
+PV = "2.6+svnr${SRCREV}"
+
+PR = "r0"
+
+DEPENDS = "llvm-common llvm2.7-native"
+
+SRC_URI = "\
+ svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
+ file://llvm-debugonly-zeroormore.patch;patch=1 \
+"
+
+EXTRA_OECMAKE += "\
+ -DLLVM_TARGET_ARCH:STRING=${LLVM_ARCH} \
+ -DLLVM_ENABLE_ASSERTIONS:BOOL=ON \
+ -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
+ "
+
+S = "${WORKDIR}/trunk"
+
+LLVM_RELEASE = "2.7"