aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2009-03-30 18:46:10 +0200
committerRobert Schuster <thebohemian@gmx.net>2009-03-31 11:55:04 +0200
commita0ac8cfacc3ae40983d47f8878d1697389f35de8 (patch)
tree882d0fbb17e5490f41ac336abc257dfb8f655a3c /recipes/llvm
parentb3dd934644e9785cd30d728b196c853fc4ca2388 (diff)
downloadopenembedded-a0ac8cfacc3ae40983d47f8878d1697389f35de8.tar.gz
llvm-native 1.9: Removed.
llvm-native 2.1: Removed. llvm-native 2.4: Removed. llvm-native cvs: Removed (llvm is not in a CVS repo anymore). llvm 2.0: Removed. llvm 2.4: Removed.
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm-native_1.9.bb9
-rw-r--r--recipes/llvm/llvm-native_2.1.bb16
-rw-r--r--recipes/llvm/llvm-native_2.4.bb15
-rw-r--r--recipes/llvm/llvm-native_cvs.bb13
-rw-r--r--recipes/llvm/llvm_2.0.bb6
-rw-r--r--recipes/llvm/llvm_2.4.bb47
6 files changed, 0 insertions, 106 deletions
diff --git a/recipes/llvm/llvm-native_1.9.bb b/recipes/llvm/llvm-native_1.9.bb
deleted file mode 100644
index 1493bab886..0000000000
--- a/recipes/llvm/llvm-native_1.9.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require llvm.inc
-
-inherit native
-
-S = "${WORKDIR}/llvm-${PV}"
-
-do_stage() {
- install -m 755 ${S}/Release/bin/* ${STAGING_BINDIR_NATIVE}/
-}
diff --git a/recipes/llvm/llvm-native_2.1.bb b/recipes/llvm/llvm-native_2.1.bb
deleted file mode 100644
index 6366b9bbbe..0000000000
--- a/recipes/llvm/llvm-native_2.1.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-require llvm.inc
-
-SRC_URI = "http://llvm.org/releases/2.1/llvm-${PV}.tar.gz"
-
-
-inherit native
-
-S = "${WORKDIR}/llvm-${PV}"
-
-do_stage() {
- install -m 755 ${S}/Release/bin/* ${STAGING_BINDIR_NATIVE}/
-}
-
-do_rm_work() {
- :
-}
diff --git a/recipes/llvm/llvm-native_2.4.bb b/recipes/llvm/llvm-native_2.4.bb
deleted file mode 100644
index 2e0a73fe86..0000000000
--- a/recipes/llvm/llvm-native_2.4.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-require llvm.inc
-
-SRC_URI = "http://llvm.org/releases/2.4/llvm-${PV}.tar.gz"
-
-inherit native
-
-S = "${WORKDIR}/llvm-${PV}"
-
-do_stage() {
- install -m 755 ${S}/Release/bin/* ${STAGING_BINDIR_NATIVE}/
-}
-
-do_rm_work() {
- :
-}
diff --git a/recipes/llvm/llvm-native_cvs.bb b/recipes/llvm/llvm-native_cvs.bb
deleted file mode 100644
index b3dfdebb2c..0000000000
--- a/recipes/llvm/llvm-native_cvs.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require llvm.inc
-
-inherit native
-
-PV = "1.9+cvs${SRCDATE}"
-
-SRC_URI = "cvs://anon@llvm.org/var/cvs/llvm;module=llvm"
-
-S = "${WORKDIR}/llvm"
-
-do_stage() {
- install -m 755 ${S}/Debug/bin/* ${STAGING_BINDIR_NATIVE}/
-}
diff --git a/recipes/llvm/llvm_2.0.bb b/recipes/llvm/llvm_2.0.bb
deleted file mode 100644
index 7e80f245cc..0000000000
--- a/recipes/llvm/llvm_2.0.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require llvm.inc
-
-SRC_URI = "http://llvm.org/releases/2.0/llvm-${PV}.tar.gz"
-
-S = "${WORKDIR}/llvm-${PV}"
-
diff --git a/recipes/llvm/llvm_2.4.bb b/recipes/llvm/llvm_2.4.bb
deleted file mode 100644
index fef48f5343..0000000000
--- a/recipes/llvm/llvm_2.4.bb
+++ /dev/null
@@ -1,47 +0,0 @@
-DESCRIPTION = "The Low Level Virtual Machine"
-HOMEPAGE = "http://llvm.org"
-LICENSE = "various"
-
-SRC_URI = "\
- http://llvm.org/releases/${PV}/llvm-${PV}.tar.gz \
- file://fix-build.patch;patch=1 \
- file://fix-static-initialization.patch;patch=1 \
- file://fix-ldr_pre.patch;patch=1 \
- "
-
-DEPENDS = "llvm-native"
-
-inherit autotools
-
-# --enable-debug-runtime disables automatic stripping and lets
-# OE control that
-EXTRA_OECONF += "--enable-debug-runtime --enable-targets=host-only"
-
-do_compile() {
- # The build wants these binaries, together with the build-fix patch
- # they are not compiled again (which would not work).
- # Most important aspect is removing BUILD_TARGET_DIRS variable.
- install -d Release/Build/bin
- cp ${STAGING_BINDIR_NATIVE}/tblgen Release/Build/bin
- cp ${STAGING_BINDIR_NATIVE}/fpcmp Release/Build/bin
- cp ${STAGING_BINDIR_NATIVE}/llvm-PerfectShuffle Release/Build/bin
-
- oe_runmake
-}
-
-do_stage() {
- autotools_stage_all
-
- rm ${STAGING_LIBDIR}/LLVMHello.*
-
- install -d ${STAGING_BINDIR_CROSS}
-
- sed -e's^my.*ABS_RUN_DIR =.*^my $ABS_RUN_DIR = "${STAGING_DIR_TARGET}";^' \
- -e's^my.*INCLUDEDIR =.*^my $INCLUDEDIR = "${STAGING_INCDIR}";^' \
- -e's^my.*LIBDIR.*^my $LIBDIR = "${STAGING_LIBDIR}";^' \
- -e's^my.*BINDIR.*^my $BINDIR = "${STAGING_BINDIR}";^' \
- Release/Host/bin/llvm-config > ${STAGING_BINDIR_CROSS}/llvm-config
-
- chmod +x ${STAGING_BINDIR_CROSS}/llvm-config
-}
-