aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lm_sensors
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/lm_sensors
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/lm_sensors')
-rw-r--r--recipes/lm_sensors/files/add-sysfs-ldflags.patch20
-rw-r--r--recipes/lm_sensors/files/iconv.patch13
-rw-r--r--recipes/lm_sensors/files/prefix-fix.patch14
-rw-r--r--recipes/lm_sensors/lmsensors-apps_2.10.1.bb47
-rw-r--r--recipes/lm_sensors/lmsensors-apps_2.10.8.bb50
-rw-r--r--recipes/lm_sensors/sensors-applet_2.2.1.bb13
6 files changed, 157 insertions, 0 deletions
diff --git a/recipes/lm_sensors/files/add-sysfs-ldflags.patch b/recipes/lm_sensors/files/add-sysfs-ldflags.patch
new file mode 100644
index 0000000000..25f13d8d4c
--- /dev/null
+++ b/recipes/lm_sensors/files/add-sysfs-ldflags.patch
@@ -0,0 +1,20 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- lm_sensors-2.10.0/lib/Module.mk~add-sysfs-ldflags
++++ lm_sensors-2.10.0/lib/Module.mk
+@@ -66,10 +66,10 @@
+ # How to create the shared library
+ ifdef SYSFS_SUPPORT
+ $(MODULE_DIR)/$(LIBSHLIBNAME): $(LIBSHOBJECTS)
+- $(CC) -shared -Wl,-soname,$(LIBSHSONAME) -o $@ $^ -lc -lm -lsysfs
++ $(CC) $(LDFLAGS) -shared -Wl,-soname,$(LIBSHSONAME) -o $@ $^ -lc -lm -lsysfs
+ else
+ $(MODULE_DIR)/$(LIBSHLIBNAME): $(LIBSHOBJECTS)
+- $(CC) -shared -Wl,-soname,$(LIBSHSONAME) -o $@ $^ -lc -lm
++ $(CC) $(LDFLAGS) -shared -Wl,-soname,$(LIBSHSONAME) -o $@ $^ -lc -lm
+ endif
+
+ $(MODULE_DIR)/$(LIBSHSONAME): $(MODULE_DIR)/$(LIBSHLIBNAME)
diff --git a/recipes/lm_sensors/files/iconv.patch b/recipes/lm_sensors/files/iconv.patch
new file mode 100644
index 0000000000..4aecafafb1
--- /dev/null
+++ b/recipes/lm_sensors/files/iconv.patch
@@ -0,0 +1,13 @@
+Index: lm_sensors-2.10.1/prog/sensors/Module.mk
+===================================================================
+--- lm_sensors-2.10.1.orig/prog/sensors/Module.mk 2006-09-24 22:30:10.000000000 +0000
++++ lm_sensors-2.10.1/prog/sensors/Module.mk 2007-04-14 22:11:47.000000000 +0000
+@@ -36,7 +36,7 @@
+ REMOVESENSORSBIN := $(patsubst $(MODULE_DIR)/%,$(DESTDIR)$(BINDIR)/%,$(PROGSENSORSTARGETS))
+ REMOVESENSORSMAN := $(patsubst $(MODULE_DIR)/%,$(DESTDIR)$(PROGSENSORSMAN1DIR)/%,$(PROGSENSORSMAN1FILES))
+
+-LIBICONV := $(shell if /sbin/ldconfig -p | grep -q libiconv\\.so ; then echo \-liconv; else echo; fi)
++LIBICONV := -liconv
+
+ $(PROGSENSORSTARGETS): $(PROGSENSORSSOURCES:.c=.ro) lib/$(LIBSHBASENAME)
+ $(CC) $(EXLDFLAGS) -o $@ $(PROGSENSORSSOURCES:.c=.ro) $(LIBICONV) -Llib -lsensors
diff --git a/recipes/lm_sensors/files/prefix-fix.patch b/recipes/lm_sensors/files/prefix-fix.patch
new file mode 100644
index 0000000000..66ec55c150
--- /dev/null
+++ b/recipes/lm_sensors/files/prefix-fix.patch
@@ -0,0 +1,14 @@
+Index: lm_sensors-2.10.1/Makefile
+===================================================================
+--- lm_sensors-2.10.1.orig/Makefile 2007-10-07 19:22:51.000000000 +0200
++++ lm_sensors-2.10.1/Makefile 2007-10-07 19:23:13.000000000 +0200
+@@ -74,9 +74,6 @@
+ # everything, set DESTDIR to the extra prefix.
+ DESTDIR :=
+
+-# This is the prefix that will be used for almost all directories below.
+-PREFIX := /usr/local
+-
+ # Your C compiler
+ CC := gcc
+
diff --git a/recipes/lm_sensors/lmsensors-apps_2.10.1.bb b/recipes/lm_sensors/lmsensors-apps_2.10.1.bb
new file mode 100644
index 0000000000..c6272555f5
--- /dev/null
+++ b/recipes/lm_sensors/lmsensors-apps_2.10.1.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "Hardware health monitoring applications"
+HOMEPAGE = "http://www.lm-sensors.org/"
+DEPENDS = "sysfsutils virtual/libiconv"
+LICENSE = "GPL"
+PR = "r3"
+
+SRC_URI = "http://dl.lm-sensors.org/lm-sensors/releases/lm_sensors-${PV}.tar.gz \
+ file://prefix-fix.patch;patch=1 \
+ file://add-sysfs-ldflags.patch;patch=1"
+
+SRC_URI_append_uclibc = "file://iconv.patch;patch=1"
+
+S = "${WORKDIR}/lm_sensors-${PV}"
+
+do_compile() {
+ oe_runmake user LINUX=${STAGING_KERNEL_DIR} EXLDFLAGS="${LDFLAGS}" PROG_EXTRA=sensors MACHINE=${TARGET_ARCH}
+}
+
+do_install() {
+ oe_runmake user_install DESTDIR=${D}
+
+ install -d ${D}/.usr
+ mv ${D}/* ${D}/.usr
+ mv ${D}/.usr ${D}/usr
+
+ install -d ${D}${sysconfdir}
+ mv ${D}/usr/etc/sensors.conf ${D}${sysconfdir}
+ # move manuals into proper place
+ install -d ${D}${mandir}
+ rm -rf ${D}${mandir}/*
+ mv ${D}/usr/man/* ${D}${mandir}
+
+
+PACKAGES =+ "libsensors libsensors-dev libsensors-dbg libsensors-doc"
+PACKAGES =+ "lmsensors-sensors lmsensors-sensors-dbg lmsensors-sensors-doc"
+PACKAGES =+ "lmsensors-scripts"
+
+FILES_lmsensors-scripts = "${bindir}/*.pl ${bindir}/ddcmon ${sbindir}/fancontrol* ${sbindir}/pwmconfig ${sbindir}/sensors-detect"
+RDEPENDS_lmsensors-scripts += "lmsensors-sensors perl bash"
+
+FILES_lmsensors-sensors = "${bindir}/sensors ${sysconfdir}"
+FILES_lmsensors-sensors-dbg += "${bindir}/.debug/sensors"
+FILES_lmsensors-sensors-doc = "${mandir}/man1 ${mandir}/man5"
+FILES_libsensors = "${libdir}/libsensors.so.*"
+FILES_libsensors-dbg += "${libdir}/.debug"
+FILES_libsensors-dev = "${libdir}/libsensors.so ${libdir}/libsensors.a ${includedir}"
+FILES_libsensors-doc = "${mandir}/man3"
diff --git a/recipes/lm_sensors/lmsensors-apps_2.10.8.bb b/recipes/lm_sensors/lmsensors-apps_2.10.8.bb
new file mode 100644
index 0000000000..8947ffb5b3
--- /dev/null
+++ b/recipes/lm_sensors/lmsensors-apps_2.10.8.bb
@@ -0,0 +1,50 @@
+DESCRIPTION = "Hardware health monitoring applications"
+HOMEPAGE = "http://www.lm-sensors.org/"
+DEPENDS = "sysfsutils virtual/libiconv"
+LICENSE = "GPL"
+
+SRC_URI = "http://dl.lm-sensors.org/lm-sensors/releases/lm_sensors-${PV}.tar.gz \
+ file://prefix-fix.patch;patch=1 \
+ file://add-sysfs-ldflags.patch;patch=1"
+
+SRC_URI_append_uclibc = "file://iconv.patch;patch=1"
+
+S = "${WORKDIR}/lm_sensors-${PV}"
+
+do_compile() {
+ oe_runmake user LINUX=${STAGING_KERNEL_DIR} EXLDFLAGS="${LDFLAGS}" PROG_EXTRA=sensors MACHINE=${TARGET_ARCH}
+}
+
+do_install() {
+ oe_runmake user_install DESTDIR=${D}
+
+ install -d ${D}/.usr
+ mv ${D}/* ${D}/.usr
+ mv ${D}/.usr ${D}/usr
+
+ install -d ${D}${sysconfdir}
+ mv ${D}/usr/etc/sensors.conf ${D}${sysconfdir}
+ # move manuals into proper place
+ install -d ${D}${mandir}
+ rm -rf ${D}${mandir}/*
+ mv ${D}/usr/man/* ${D}${mandir}
+}
+
+do_stage() {
+ oe_runmake user_install DESTDIR=${STAGING_DIR_TARGET}/${layout_prefix}
+}
+
+PACKAGES =+ "libsensors libsensors-dev libsensors-dbg libsensors-doc"
+PACKAGES =+ "lmsensors-sensors lmsensors-sensors-dbg lmsensors-sensors-doc"
+PACKAGES =+ "lmsensors-scripts"
+
+FILES_lmsensors-scripts = "${bindir}/*.pl ${bindir}/ddcmon ${sbindir}/fancontrol* ${sbindir}/pwmconfig ${sbindir}/sensors-detect"
+RDEPENDS_lmsensors-scripts += "lmsensors-sensors perl bash"
+
+FILES_lmsensors-sensors = "${bindir}/sensors ${sysconfdir}"
+FILES_lmsensors-sensors-dbg += "${bindir}/.debug/sensors"
+FILES_lmsensors-sensors-doc = "${mandir}/man1 ${mandir}/man5"
+FILES_libsensors = "${libdir}/libsensors.so.*"
+FILES_libsensors-dbg += "${libdir}/.debug"
+FILES_libsensors-dev = "${libdir}/libsensors.so ${libdir}/libsensors.a ${includedir}"
+FILES_libsensors-doc = "${mandir}/man3"
diff --git a/recipes/lm_sensors/sensors-applet_2.2.1.bb b/recipes/lm_sensors/sensors-applet_2.2.1.bb
new file mode 100644
index 0000000000..40f8823172
--- /dev/null
+++ b/recipes/lm_sensors/sensors-applet_2.2.1.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "GNOME Sensors Applet is an applet for the GNOME Panel to display readings from hardware sensors"
+LICENSE = "GPLv2"
+
+inherit gnome
+
+DEPENDS += "gnome-panel libnotify"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sensors-applet/sensors-applet-${PV}.tar.gz"
+
+EXTRA_OECONF = " --disable-scrollkeeper --with-libsensors=${STAGING_LIBDIR}/../ "
+
+FILES_${PN}-dbg += "${libdir}/sensors-applet/plugins/"
+