aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/log4cxx/log4cxx_0.9.7.bb
diff options
context:
space:
mode:
authorLucian Ion <luciani@luciani-laptop.(none)>2009-06-05 11:43:22 +0100
committerPhil Blundell <philb@gnu.org>2009-06-05 13:51:24 +0100
commit19160b953fdddd2a0a05361880e6adfb48668aeb (patch)
tree8151633dbd9de1e6972f8383910970dbfdd80be2 /recipes/log4cxx/log4cxx_0.9.7.bb
parentd145ebb48a5cd76a758c763e8ac8785423865456 (diff)
downloadopenembedded-19160b953fdddd2a0a05361880e6adfb48668aeb.tar.gz
add log4cxx recipes from apache
Diffstat (limited to 'recipes/log4cxx/log4cxx_0.9.7.bb')
-rw-r--r--recipes/log4cxx/log4cxx_0.9.7.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/log4cxx/log4cxx_0.9.7.bb b/recipes/log4cxx/log4cxx_0.9.7.bb
new file mode 100644
index 0000000000..4817163e1f
--- /dev/null
+++ b/recipes/log4cxx/log4cxx_0.9.7.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Apache logging framework for C++ library"
+SECTION = "libs"
+DEPENDS = "apr apr-util expat gdbm"
+LICENSE = "Apache License, Version 2.0"
+HOMEPAGE = "http://logging.apache.org/log4cxx/"
+# PV = "0.10.0"
+PR = "r1"
+
+SRC_URI = "http://archive.apache.org/dist/logging/log4cxx/log4cxx-0.9.7.tar.gz \
+ file://log4cxx097.patch;patch=1"
+
+#build this:
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}