aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/log4cxx
diff options
context:
space:
mode:
authorLucian Ion <luciani@luciani-laptop.(none)>2009-06-05 11:43:22 +0100
committerPhil Blundell <philb@gnu.org>2009-06-05 13:51:24 +0100
commit19160b953fdddd2a0a05361880e6adfb48668aeb (patch)
tree8151633dbd9de1e6972f8383910970dbfdd80be2 /recipes/log4cxx
parentd145ebb48a5cd76a758c763e8ac8785423865456 (diff)
downloadopenembedded-19160b953fdddd2a0a05361880e6adfb48668aeb.tar.gz
add log4cxx recipes from apache
Diffstat (limited to 'recipes/log4cxx')
-rw-r--r--recipes/log4cxx/log4cxx/log4cxx097.patch48
-rw-r--r--recipes/log4cxx/log4cxx_0.9.7.bb19
2 files changed, 67 insertions, 0 deletions
diff --git a/recipes/log4cxx/log4cxx/log4cxx097.patch b/recipes/log4cxx/log4cxx/log4cxx097.patch
new file mode 100644
index 0000000000..86b6effdb0
--- /dev/null
+++ b/recipes/log4cxx/log4cxx/log4cxx097.patch
@@ -0,0 +1,48 @@
+--- log4cxx-0.9.7/src/socketoutputstream.cpp~ 2009-05-21 10:06:47.000000000 +0100
++++ log4cxx-0.9.7/src/socketoutputstream.cpp 2009-05-21 10:06:47.000000000 +0100
+@@ -13,7 +13,8 @@
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+-
++
++#include <string.h>
+ #include <log4cxx/helpers/socketoutputstream.h>
+ #include <log4cxx/helpers/socket.h>
+ #include <log4cxx/helpers/loglog.h>
+
+--- log4cxx-0.9.7/src/stringtokenizer.cpp~ 2009-05-21 10:11:19.000000000 +0100
++++ log4cxx-0.9.7/src/stringtokenizer.cpp 2009-05-21 10:11:20.000000000 +0100
+@@ -13,7 +13,8 @@
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+-
++
++#include <string.h>
+ #include <log4cxx/helpers/stringtokenizer.h>
+
+ using namespace log4cxx;
+
+--- log4cxx-0.9.7/src/timezone.cpp~ 2009-05-21 10:14:27.000000000 +0100
++++ log4cxx-0.9.7/src/timezone.cpp 2009-05-21 10:14:27.000000000 +0100
+@@ -13,7 +13,8 @@
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+-
++
++#include <string.h>
+ #include <log4cxx/helpers/timezone.h>
+ #include <locale>
+
+--- log4cxx-0.9.7/src/xmlsocketappender.cpp~ 2009-05-21 10:16:24.000000000 +0100
++++ log4cxx-0.9.7/src/xmlsocketappender.cpp 2009-05-21 10:16:25.000000000 +0100
+@@ -14,6 +14,7 @@
+ * limitations under the License.
+ */
+
++#include <string.h>
+ #include <log4cxx/net/xmlsocketappender.h>
+ #include <log4cxx/helpers/loglog.h>
+ #include <log4cxx/helpers/socketoutputstream.h>
diff --git a/recipes/log4cxx/log4cxx_0.9.7.bb b/recipes/log4cxx/log4cxx_0.9.7.bb
new file mode 100644
index 0000000000..4817163e1f
--- /dev/null
+++ b/recipes/log4cxx/log4cxx_0.9.7.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Apache logging framework for C++ library"
+SECTION = "libs"
+DEPENDS = "apr apr-util expat gdbm"
+LICENSE = "Apache License, Version 2.0"
+HOMEPAGE = "http://logging.apache.org/log4cxx/"
+# PV = "0.10.0"
+PR = "r1"
+
+SRC_URI = "http://archive.apache.org/dist/logging/log4cxx/log4cxx-0.9.7.tar.gz \
+ file://log4cxx097.patch;patch=1"
+
+#build this:
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}