aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lowlevel_topas910
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2009-04-22 11:48:31 +0200
committerFlorian Boor <florian.boor@kernelconcepts.de>2009-04-22 13:00:23 +0200
commit6a1b13cfbcd16e482e95ff6da79afabb1338f3f1 (patch)
tree2d647eb6b36f4b6426c67e3815a0f6dbf440d654 /recipes/lowlevel_topas910
parentafa8c86350f8fd77e32c96c2310d217c611853f6 (diff)
downloadopenembedded-6a1b13cfbcd16e482e95ff6da79afabb1338f3f1.tar.gz
New recipe: lowlevel-topas910, a mini bootloader for the Topas910
Diffstat (limited to 'recipes/lowlevel_topas910')
-rw-r--r--recipes/lowlevel_topas910/lowlevel-topas910_1.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/lowlevel_topas910/lowlevel-topas910_1.0.bb b/recipes/lowlevel_topas910/lowlevel-topas910_1.0.bb
new file mode 100644
index 0000000000..6a814a2462
--- /dev/null
+++ b/recipes/lowlevel_topas910/lowlevel-topas910_1.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Lowlevel - a simple bootloader for the Toshiba Topas 910."
+SECTION = "bootloaders"
+PRIORITY = "optional"
+LICENSE = "BSD"
+PROVIDES = "virtual/bootloader"
+DEPENDS = "virtual/kernel"
+PR = "r0"
+
+inherit gpe
+
+SRC_URI = "http://www.bplan-gmbh.org/data/toshiba/topas/linux/2.6.26.5/lowlevel_topas910.tar.bz2"
+
+
+S = "${WORKDIR}/lowlevel/"
+
+CFLAGS_append = " -D__LITTLEENDIAN__ -ffreestanding -I. -include ./arm.h -include ./simple_io32.h"
+
+do_install () {
+}
+
+do_deploy () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install ${S}/bootstart_tmpa910.bin ${DEPLOY_DIR_IMAGE}/bootstart_tmpa910.bin
+ dd if=/dev/full of=/tmp/pad bs=1k count=256
+ cat ${S}/bootstart_tmpa910.bin /tmp/pad > /tmp/pad1
+ dd if=/tmp/pad1 of=/tmp/pad2 bs=1k count=256
+ cat /tmp/pad2 ${DEPLOY_DIR_IMAGE}/zImage-topas910.bin > ${DEPLOY_DIR_IMAGE}/flashimage-topas910.bin
+}
+
+do_deploy[dirs] = "${S}"
+addtask deploy before do_build after do_compile