aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lvm2
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/lvm2
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/lvm2')
-rw-r--r--recipes/lvm2/lvm2-2.01.15/crosscompile_fix.patch13
-rw-r--r--recipes/lvm2/lvm2_2.01.09.bb12
-rw-r--r--recipes/lvm2/lvm2_2.01.15.bb16
3 files changed, 41 insertions, 0 deletions
diff --git a/recipes/lvm2/lvm2-2.01.15/crosscompile_fix.patch b/recipes/lvm2/lvm2-2.01.15/crosscompile_fix.patch
new file mode 100644
index 0000000000..7f54f80072
--- /dev/null
+++ b/recipes/lvm2/lvm2-2.01.15/crosscompile_fix.patch
@@ -0,0 +1,13 @@
+Index: LVM2.2.01.15/make.tmpl.in
+===================================================================
+--- LVM2.2.01.15.orig/make.tmpl.in 2008-03-26 11:24:50.000000000 +0000
++++ LVM2.2.01.15/make.tmpl.in 2008-03-26 11:25:02.000000000 +0000
+@@ -72,7 +72,7 @@
+ CFLAGS += -DINTL_PACKAGE=\"@INTL_PACKAGE@\" -DLOCALEDIR=\"@LOCALEDIR@\"
+ endif
+
+-LDFLAGS += -L$(top_srcdir)/lib -L$(libdir)
++LDFLAGS += -L$(top_srcdir)/lib
+
+ #CFLAGS += -DDEBUG_POOL
+ #CFLAGS += -DBOUNDS_CHECK
diff --git a/recipes/lvm2/lvm2_2.01.09.bb b/recipes/lvm2/lvm2_2.01.09.bb
new file mode 100644
index 0000000000..bc8386f2ce
--- /dev/null
+++ b/recipes/lvm2/lvm2_2.01.09.bb
@@ -0,0 +1,12 @@
+SECTION = "utils"
+DESCRIPTION = "LVM2 is a set of utilities to manage logical volumes in Linux."
+LICENSE = "GPL"
+PR = "r1"
+DEPENDS = "device-mapper"
+
+S = "${WORKDIR}/LVM2.${PV}"
+
+SRC_URI = "ftp://sources.redhat.com/pub/lvm2/LVM2.${PV}.tgz"
+
+inherit autotools
+
diff --git a/recipes/lvm2/lvm2_2.01.15.bb b/recipes/lvm2/lvm2_2.01.15.bb
new file mode 100644
index 0000000000..61a18ab87e
--- /dev/null
+++ b/recipes/lvm2/lvm2_2.01.15.bb
@@ -0,0 +1,16 @@
+SECTION = "utils"
+DESCRIPTION = "LVM2 is a set of utilities to manage logical volumes in Linux."
+LICENSE = "GPL"
+PR = "r1"
+DEPENDS = "device-mapper"
+
+S = "${WORKDIR}/LVM2.${PV}"
+
+SRC_URI = "ftp://sources.redhat.com/pub/lvm2/LVM2.${PV}.tgz \
+ file://crosscompile_fix.patch;patch=1"
+
+# Unset user/group to unbreak install.
+EXTRA_OECONF = "--with-user= --with-group= --disable-o_direct"
+EXTRA_OECONF_arm = "--with-user= --with-group= --disable-o_direct"
+inherit autotools
+