aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/madwifi
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/madwifi
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/madwifi')
-rw-r--r--recipes/madwifi/madwifi-modules_0.9.3.bb4
-rw-r--r--recipes/madwifi/madwifi-ng_r.inc12
-rw-r--r--recipes/madwifi/madwifi-ng_r3314-20080131.bb2
-rw-r--r--recipes/madwifi/madwifi-ng_r3837-20080802.bb8
-rw-r--r--recipes/madwifi/madwifi-ng_r4029-20090525.bb6
5 files changed, 16 insertions, 16 deletions
diff --git a/recipes/madwifi/madwifi-modules_0.9.3.bb b/recipes/madwifi/madwifi-modules_0.9.3.bb
index c224e36c74..539149852f 100644
--- a/recipes/madwifi/madwifi-modules_0.9.3.bb
+++ b/recipes/madwifi/madwifi-modules_0.9.3.bb
@@ -9,8 +9,8 @@ SRCDATE = "20050803"
PV = "0.9.3"
SRC_URI = "${SOURCEFORGE_MIRROR}/madwifi/madwifi-${PV}.tar.bz2 \
- file://madwifi-devname.patch;apply=yes \
- file://madwifi-skbpanic.patch;apply=yes"
+ file://madwifi-devname.patch \
+ file://madwifi-skbpanic.patch"
S = "${WORKDIR}/madwifi-${PV}"
inherit module-base
diff --git a/recipes/madwifi/madwifi-ng_r.inc b/recipes/madwifi/madwifi-ng_r.inc
index dee746f544..baab484e49 100644
--- a/recipes/madwifi/madwifi-ng_r.inc
+++ b/recipes/madwifi/madwifi-ng_r.inc
@@ -7,15 +7,15 @@ DEPENDS = "virtual/kernel"
PR ="r6"
WACKELF_SRC_URI = ""
-WACKELF_SRC_URI_ixp4xx = " file://20-xscale-VFP-wackelf.patch;apply=yes"
-WACKELF_SRC_URI_compulab-pxa270 = " file://20-xscale-VFP-wackelf.patch;apply=yes"
+WACKELF_SRC_URI_ixp4xx = " file://20-xscale-VFP-wackelf.patch"
+WACKELF_SRC_URI_compulab-pxa270 = " file://20-xscale-VFP-wackelf.patch"
SRCNAME = "${PN}"
SRC_URI = "http://snapshots.madwifi-project.org/madwifi-trunk/${SRCNAME}-${PV}.tar.gz \
- file://10-xscale-be-elf-copts.patch;apply=yes \
- file://10-xscale-le-elf-copts.patch;apply=yes \
- file://10-sh4-le-elf-copts.patch;apply=yes \
- file://powerpc-fix.patch;apply=yes \
+ file://10-xscale-be-elf-copts.patch \
+ file://10-xscale-le-elf-copts.patch \
+ file://10-sh4-le-elf-copts.patch \
+ file://powerpc-fix.patch \
${WACKELF_SRC_URI}"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/recipes/madwifi/madwifi-ng_r3314-20080131.bb b/recipes/madwifi/madwifi-ng_r3314-20080131.bb
index 912d0703d5..75c9851541 100644
--- a/recipes/madwifi/madwifi-ng_r3314-20080131.bb
+++ b/recipes/madwifi/madwifi-ng_r3314-20080131.bb
@@ -7,7 +7,7 @@ PACKAGE_STRIP = "no"
require madwifi-ng_r.inc
SRC_URI += " \
- file://30-define-ioreadwrite32be-for-little-endian-too.patch;apply=yes \
+ file://30-define-ioreadwrite32be-for-little-endian-too.patch \
"
# PR set after the include, to override what's set in the included file.
diff --git a/recipes/madwifi/madwifi-ng_r3837-20080802.bb b/recipes/madwifi/madwifi-ng_r3837-20080802.bb
index 8bbbcc9d7f..9d49f1285b 100644
--- a/recipes/madwifi/madwifi-ng_r3837-20080802.bb
+++ b/recipes/madwifi/madwifi-ng_r3837-20080802.bb
@@ -9,11 +9,11 @@ require madwifi-ng_r.inc
# Due to a minor Makefile restructuring, newer versions require an updated
# patch; this is really ugly and some alternate way to do this that's more
# generic should be figured out.
-WACKELF_SRC_URI_ixp4xx = " file://20-xscale-VFP-wackelf-v2.patch;apply=yes"
-WACKELF_SRC_URI_compulab-pxa270 = " file://20-xscale-VFP-wackelf-v2.patch;apply=yes"
+WACKELF_SRC_URI_ixp4xx = " file://20-xscale-VFP-wackelf-v2.patch"
+WACKELF_SRC_URI_compulab-pxa270 = " file://20-xscale-VFP-wackelf-v2.patch"
-SRC_URI += "file://respect-ldflags.patch;apply=yes"
-SRC_URI += "file://madwifi-fix-2.6.30.patch;apply=yes"
+SRC_URI += "file://respect-ldflags.patch"
+SRC_URI += "file://madwifi-fix-2.6.30.patch"
SRCNAME = "madwifi-trunk"
diff --git a/recipes/madwifi/madwifi-ng_r4029-20090525.bb b/recipes/madwifi/madwifi-ng_r4029-20090525.bb
index 2061b64cce..ef21695f3d 100644
--- a/recipes/madwifi/madwifi-ng_r4029-20090525.bb
+++ b/recipes/madwifi/madwifi-ng_r4029-20090525.bb
@@ -9,11 +9,11 @@ require madwifi-ng_r.inc
# Due to a minor Makefile restructuring, newer versions require an updated
# patch; this is really ugly and some alternate way to do this that's more
# generic should be figured out.
-WACKELF_SRC_URI_ixp4xx = " file://20-xscale-VFP-wackelf-v2.patch;apply=yes"
-WACKELF_SRC_URI_compulab-pxa270 = " file://20-xscale-VFP-wackelf-v2.patch;apply=yes"
+WACKELF_SRC_URI_ixp4xx = " file://20-xscale-VFP-wackelf-v2.patch"
+WACKELF_SRC_URI_compulab-pxa270 = " file://20-xscale-VFP-wackelf-v2.patch"
SRC_URI = "http://snapshots.madwifi-project.org/madwifi-trunk/${SRCNAME}-${PV}.tar.gz \
- file://respect-ldflags.patch;apply=yes"
+ file://respect-ldflags.patch"
SRCNAME = "madwifi-trunk"