aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/maemo-mapper
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/maemo-mapper
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/maemo-mapper')
-rw-r--r--recipes/maemo-mapper/files/fix_segfault.patch31
-rw-r--r--recipes/maemo-mapper/files/mapper-hildon1.diff20
-rw-r--r--recipes/maemo-mapper/maemo-mapper-nohildon_svn.bb22
-rw-r--r--recipes/maemo-mapper/maemo-mapper_svn.bb21
4 files changed, 94 insertions, 0 deletions
diff --git a/recipes/maemo-mapper/files/fix_segfault.patch b/recipes/maemo-mapper/files/fix_segfault.patch
new file mode 100644
index 0000000000..23730e8c01
--- /dev/null
+++ b/recipes/maemo-mapper/files/fix_segfault.patch
@@ -0,0 +1,31 @@
+ src/maemo-mapper.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+Index: trunk/src/maemo-mapper.c
+===================================================================
+--- trunk.orig/src/maemo-mapper.c 2006-11-28 15:11:49.000000000 +0000
++++ trunk/src/maemo-mapper.c 2006-11-28 22:40:19.000000000 +0000
+@@ -140,8 +140,8 @@
+ #define HILDON_HARDKEY_RIGHT GDK_Right
+ #define HILDON_HARDKEY_SELECT GDK_Return
+ #define HILDON_HARDKEY_FULLSCREEN GDK_F10
+-#define HILDON_HARDKEY_INCREASE GDK_F6
+-#define HILDON_HARDKEY_DECREASE GDK_F5
++#define HILDON_HARDKEY_INCREASE GDK_plus
++#define HILDON_HARDKEY_DECREASE GDK_minus
+ #define HILDON_HARDKEY_ESC GDK_Escape
+ #define HILDON_COLOR_BUTTON GTK_COLOR_BUTTON
+
+@@ -3117,9 +3117,9 @@ set_conn_state(ConnState new_conn_state)
+ gtk_widget_destroy(_fix_banner);
+ _fix_banner = NULL;
+ }
+- if(!_connect_banner)
+- _connect_banner = hildon_banner_show_animation(
+- _window, NULL, _("Searching for GPS receiver"));
++// if(!_connect_banner)
++// _connect_banner = hildon_banner_show_animation(
++// _window, NULL, _("Searching for GPS receiver"));
+ break;
+ case RCVR_UP:
+ if(_connect_banner)
diff --git a/recipes/maemo-mapper/files/mapper-hildon1.diff b/recipes/maemo-mapper/files/mapper-hildon1.diff
new file mode 100644
index 0000000000..55ea791955
--- /dev/null
+++ b/recipes/maemo-mapper/files/mapper-hildon1.diff
@@ -0,0 +1,20 @@
+--- /tmp/maemo-mapper.c 2007-10-02 12:15:04.000000000 +0200
++++ maemo-mapper/src/maemo-mapper.c 2007-10-02 12:18:06.622045000 +0200
+@@ -52,7 +52,7 @@
+ #include <hildon-widgets/hildon-controlbar.h>
+ #include <hildon-widgets/hildon-note.h>
+ #include <hildon-widgets/hildon-color-button.h>
+-#include <hildon-widgets/hildon-file-chooser-dialog.h>
++#include <hildon-fm-2/hildon/hildon-file-chooser-dialog.h>
+ #include <hildon-widgets/hildon-number-editor.h>
+ #include <hildon-widgets/hildon-banner.h>
+ #include <hildon-widgets/hildon-system-sound.h>
+@@ -6532,8 +6532,6 @@
+
+ gtk_widget_show_all(GTK_WIDGET(menu));
+
+- gtk_widget_tap_and_hold_setup(_map_widget, GTK_WIDGET(menu), NULL, 0);
+-
+ vprintf("%s(): return\n", __PRETTY_FUNCTION__);
+ }
+
diff --git a/recipes/maemo-mapper/maemo-mapper-nohildon_svn.bb b/recipes/maemo-mapper/maemo-mapper-nohildon_svn.bb
new file mode 100644
index 0000000000..ceda4ff811
--- /dev/null
+++ b/recipes/maemo-mapper/maemo-mapper-nohildon_svn.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GPS navigation/map display software"
+LICENSE = "GPL"
+DEPENDS = "sqlite3 gtk+ gnome-vfs dbus bluez-libs"
+RDEPENDS = "bluez-utils"
+PV = "1.2.4+svn${SRCDATE}"
+PR = "r1"
+
+# Only works with SRCDATE_maemo-mapper-nohildon = "20061114"
+SRC_URI = "svn://garage.maemo.org/svn/maemo-mapper;proto=https;module=trunk \
+ http://home.tal.org/%7Emilang/n770/maemo-mapper-desktop-20061114-001.patch;patch=1;pnum=0 \
+ file://fix_segfault.patch;patch=1"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}${datadir}/applications/
+ mv ${D}/maemo-mapper.desktop ${D}${datadir}/applications/
+}
+
+#FILES_${PN} += "${datadir}/icons"
diff --git a/recipes/maemo-mapper/maemo-mapper_svn.bb b/recipes/maemo-mapper/maemo-mapper_svn.bb
new file mode 100644
index 0000000000..39e89fcc98
--- /dev/null
+++ b/recipes/maemo-mapper/maemo-mapper_svn.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "GPS navigation/map display software"
+LICENSE = "GPL"
+DEPENDS = "gdbm libconic sqlite3 gtk+ libhildonfm libosso osso-ic-oss libosso-help gnome-vfs dbus bluez-libs"
+RDEPENDS = "bluez-utils"
+RRECOMMENDS = "gpsd flite"
+PV = "2.0.3+svnr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "svn://garage.maemo.org/svn/maemo-mapper;proto=https;module=trunk \
+ file://mapper-hildon1.diff;patch=1;maxrev=108"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}${datadir}/applications/
+ mv ${D}/maemo-mapper.desktop ${D}${datadir}/applications/
+}
+
+#FILES_${PN} += "${datadir}/icons"