aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/maemo4
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/maemo4
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/maemo4')
-rw-r--r--recipes/maemo4/hildon-control-panel_2.0.1.bb20
-rw-r--r--recipes/maemo4/hildon-thumbnail.inc19
-rw-r--r--recipes/maemo4/hildon-thumbnail_0.14.bb10
-rw-r--r--recipes/maemo4/libconic_0.13.bb15
-rw-r--r--recipes/maemo4/libgpsbt_0.1.bb15
-rw-r--r--recipes/maemo4/libgpsmgr_0.1.bb13
-rw-r--r--recipes/maemo4/libhildon.inc13
-rw-r--r--recipes/maemo4/libhildon/libhildon-buildfix.patch16
-rw-r--r--recipes/maemo4/libhildon_1.99.0.bb11
-rw-r--r--recipes/maemo4/libhildonfm.inc27
-rw-r--r--recipes/maemo4/libhildonfm/libhildonfm-gtkmaemo-ifdef.patch133
-rw-r--r--recipes/maemo4/libhildonfm_1.9.46.bb9
-rw-r--r--recipes/maemo4/libhildonhelp.inc17
-rw-r--r--recipes/maemo4/libhildonhelp_1.9.6.bb6
-rw-r--r--recipes/maemo4/libhildonmime.inc17
-rw-r--r--recipes/maemo4/libhildonmime_1.10.0.bb9
-rw-r--r--recipes/maemo4/libhildonmime_1.9.5.bb6
-rw-r--r--recipes/maemo4/libosso-gsf_1.11.10.4.bb21
-rw-r--r--recipes/maemo4/libosso-help_2.1.2.bb24
-rw-r--r--recipes/maemo4/libosso.inc19
-rw-r--r--recipes/maemo4/libosso/libosso-buildfix.patch64
-rw-r--r--recipes/maemo4/libosso/libosso-dont-use-inline.patch47
-rw-r--r--recipes/maemo4/libosso_2.13.bb17
-rw-r--r--recipes/maemo4/mce-dev.inc22
-rw-r--r--recipes/maemo4/mce-dev_1.6.3.bb7
-rw-r--r--recipes/maemo4/osso-gnome-vfs2/gnome-vfs-no-kerberos.patch51
-rw-r--r--recipes/maemo4/osso-gnome-vfs2_2.16.3.bb51
-rw-r--r--recipes/maemo4/osso-gwconnect.inc17
-rw-r--r--recipes/maemo4/osso-gwconnect_1.0.12.bb8
-rw-r--r--recipes/maemo4/osso-ic-oss/dbus-api-update.patch33
-rw-r--r--recipes/maemo4/osso-ic-oss_1.0.4.bb25
31 files changed, 762 insertions, 0 deletions
diff --git a/recipes/maemo4/hildon-control-panel_2.0.1.bb b/recipes/maemo4/hildon-control-panel_2.0.1.bb
new file mode 100644
index 0000000000..d7dd6c3e90
--- /dev/null
+++ b/recipes/maemo4/hildon-control-panel_2.0.1.bb
@@ -0,0 +1,20 @@
+LICENSE = "GPL"
+
+DEPENDS = "libosso libhildon gnome-vfs libhildonhelp"
+
+SRC_URI = "http://repository.maemo.org/pool/os2008/free/source/h/hildon-control-panel/hildon-control-panel_2.0.1-1.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${libdir}/dbus-1.0 ${datadir}/applications"
+
+do_stage() {
+ autotools_stage_all
+}
+
+# pkg-config file will get broken after pkgconfig.bbclass work
+#
+# This code will fix it
+#
+# sed -i -e 's:${STAGING_LIBDIR}/hildon:${libdir}/hildon:g' -e 's:${STAGING_DATADIR}/applications/hildon:${datadir}/applications/hildon:g' ${PKG_CONFIG_DIR}/hildon-control-panel.pc
+#
diff --git a/recipes/maemo4/hildon-thumbnail.inc b/recipes/maemo4/hildon-thumbnail.inc
new file mode 100644
index 0000000000..46468e1ca1
--- /dev/null
+++ b/recipes/maemo4/hildon-thumbnail.inc
@@ -0,0 +1,19 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia hildon thumbnail library"
+
+DEPENDS = "libhildonmime"
+
+inherit autotools pkgconfig lib_package
+
+do_configure_prepend() {
+ # remove Werror from OSSO_CFLAGS
+ sed -i s:-Werror::g configure.ac
+
+ touch gtk-doc.make
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/maemo4/hildon-thumbnail_0.14.bb b/recipes/maemo4/hildon-thumbnail_0.14.bb
new file mode 100644
index 0000000000..4098e465b1
--- /dev/null
+++ b/recipes/maemo4/hildon-thumbnail_0.14.bb
@@ -0,0 +1,10 @@
+require hildon-thumbnail.inc
+
+DEPENDS = "libhildon libosso osso-gnome-vfs2"
+
+PR = "r0"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo4.0/free/source/h/${PN}/${PN}_${PV}.tar.gz \
+ "
+
+
diff --git a/recipes/maemo4/libconic_0.13.bb b/recipes/maemo4/libconic_0.13.bb
new file mode 100644
index 0000000000..5f57cf77b1
--- /dev/null
+++ b/recipes/maemo4/libconic_0.13.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Internet connection library"
+LICENSE = "LGPL"
+DEPENDS = "dbus gconf osso-ic-oss"
+
+PR = "r1"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo4.0/free/source/libc/${PN}/${PN}_${PV}-0.8.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/maemo4/libgpsbt_0.1.bb b/recipes/maemo4/libgpsbt_0.1.bb
new file mode 100644
index 0000000000..beca783a0b
--- /dev/null
+++ b/recipes/maemo4/libgpsbt_0.1.bb
@@ -0,0 +1,15 @@
+LICENSE = "nokia"
+
+DEPENDS = "libgpsmgr dbus"
+
+# This is proprietary software in Chinook, so we have to stay with the last released
+# free version.
+SRC_URI = "http://repository.maemo.org/pool/bora/free/source/${PN}_${PV}-18.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/maemo4/libgpsmgr_0.1.bb b/recipes/maemo4/libgpsmgr_0.1.bb
new file mode 100644
index 0000000000..bcbb4cefcb
--- /dev/null
+++ b/recipes/maemo4/libgpsmgr_0.1.bb
@@ -0,0 +1,13 @@
+LICENSE = "nokia"
+
+# This is proprietary software in Chinook, so we have to stay with the last released
+# free version.
+SRC_URI = "http://repository.maemo.org/pool/bora/free/source/${PN}_${PV}-10.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/maemo4/libhildon.inc b/recipes/maemo4/libhildon.inc
new file mode 100644
index 0000000000..bab16cf062
--- /dev/null
+++ b/recipes/maemo4/libhildon.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Hildon widget library"
+LICENSE = "LGPL"
+
+DEPENDS = "gconf-dbus esound gtk+"
+
+inherit autotools pkgconfig lib_package
+
+EXTRA_OECONF = "--with-maemo-gtk=no"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/maemo4/libhildon/libhildon-buildfix.patch b/recipes/maemo4/libhildon/libhildon-buildfix.patch
new file mode 100644
index 0000000000..b9a669c76a
--- /dev/null
+++ b/recipes/maemo4/libhildon/libhildon-buildfix.patch
@@ -0,0 +1,16 @@
+Index: libhildon-1.99.0/src/hildon-code-dialog.c
+===================================================================
+--- libhildon-1.99.0.orig/src/hildon-code-dialog.c 2007-10-10 15:03:09.000000000 +0200
++++ libhildon-1.99.0/src/hildon-code-dialog.c 2008-02-13 13:54:47.000000000 +0100
+@@ -302,7 +302,11 @@
+ gtk_container_add (GTK_CONTAINER (priv->buttons[3][2]), image1);
+ dialog_action_area1 = GTK_DIALOG (dialog)->action_area;
+ gtk_button_box_set_layout (GTK_BUTTON_BOX (dialog_action_area1),
++#if defined (MAEMO_GTK)
+ GTK_BUTTONBOX_CENTER);
++#else
++ GTK_BUTTONBOX_DEFAULT_STYLE);
++#endif
+
+ okButton = gtk_dialog_add_button (GTK_DIALOG (dialog) ,DEVICELOCK_OK,
+ GTK_RESPONSE_OK);
diff --git a/recipes/maemo4/libhildon_1.99.0.bb b/recipes/maemo4/libhildon_1.99.0.bb
new file mode 100644
index 0000000000..4757d140b2
--- /dev/null
+++ b/recipes/maemo4/libhildon_1.99.0.bb
@@ -0,0 +1,11 @@
+require libhildon.inc
+
+DEPENDS += "libpng libxt libxi"
+
+SRC_URI = "\
+ http://repository.maemo.org/pool/maemo4.0/free/source/libh/${PN}/${PN}_${PV}-1.tar.gz \
+ file://libhildon-buildfix.patch;patch=1 \
+ "
+
+
+
diff --git a/recipes/maemo4/libhildonfm.inc b/recipes/maemo4/libhildonfm.inc
new file mode 100644
index 0000000000..26c1555e52
--- /dev/null
+++ b/recipes/maemo4/libhildonfm.inc
@@ -0,0 +1,27 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia hildon filemanager library"
+
+DEPENDS = "gtk+ libxi libxt libpng gconf dbus libosso libhildon hildon-thumbnail libhildonmime osso-gwconnect mce-dev"
+
+inherit autotools pkgconfig lib_package
+
+do_configure_prepend() {
+ # remove Werror from OSSO_CFLAGS
+ sed -i s:-Werror::g configure.ac
+
+ touch gtk-doc.make
+}
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ autotools_stage_all
+ if [ ! -d ${STAGING_INCDIR}/hildon-widgets ]
+ then
+ mkdir -p ${STAGING_INCDIR}/hildon-widgets
+ fi
+
+ ln -sf ${STAGING_INCDIR}/hildon-fm-2/hildon/* ${STAGING_INCDIR}/hildon-widgets/
+}
+
+
diff --git a/recipes/maemo4/libhildonfm/libhildonfm-gtkmaemo-ifdef.patch b/recipes/maemo4/libhildonfm/libhildonfm-gtkmaemo-ifdef.patch
new file mode 100644
index 0000000000..6af13d24bf
--- /dev/null
+++ b/recipes/maemo4/libhildonfm/libhildonfm-gtkmaemo-ifdef.patch
@@ -0,0 +1,133 @@
+Index: libhildonfm-1.9.46/hildon-fm/hildon-file-chooser-dialog.c
+===================================================================
+--- libhildonfm-1.9.46.orig/hildon-fm/hildon-file-chooser-dialog.c 2007-10-16 10:11:59.000000000 +0200
++++ libhildonfm-1.9.46/hildon-fm/hildon-file-chooser-dialog.c 2008-02-14 08:24:41.000000000 +0100
+@@ -192,6 +192,7 @@
+ return (first_digit << 4) | second_digit;
+ }
+
++#ifdef USE_MAEMO_GTK
+ static void chooser_entry_invalid_input_cb (GtkEntry *entry,
+ GtkInvalidInputType inv_type,
+ gpointer user_data)
+@@ -202,6 +203,7 @@
+ HCS("ckdg_ib_maximum_characters_reached"));
+ }
+ }
++#endif
+
+ static gchar *
+ g_unescape_uri_string (const char *escaped,
+@@ -1838,7 +1840,9 @@
+ g_object_class_install_property(gobject_class, PROP_SELECTION_MODE, pspec);
+
+
++#ifdef USE_MAEMO_GTK
+ hildon_gtk_file_chooser_install_properties(gobject_class);
++#endif
+ }
+
+ static void hildon_file_chooser_dialog_sort_changed(GtkWidget * item,
+@@ -1975,10 +1979,10 @@
+ g_signal_connect( priv->entry_name, "changed",
+ G_CALLBACK( hildon_file_chooser_entry_changed ),
+ self );
+-
++#ifdef USE_MAEMO_GTK
+ g_signal_connect(priv->entry_name, "invalid-input",
+ G_CALLBACK(chooser_entry_invalid_input_cb), self);
+-
++#endif
+ priv->hbox_location = gtk_hbox_new(FALSE, HILDON_MARGIN_DEFAULT);
+ priv->hbox_items = gtk_hbox_new(FALSE, HILDON_MARGIN_DEFAULT);
+ priv->image_location = gtk_image_new();
+Index: libhildonfm-1.9.46/hildon-fm/hildon-file-selection.c
+===================================================================
+--- libhildonfm-1.9.46.orig/hildon-fm/hildon-file-selection.c 2007-10-16 10:11:59.000000000 +0200
++++ libhildonfm-1.9.46/hildon-fm/hildon-file-selection.c 2008-02-14 08:21:31.000000000 +0100
+@@ -2036,6 +2036,7 @@
+ g_object_set(cell, "text", buffer, "sensitive", sensitive, NULL);
+ }
+
++#ifdef USE_MAEMO_GTK
+ static void hildon_file_selection_navigation_pane_context(GtkWidget *
+ widget,
+ gpointer data)
+@@ -2052,6 +2053,7 @@
+ ULOG_DEBUG(__FUNCTION__);
+ g_signal_emit(data, signal_content_pane_context_menu, 0);
+ }
++#endif
+
+ static gboolean hildon_file_selection_on_content_pane_key(GtkWidget *
+ widget,
+@@ -2200,6 +2202,7 @@
+ }
+ }
+
++#ifdef USE_MAEMO_GTK
+ static gboolean
+ tap_and_hold_query (gpointer self, guint signal_id)
+ {
+@@ -2224,6 +2227,7 @@
+ {
+ return tap_and_hold_query (self, signal_navigation_pane_context_menu);
+ }
++#endif
+
+ static void hildon_file_selection_create_thumbnail_view(HildonFileSelection
+ * self)
+@@ -2277,7 +2281,7 @@
+ g_signal_connect_object(tree, "key-press-event",
+ G_CALLBACK(hildon_file_selection_on_content_pane_key),
+ self, 0);
+-
++#ifdef USE_MAEMO_GTK
+ gtk_widget_tap_and_hold_setup(GTK_WIDGET(tree), NULL, NULL,
+ GTK_TAP_AND_HOLD_NONE | GTK_TAP_AND_HOLD_NO_INTERNALS);
+ g_signal_connect_object (tree, "tap-and-hold-query",
+@@ -2286,7 +2290,7 @@
+ g_signal_connect_object(tree, "tap-and-hold",
+ G_CALLBACK
+ (hildon_file_selection_content_pane_context), self, 0);
+-
++#endif
+ g_signal_connect_object(tree, "notify::has-focus",
+ G_CALLBACK(content_pane_focus), self, 0);
+ }
+@@ -2397,7 +2401,7 @@
+ (selection, "changed",
+ G_CALLBACK (hildon_file_selection_content_pane_selection_changed),
+ self, 0);
+-
++#ifdef USE_MAEMO_GTK
+ gtk_widget_tap_and_hold_setup(GTK_WIDGET(tree), NULL, NULL,
+ GTK_TAP_AND_HOLD_NONE | GTK_TAP_AND_HOLD_NO_INTERNALS);
+ g_signal_connect_object (tree, "tap-and-hold-query",
+@@ -2406,7 +2410,7 @@
+ g_signal_connect_object(tree, "tap-and-hold",
+ G_CALLBACK
+ (hildon_file_selection_content_pane_context), self, 0);
+-
++#endif
+ g_signal_connect_object(tree, "key-press-event",
+ G_CALLBACK(hildon_file_selection_on_content_pane_key),
+ self, 0);
+@@ -2492,7 +2496,7 @@
+ g_signal_connect_object(selection, "changed",
+ G_CALLBACK(hildon_file_selection_selection_changed),
+ self, 0);
+-
++#ifdef USE_MAEMO_GTK
+ gtk_widget_tap_and_hold_setup(GTK_WIDGET(self->priv->dir_tree), NULL,
+ NULL, GTK_TAP_AND_HOLD_NONE | GTK_TAP_AND_HOLD_NO_INTERNALS);
+ g_signal_connect_object (self->priv->dir_tree, "tap-and-hold-query",
+@@ -2502,7 +2506,7 @@
+ G_CALLBACK
+ (hildon_file_selection_navigation_pane_context),
+ self, 0);
+-
++#endif
+ g_signal_connect_object(self->priv->dir_tree, "key-press-event",
+ G_CALLBACK
+ (hildon_file_selection_on_navigation_pane_key), self, 0);
diff --git a/recipes/maemo4/libhildonfm_1.9.46.bb b/recipes/maemo4/libhildonfm_1.9.46.bb
new file mode 100644
index 0000000000..67816fb496
--- /dev/null
+++ b/recipes/maemo4/libhildonfm_1.9.46.bb
@@ -0,0 +1,9 @@
+require libhildonfm.inc
+
+PR = "r1"
+
+SRC_URI = "\
+ http://repository.maemo.org/pool/maemo4.0/free/source/libh/${PN}/${PN}_${PV}.tar.gz \
+ file://libhildonfm-gtkmaemo-ifdef.patch;patch=1 \
+ "
+
diff --git a/recipes/maemo4/libhildonhelp.inc b/recipes/maemo4/libhildonhelp.inc
new file mode 100644
index 0000000000..6ce0f0ac6f
--- /dev/null
+++ b/recipes/maemo4/libhildonhelp.inc
@@ -0,0 +1,17 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia hildon help library"
+
+DEPENDS = "gtk+ intltool-native libxml2 gtkhtml-3.8 libosso libhildon"
+
+inherit autotools pkgconfig lib_package
+
+do_configure_prepend() {
+ # remove Werror from OSSO_CFLAGS
+ sed -i s:-Werror::g configure.ac
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/maemo4/libhildonhelp_1.9.6.bb b/recipes/maemo4/libhildonhelp_1.9.6.bb
new file mode 100644
index 0000000000..6b6e23d951
--- /dev/null
+++ b/recipes/maemo4/libhildonhelp_1.9.6.bb
@@ -0,0 +1,6 @@
+require libhildonhelp.inc
+
+PR = "r0"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo4.0/free/source/libh/${PN}/${PN}_${PV}-1.tar.gz"
+
diff --git a/recipes/maemo4/libhildonmime.inc b/recipes/maemo4/libhildonmime.inc
new file mode 100644
index 0000000000..12c74a334b
--- /dev/null
+++ b/recipes/maemo4/libhildonmime.inc
@@ -0,0 +1,17 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia hildon mime library"
+
+DEPENDS = "libosso gnome-vfs"
+
+inherit autotools pkgconfig lib_package
+
+do_configure_prepend() {
+ # remove Werror from OSSO_CFLAGS
+ sed -i s:-Werror::g configure.in
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/maemo4/libhildonmime_1.10.0.bb b/recipes/maemo4/libhildonmime_1.10.0.bb
new file mode 100644
index 0000000000..2198f6b2ee
--- /dev/null
+++ b/recipes/maemo4/libhildonmime_1.10.0.bb
@@ -0,0 +1,9 @@
+require libhildonmime.inc
+
+DEPENDS += "osso-gnome-vfs2"
+
+PR = "r0"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo4.0/free/source/libh/${PN}/${PN}_${PV}-1.tar.gz"
+
+EXTRA_OECONF += "--with-compile-warnings=no"
diff --git a/recipes/maemo4/libhildonmime_1.9.5.bb b/recipes/maemo4/libhildonmime_1.9.5.bb
new file mode 100644
index 0000000000..1a06284314
--- /dev/null
+++ b/recipes/maemo4/libhildonmime_1.9.5.bb
@@ -0,0 +1,6 @@
+require libhildonmime.inc
+
+PR = "r0"
+
+SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/universe/libh/libhildonmime/libhildonmime_${PV}-1ubuntu1.tar.gz"
+
diff --git a/recipes/maemo4/libosso-gsf_1.11.10.4.bb b/recipes/maemo4/libosso-gsf_1.11.10.4.bb
new file mode 100644
index 0000000000..6adbc0f6e3
--- /dev/null
+++ b/recipes/maemo4/libosso-gsf_1.11.10.4.bb
@@ -0,0 +1,21 @@
+LICENSE = "GPL"
+
+PR = "r1"
+
+DEPENDS = "glib-2.0 zlib"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo4.0/free/source/libo/${PN}_${PV}-1.tar.gz"
+
+inherit autotools pkgconfig
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/maemo4/libosso-help_2.1.2.bb b/recipes/maemo4/libosso-help_2.1.2.bb
new file mode 100644
index 0000000000..8a35e1a4f0
--- /dev/null
+++ b/recipes/maemo4/libosso-help_2.1.2.bb
@@ -0,0 +1,24 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia osso help library"
+
+DEPENDS = "libhildonhelp libosso gtkhtml-3.8 libxml2 "
+
+PR = "r0"
+
+SRC_URI = "http://repository.maemo.org/pool/sardine-experimental/main.disabled/source/libo/libosso-help/libosso-help_${PV}-2.tar.gz"
+
+inherit autotools pkgconfig lib_package
+
+S = "${WORKDIR}/2.1.2-2"
+
+do_configure_prepend() {
+ # remove Werror from OSSO_CFLAGS
+ sed -i s:-Werror::g configure.ac
+ sed -i -e s:AC_CONFIG_SRCDIR:#AC_CONFIG_SRCDIR:g configure.ac
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/maemo4/libosso.inc b/recipes/maemo4/libosso.inc
new file mode 100644
index 0000000000..7af653ed44
--- /dev/null
+++ b/recipes/maemo4/libosso.inc
@@ -0,0 +1,19 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia OSSO IPC library"
+
+DEPENDS = "dbus-glib glib-2.0 mce-dev"
+
+inherit autotools pkgconfig lib_package
+
+do_configure_prepend() {
+ # Remove Werror from OSSO_CFLAGS since the source
+ # contains many implicit (const void *) to (void *)
+ # conversions.
+ sed -i s:-Werror::g configure.ac
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/maemo4/libosso/libosso-buildfix.patch b/recipes/maemo4/libosso/libosso-buildfix.patch
new file mode 100644
index 0000000000..adb0ca6b5f
--- /dev/null
+++ b/recipes/maemo4/libosso/libosso-buildfix.patch
@@ -0,0 +1,64 @@
+Index: libosso-2.13/src/osso-hw.c
+===================================================================
+--- libosso-2.13.orig/src/osso-hw.c 2008-02-13 12:55:17.000000000 +0100
++++ libosso-2.13/src/osso-hw.c 2008-02-13 13:02:55.000000000 +0100
+@@ -23,6 +23,9 @@
+ * 02110-1301 USA
+ */
+
++#define _GNU_SOURCE
++#include <string.h>
++
+ #include "osso-internal.h"
+ #include "osso-hw.h"
+ #include "osso-mem.h"
+@@ -635,7 +638,7 @@
+ (*cb)((muali_context_t*)osso, &info, data->user_data);
+
+ if (info.args != NULL) {
+- free(info.args);
++ free((void *) info.args);
+ info.args = NULL;
+ }
+ }
+@@ -762,7 +765,7 @@
+ (*cb)((muali_context_t*)osso, &info, data->user_data);
+
+ if (info.args != NULL) {
+- free(info.args);
++ free((void *) info.args);
+ info.args = NULL;
+ }
+ }
+Index: libosso-2.13/src/osso-rpc.c
+===================================================================
+--- libosso-2.13.orig/src/osso-rpc.c 2008-02-13 13:03:13.000000000 +0100
++++ libosso-2.13/src/osso-rpc.c 2008-02-13 13:06:05.000000000 +0100
+@@ -997,7 +997,8 @@
+ int *serial)
+ {
+ int i;
+- char buf[20], *p;
++ char buf[20];
++ const char *p;
+
+ /* get bus type */
+ for (i = 0, p = id; *p != ','; ++p, ++i) {
+@@ -1101,7 +1102,7 @@
+ (*cb)((muali_context_t*)osso, &info, cb_data->user_data);
+
+ if (info.args != NULL) {
+- free(info.args);
++ free((void *) info.args);
+ info.args = NULL;
+ }
+ }
+@@ -1410,7 +1411,7 @@
+ cb_data->message_id = (long)msg_serial;
+
+ cb_data->user_cb = reply_handler;
+- cb_data->user_data = user_data;
++ cb_data->user_data = (void *) user_data;
+ cb_data->match_rule = NULL;
+ cb_data->event_type = 0;
+ cb_data->bus_type = bus_type;
diff --git a/recipes/maemo4/libosso/libosso-dont-use-inline.patch b/recipes/maemo4/libosso/libosso-dont-use-inline.patch
new file mode 100644
index 0000000000..d3878308c2
--- /dev/null
+++ b/recipes/maemo4/libosso/libosso-dont-use-inline.patch
@@ -0,0 +1,47 @@
+--- libosso-2.13/src/osso-init.c.orig 2008-09-22 12:56:49.000000000 -0700
++++ libosso-2.13/src/osso-init.c 2008-09-22 12:57:22.000000000 -0700
+@@ -657,7 +657,8 @@
+ return DBUS_HANDLER_RESULT_NOT_YET_HANDLED;
+ }
+
+-inline int __attribute__ ((visibility("hidden")))
++//inline int __attribute__ ((visibility("hidden")))
++static int
+ muali_convert_msgtype(int t)
+ {
+ switch (t) {
+--- libosso-2.13/src/osso-internal.h.orig 2008-09-22 12:57:39.000000000 -0700
++++ libosso-2.13/src/osso-internal.h 2008-09-22 12:58:13.000000000 -0700
+@@ -209,7 +209,8 @@
+ # define dprint(f, a...)
+ # endif /* LIBOSSO_DEBUG */
+
+-inline int __attribute__ ((visibility("hidden")))
++//inline int __attribute__ ((visibility("hidden")))
++static int
+ muali_convert_msgtype(int t);
+
+ muali_arg_t* _get_muali_args(DBusMessageIter *iter);
+@@ -297,7 +298,8 @@
+ _muali_parse_id(const char *id, muali_bus_type *bus, char *sender,
+ int *serial);
+
+-inline void __attribute__ ((visibility("hidden")))
++//inline void __attribute__ ((visibility("hidden")))
++static void
+ _muali_make_id(muali_bus_type bus, const char *sender, int serial, char *id);
+
+ #endif /* OSSO_INTERNAL_H_ */
+--- libosso-2.13/src/osso-rpc.c.orig 2008-09-22 12:58:53.000000000 -0700
++++ libosso-2.13/src/osso-rpc.c 2008-09-22 12:59:42.000000000 -0700
+@@ -1026,7 +1026,8 @@
+ *serial = atoi(buf);
+ }
+
+-inline void __attribute__ ((visibility("hidden")))
++//inline void __attribute__ ((visibility("hidden")))
++static void
+ _muali_make_id(muali_bus_type bus, const char *sender, int serial, char *id)
+ {
+ snprintf(id, MAX_MSGID_LEN, "%d,%s,%d", bus, sender, serial);
+
diff --git a/recipes/maemo4/libosso_2.13.bb b/recipes/maemo4/libosso_2.13.bb
new file mode 100644
index 0000000000..25ee9aac15
--- /dev/null
+++ b/recipes/maemo4/libosso_2.13.bb
@@ -0,0 +1,17 @@
+require libosso.inc
+
+PR = "r1"
+
+SRC_URI = "\
+ http://repository.maemo.org/pool/maemo4.0/free/source/libo/${PN}/${PN}_${PV}-1.1fix.tar.gz \
+ file://libosso-buildfix.patch;patch=1 \
+ file://libosso-dont-use-inline.patch;patch=1 \
+ "
+
+PACKAGES += "${PN}-outo ${PN}-outo-dev ${PN}-outo-dbg ${PN}-outo-bin-dbg ${PN}-outo-bin"
+
+FILES_${PN}-outo = "${libdir}/outo/lib*.so"
+FILES_${PN}-outo-dev = "${libdir}/outo/*.la ${libdir}/outo/*.a"
+FILES_${PN}-outo-dbg = "${libdir}/outo/.debug/lib*.so
+FILES_${PN}-outo-bin-dbg = "${libdir}/outo/.debug/*bin"
+FILES_${PN}-outo-bin = "${libdir}/outo/*bin ${libdir}/outo/mimedummy.doc"
diff --git a/recipes/maemo4/mce-dev.inc b/recipes/maemo4/mce-dev.inc
new file mode 100644
index 0000000000..55db0d69da
--- /dev/null
+++ b/recipes/maemo4/mce-dev.inc
@@ -0,0 +1,22 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia MCE headers"
+
+inherit pkgconfig
+
+do_compile() {
+ # Nothing to compile in this recipe. These are just headers.
+ :
+}
+
+do_install() {
+ install -d ${D}${prefix}/include
+ install -d ${D}${libdir}/pkgconfig
+
+ cp -pPr include/* ${D}${prefix}/include
+ cp *.pc ${D}${libdir}/pkgconfig/
+}
+
+do_stage() {
+ cp -pPr include/* ${STAGING_INCDIR}/
+}
+
diff --git a/recipes/maemo4/mce-dev_1.6.3.bb b/recipes/maemo4/mce-dev_1.6.3.bb
new file mode 100644
index 0000000000..66e238c109
--- /dev/null
+++ b/recipes/maemo4/mce-dev_1.6.3.bb
@@ -0,0 +1,7 @@
+require mce-dev.inc
+
+PR = "r0"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo4.0/free/source/m/mce-dev/mce-dev_${PV}.tar.gz"
+
+
diff --git a/recipes/maemo4/osso-gnome-vfs2/gnome-vfs-no-kerberos.patch b/recipes/maemo4/osso-gnome-vfs2/gnome-vfs-no-kerberos.patch
new file mode 100644
index 0000000000..e25ecdd66f
--- /dev/null
+++ b/recipes/maemo4/osso-gnome-vfs2/gnome-vfs-no-kerberos.patch
@@ -0,0 +1,51 @@
+removes kerberos completely to avoid conflicts with installed kerberos
+--- configure.in.orig 2007-01-05 19:42:26.418541610 +0200
++++ configure.in 2007-01-05 19:42:56.604261797 +0200
+@@ -436,47 +436,6 @@
+ ])
+ AM_CONDITIONAL(HAVE_CDDA, test $have_cdda = yes)
+ AC_SUBST(CDDA_LIBS)
+-
+-dnl GSSAPI
+-dnl Check for Kerberos installation
+-have_gssapi=no
+-AC_PATH_PROG([KRB5_CONFIG], krb5-config, none, $PATH:/usr/kerberos/bin)
+-
+-if test "x$KRB5_CONFIG" != "xnone"; then
+- GSSAPI_LIBS="`${KRB5_CONFIG} --libs gssapi`"
+- GSSAPI_CFLAGS="`${KRB5_CONFIG} --cflags gssapi`"
+-
+- saved_CPPFLAGS="$CPPFLAGS"
+- saved_LIBS="$LIBS"
+- LIBS="$LIBS $GSSAPI_LIBS"
+- CPPFLAGS="$CPPFLAGS $GSSAPI_CFLAGS"
+- # MIT and Heimdal put gssapi.h in different places
+- AC_CHECK_HEADERS(gssapi/gssapi.h gssapi.h, [
+- AC_CHECK_FUNCS(gss_init_sec_context, [
+- AC_MSG_NOTICE([GSSAPI authentication support enabled])
+- AC_DEFINE(HAVE_GSSAPI, 1, [Define if GSSAPI support is enabled])
+- AC_CHECK_HEADERS(gssapi/gssapi_generic.h)
+- have_gssapi=yes
+-
+- # MIT Kerberos lacks GSS_C_NT_HOSTBASED_SERVICE
+- AC_CHECK_DECL([GSS_C_NT_HOSTBASED_SERVICE],,
+- [AC_DEFINE([GSS_C_NT_HOSTBASED_SERVICE], gss_nt_service_name,
+- [Define if GSS_C_NT_HOSTBASED_SERVICE is not defined otherwise])
+- ], [
+- #ifdef HAVE_GSSAPI_GSSAPI_H
+- #include <gssapi/gssapi.h>
+- #else
+- #include <gssapi.h>
+- #endif
+- ])
+- ])
+- break
+- ])
+- LIBS="$saved_LIBS"
+- CPPFLAGS="$saved_CPPFLAGS"
+-fi
+-AC_SUBST(GSSAPI_LIBS)
+-AC_SUBST(GSSAPI_CFLAGS)
+
+ dnl ******************************
+ dnl http-method (neon checks)
diff --git a/recipes/maemo4/osso-gnome-vfs2_2.16.3.bb b/recipes/maemo4/osso-gnome-vfs2_2.16.3.bb
new file mode 100644
index 0000000000..4a0be7a9be
--- /dev/null
+++ b/recipes/maemo4/osso-gnome-vfs2_2.16.3.bb
@@ -0,0 +1,51 @@
+LICENSE = "GPL"
+DEPENDS = "libxml2 gconf gnutls avahi dbus bzip2 gnome-mime-data zlib"
+RRECOMMENDS = "gnome-vfs-plugin-file gnome-mime-data shared-mime-info"
+
+DESCRIPTION = "gnomevfs - osso variant"
+
+PR = "r0"
+
+inherit gnome
+
+SRC_URI = "\
+ http://repository.maemo.org/pool/maemo4.0/free/source/o/${PN}/${PN}_${PV}-1osso31.tar.gz \
+ file://gnome-vfs-no-kerberos.patch;patch=1;pnum=0 \
+ "
+
+
+EXTRA_OECONF = " \
+ --disable-openssl \
+ --enable-gnutls \
+ --enable-avahi \
+ --with-samba-includes=${STAGING_INCDIR} \
+ --enable-more-warnings=no \
+ "
+
+do_configure_prepend() {
+ # remove Werror from VFS_CFLAGS
+ sed -i s:-Werror::g configure.in
+
+ # G_GNUC_FUNCTION is deprecated
+ sed -i -e s,-DG_DISABLE_DEPRECATED,-DSED_ROCKS_DUDE, */Makefile.am
+
+ touch gtk-doc.make
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES_DYNAMIC = "osso-gnome-vfs-plugin-*"
+
+python populate_packages_prepend () {
+ print bb.data.getVar('FILES_osso-gnome-vfs', d, 1)
+
+ plugindir = bb.data.expand('${libdir}/gnome-vfs-2.0/modules/', d)
+ do_split_packages(d, plugindir, '^lib(.*)\.so$', 'osso-gnome-vfs-plugin-%s', 'OSSO GNOME VFS plugin for %s')
+}
+
+FILES_${PN} += "${datadir}/dbus-1"
+FILES_${PN}-dbg += " ${libdir}/gnome-vfs-2.0/modules/.debug/lib*.so"
+FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/include ${libdir}/gnome-vfs-2.0/modules/lib*.a ${libdir}/gnome-vfs-2.0/modules/lib*.la"
+FILES_${PN}-doc += " ${datadir}/gtk-doc"
diff --git a/recipes/maemo4/osso-gwconnect.inc b/recipes/maemo4/osso-gwconnect.inc
new file mode 100644
index 0000000000..8781b1eb25
--- /dev/null
+++ b/recipes/maemo4/osso-gwconnect.inc
@@ -0,0 +1,17 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia osso connection library"
+
+DEPENDS = "libosso"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ # remove Werror from OSSO_CFLAGS
+ sed -i s:-Werror::g configure.ac
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/maemo4/osso-gwconnect_1.0.12.bb b/recipes/maemo4/osso-gwconnect_1.0.12.bb
new file mode 100644
index 0000000000..1a499687f8
--- /dev/null
+++ b/recipes/maemo4/osso-gwconnect_1.0.12.bb
@@ -0,0 +1,8 @@
+require osso-gwconnect.inc
+
+DEPENDS += "libhildon bluez-libs"
+
+PR = "r0"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo4.0/free/source/o/${PN}/${PN}_${PV}.tar.gz"
+
diff --git a/recipes/maemo4/osso-ic-oss/dbus-api-update.patch b/recipes/maemo4/osso-ic-oss/dbus-api-update.patch
new file mode 100644
index 0000000000..425f959d79
--- /dev/null
+++ b/recipes/maemo4/osso-ic-oss/dbus-api-update.patch
@@ -0,0 +1,33 @@
+--- /tmp/osso-iap-connect.c 2007-08-07 12:06:51.000000000 +0200
++++ osso-ic-oss-1.0.4/examples/osso-iap-connect.c 2007-08-07 12:07:32.698400000 +0200
+@@ -276,7 +276,7 @@
+ g_main_loop_run(ctxt.loop);
+
+ /* Clean up */
+- dbus_connection_disconnect(conn);
++ dbus_connection_close(conn);
+ dbus_connection_unref(conn);
+
+ g_main_loop_unref(ctxt.loop);
+--- /tmp/ic-compat-preload.c 2007-08-07 12:06:57.000000000 +0200
++++ osso-ic-oss-1.0.4/src/ic-compat-preload.c 2007-08-07 12:07:40.268400000 +0200
+@@ -140,7 +140,7 @@
+ return NULL;
+
+ if (!dbus_bus_register(connection, NULL)) {
+- dbus_connection_disconnect(connection);
++ dbus_connection_close(connection);
+ dbus_connection_unref(connection);
+ connection = NULL;
+ return NULL;
+--- /tmp/ic-api.c 2007-08-07 12:06:57.000000000 +0200
++++ osso-ic-oss-1.0.4/src/ic-api.c 2007-08-07 12:07:55.628400000 +0200
+@@ -145,7 +145,7 @@
+ if (dbus_connection_register_object_path(
+ connection, ICD_DBUS_PATH,
+ &icd_vtable, arg) == FALSE) {
+- dbus_connection_disconnect(connection);
++ dbus_connection_close(connection);
+ dbus_connection_unref(connection);
+ connection = NULL;
+ return NULL;
diff --git a/recipes/maemo4/osso-ic-oss_1.0.4.bb b/recipes/maemo4/osso-ic-oss_1.0.4.bb
new file mode 100644
index 0000000000..04ec84e4e2
--- /dev/null
+++ b/recipes/maemo4/osso-ic-oss_1.0.4.bb
@@ -0,0 +1,25 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia osso-ic library"
+
+DEPENDS = "dbus-glib glib-2.0 libosso"
+
+PR = "r1"
+
+# No sources for that Maemo revision any more.
+SRC_URI = "http://repository.maemo.org/pool/bora/free/source/${PN}_${PV}.tar.gz \
+ file://dbus-api-update.patch;patch=1 "
+
+inherit autotools pkgconfig lib_package
+
+do_configure_prepend() {
+ # remove Werror from OSSO_CFLAGS
+ sed -i s:-Werror::g configure.ac
+}
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ autotools_stage_all
+}
+
+