summaryrefslogtreecommitdiffstats
path: root/recipes/mamona
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-10 15:58:51 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-10 21:50:21 +0200
commit719de6735f6d14ad05f231df900795bbb19a2810 (patch)
tree9ca5895db50f8a6ded61922f9637c072f8ccce21 /recipes/mamona
parentf91c6bd3df717860d852e717ffab24eba48fd00f (diff)
downloadopenembedded-719de6735f6d14ad05f231df900795bbb19a2810.tar.gz
recipes: conform to OE packaging guidelines with RSUGGESTS/RPROVIDES/RCONFLICTS/RREPLACES
* even worse than last RDEPENDS/RRECOMMENDS change, because now ie: opkg info coreutils-doc Provides: textutils, shellutils, fileutils Replaces: textutils, shellutils, fileutils Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/mamona')
-rw-r--r--recipes/mamona/bash-noemu_3.2.bb4
-rw-r--r--recipes/mamona/binutils-noemu_2.17.50.0.5.bb4
-rw-r--r--recipes/mamona/binutils-noemu_2.18.bb4
-rw-r--r--recipes/mamona/gcc-noemu_4.1.1.bb4
-rw-r--r--recipes/mamona/gcc-noemu_4.1.2.bb4
5 files changed, 10 insertions, 10 deletions
diff --git a/recipes/mamona/bash-noemu_3.2.bb b/recipes/mamona/bash-noemu_3.2.bb
index 4b517ec95d..1a1f99159e 100644
--- a/recipes/mamona/bash-noemu_3.2.bb
+++ b/recipes/mamona/bash-noemu_3.2.bb
@@ -1,8 +1,8 @@
require ../bash/bash.inc
PR = "r1"
-RCONFLICTS = "bash"
-RREPLACES = "bash"
+RCONFLICTS_${PN} = "bash"
+RREPLACES_${PN} = "bash"
SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
file://001-005.patch \
diff --git a/recipes/mamona/binutils-noemu_2.17.50.0.5.bb b/recipes/mamona/binutils-noemu_2.17.50.0.5.bb
index 2ba6b44304..189f13e35a 100644
--- a/recipes/mamona/binutils-noemu_2.17.50.0.5.bb
+++ b/recipes/mamona/binutils-noemu_2.17.50.0.5.bb
@@ -2,8 +2,8 @@ require ../binutils/binutils.inc
PR = "r1"
-RCONFLICTS = "binutils"
-RREPLACES = "binutils"
+RCONFLICTS_${PN} = "binutils"
+RREPLACES_${PN} = "binutils"
SRC_URI = \
"${KERNELORG_MIRROR}/pub/linux/devel/binutils/binutils-${PV}.tar.bz2 \
diff --git a/recipes/mamona/binutils-noemu_2.18.bb b/recipes/mamona/binutils-noemu_2.18.bb
index 71ee3842b3..e1ac7fcaf6 100644
--- a/recipes/mamona/binutils-noemu_2.18.bb
+++ b/recipes/mamona/binutils-noemu_2.18.bb
@@ -2,8 +2,8 @@ PR = "r0"
require ../binutils/binutils.inc
-RCONFLICTS = "binutils"
-RREPLACES = "binutils"
+RCONFLICTS_${PN} = "binutils"
+RREPLACES_${PN} = "binutils"
RCONFLICTS_binutils-noemu-symlinks = "binutils-symlinks"
RREPLACES_binutils-noemu-symlinks = "binutils-symlinks"
diff --git a/recipes/mamona/gcc-noemu_4.1.1.bb b/recipes/mamona/gcc-noemu_4.1.1.bb
index bd00ee1fa7..f27163109b 100644
--- a/recipes/mamona/gcc-noemu_4.1.1.bb
+++ b/recipes/mamona/gcc-noemu_4.1.1.bb
@@ -4,8 +4,8 @@ HOMEPAGE = "http://www.gnu.org/software/gcc/"
SECTION = "devel"
LICENSE = "GPL"
-RCONFLICTS = "gcc"
-RREPLACES = "gcc"
+RCONFLICTS_${PN} = "gcc"
+RREPLACES_${PN} = "gcc"
inherit autotools gettext
diff --git a/recipes/mamona/gcc-noemu_4.1.2.bb b/recipes/mamona/gcc-noemu_4.1.2.bb
index 05cdeb003b..835dcbd825 100644
--- a/recipes/mamona/gcc-noemu_4.1.2.bb
+++ b/recipes/mamona/gcc-noemu_4.1.2.bb
@@ -6,8 +6,8 @@ LICENSE = "GPL"
# remember to increment the -cross .bb PR too.
PR = "r0"
-RCONFLICTS = "gcc"
-RREPLACES = "gcc"
+RCONFLICTS_${PN} = "gcc"
+RREPLACES_${PN} = "gcc"
RCONFLICTS_g++-noemu = "g++"
RREPLACES_g++-noemu = "g++"
RCONFLICTS_cpp-noemu = "cpp"